Wacom Volito

Getting your soundcard to work, using Debian on non-i386 hardware, etc

Wacom Volito

Postby skejoe » 2007-03-31 19:13

I've got some big troubles with installing my Wacom Volito tablet.
I've tried to follow the documentation on linuxwacom.sourceforge.net but that didn't help me very much. Then I tried to
Code: Select all
dpkg-reconfigure wacom-kernel-source

and wrote the path to my linux-headers(/usr/src/linux-headers-2.6.18-4-686). Then it started to configure and compile the package but the following messages caused the installation to stop:

Code: Select all
   1.
      ./configure     --disable-libwacomxi    \
   2.
                              --disable-wacomdrv      \
   3.
                              --disable-libwacomcfg   \
   4.
                              --disable-wacdump       \
   5.
                              --disable-xidump        \
   6.
                              --disable-xsetwacom     \
   7.
                              --enable-wacom          \
   8.
                              --with-kernel=/usr/src/linux-headers-2.6.18-4-686
   9.
       
  10.
      ....
  11.
      ....
  12.
       
  13.
      checking for arch type... i486-linux-gnu
  14.
      checking for kernel type... Linux
  15.
      checking for linux-based kernel... yes
  16.
      checking for valid kernel source tree... ok
  17.
      checking for kernel module versioning... yes
  18.
      ***
  19.
      *** WARNING:
  20.
      ***  is not supported by this pachage
  21.
      *** Kernel modules will not be built
  22.
      ***
  23.
      no
  24.
       
  25.
      ....
  26.
      ....
  27.
       
  28.
      ***
  29.
      *** WARNING:
  30.
      *** Unable to compile wacom.o without kernel build environment
  31.
      *** wacom.o will not be built
  32.
      ***
  33.
       
  34.
      ....
  35.
      ....
  36.
       
  37.
      ----------------------------------------
  38.
        BUILD ENVIRONMENT:
  39.
             architecture - i486-linux-gnu
  40.
             linux kernel - yes 2.4
  41.
        module versioning - no
  42.
            kernel source - no /usr/src/linux-headers-2.6.18-4-686
  43.
                 Xorg SDK - yes /usr/include/xorg
  44.
                XSERVER64 - no
  45.
                 dlloader - yes
  46.
                     XLib - yes /usr/lib
  47.
                      TCL - yes /usr/include/tcl8.4/
  48.
                       TK - yes /usr/include/tcl8.4/
  49.
                  ncurses - yes
  50.
       
  51.
        BUILD OPTIONS:
  52.
                  wacom.o - no
  53.
                  wacdump - no
  54.
                   xidump - no
  55.
              libwacomcfg - no
  56.
               libwacomxi - no
  57.
                xsetwacom - no
  58.
                    hid.o - no
  59.
               usbmouse.o - no
  60.
                  evdev.o - no
  61.
               mousedev.o - no
  62.
                  input.o - no
  63.
              tabletdev.o - no
  64.
             wacom_drv.so - no
  65.
              wacom_drv.o - no
  66.
      ----------------------------------------
  67.
       
  68.
      ....
  69.
      ....
  70.
       
  71.
      cp: kan ikke udføre stat() './temp/wacom.ko': Ingen sådan fil eller filkatalog
  72.
      dh_install: command returned error code 256
  73.
      make[1]: *** [binary-modules] Fejl 1
  74.
      make[1]: Forlader katalog '/usr/src/modules/wacom'
  75.
      make: *** [kdist_image] Fejl 2

(http://pastebin.antistof.dk/163)

What's the problem and how do I fix it?

I'm using a 2.6.18-4-686 kernel and Debian Etch
skejoe
 

Postby thamarok » 2007-04-01 07:42

Hmm... I have a Wacom Volito2 USB and I just plug it in and it works after modprobe wacom :roll:
However, make sure you have this installed: apt-get install xserver-xorg-input-wacom
thamarok
 

Postby finferflu » 2007-04-17 16:08

I have the same problem. My Volito 2 is not recognised. I have installed all the needed packages, xserver-xorg-input-wacom and wacom-tools, tried to configure xorg.conf, but it seems like nothing is working...
finferflu
 
Posts: 8
Joined: 2007-04-12 17:59
Location: Manchester, UK

Postby thamarok » 2007-04-17 20:12

finferflu wrote:I have the same problem. My Volito 2 is not recognised. I have installed all the needed packages, xserver-xorg-input-wacom and wacom-tools, tried to configure xorg.conf, but it seems like nothing is working...
Did you modprobe wacom ?
thamarok
 

Postby finferflu » 2007-04-17 20:13

Of course I did...
finferflu
 
Posts: 8
Joined: 2007-04-12 17:59
Location: Manchester, UK

Postby thamarok » 2007-04-17 20:20

finferflu wrote:Of course I did...
Don't know how to help you there.. all I can say is that my Volito works fine and I didn't do anything special to get it to work..
thamarok
 

Postby finferflu » 2007-04-17 20:22

It looks like I'm always lucky... :P
finferflu
 
Posts: 8
Joined: 2007-04-12 17:59
Location: Manchester, UK

Postby thamarok » 2007-04-18 08:22

finferflu wrote:It looks like I'm always lucky... :P
Incase you need to check configurations or some other things, you can rely on me; I am sure we will get this sorted out.
thamarok
 

Postby finferflu » 2007-04-18 16:18

Thanks for your support.
At the moment I have no clue about what could be missing, because it seems everything it's alright, only the pen tablet doesn't seem to give inputs (and I'm sure it works, since on Ubuntu it does).

I'll come back to you whenever (and if) I'll need to check configuration files, thanks :)
finferflu
 
Posts: 8
Joined: 2007-04-12 17:59
Location: Manchester, UK

Postby thamarok » 2007-04-18 17:25

Could you post your /etc/X11/xorg.conf file here?
I think I know what could be causing this.
thamarok
 

Postby finferflu » 2007-04-18 17:41

Of course!
I hope you are right.
Code: Select all
Section "Files"
   FontPath   "/usr/share/fonts/X11/misc"
   FontPath   "/usr/X11R6/lib/X11/fonts/misc"
   FontPath   "/usr/share/fonts/X11/cyrillic"
   FontPath   "/usr/X11R6/lib/X11/fonts/cyrillic"
   FontPath   "/usr/share/fonts/X11/100dpi/:unscaled"
   FontPath   "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
   FontPath   "/usr/share/fonts/X11/75dpi/:unscaled"
   FontPath   "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
   FontPath   "/usr/share/fonts/X11/Type1"
   FontPath   "/usr/X11R6/lib/X11/fonts/Type1"
   FontPath   "/usr/share/fonts/X11/100dpi"
   FontPath   "/usr/X11R6/lib/X11/fonts/100dpi"
   FontPath   "/usr/share/fonts/X11/75dpi"
   FontPath   "/usr/X11R6/lib/X11/fonts/75dpi"
   # path to defoma fonts
   FontPath   "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
   Load   "bitmap"
   Load   "dbe"
   Load   "ddc"
   Load   "dri"
   Load   "extmod"
   Load   "freetype"
   Load   "glx"
   Load   "int10"
   Load   "vbe"
EndSection

Section "InputDevice"
   Identifier   "Generic Keyboard"
   Driver      "kbd"
   Option      "CoreKeyboard"
   Option      "XkbRules"   "xorg"
   Option      "XkbModel"   "pc105"
   Option      "XkbLayout"   "it"
EndSection

Section "InputDevice"
   Identifier   "Configured Mouse"
   Driver      "mouse"
   Option      "CorePointer"
   Option      "Device"      "/dev/input/mice"
   Option      "Protocol"      "ImPS/2"
   Option      "Emulate3Buttons"   "true"
EndSection

Section "InputDevice"
   Identifier   "Synaptics Touchpad"
   Driver      "synaptics"
   Option      "SendCoreEvents"   "true"
   Option      "Device"      "/dev/psaux"
   Option      "Protocol"      "auto-dev"
   Option      "HorizScrollDelta"   "0"
EndSection

Section "InputDevice"
  Driver        "wacom"
  Identifier    "stylus"
  Option        "Device"        "/dev/input/wacom"          # Change to
                                                      # /dev/input/event
                                                      # for USB
  Option        "Type"          "stylus"
  Option          "USB"           "on"
  Option        "PressCurve"    "50,0,100,50"
EndSection

Section "InputDevice"
  Driver        "wacom"
  Identifier    "eraser"
  Option        "Device"        "/dev/input/wacom"          # Change to
                                                      # /dev/input/event
                                                      # for USB
  Option        "Type"          "eraser"
  Option          "USB"           "on"
EndSection

Section "InputDevice"
  Driver        "wacom"
  Identifier    "cursor"
  Option        "Device"        "/dev/input/wacom"          # Change to
                                                      # /dev/input/event
                                                      # for USB
  Option        "Type"          "cursor"
  Option          "USB"           "on"
EndSection

Section "Device"
   Identifier   "ATI Radeon Mobility 7500"
   Driver      "ati"
   BusID      "PCI:1:0:0"
   Option "XAANoOffscreenPixmaps" "true"
   Option          "AGPMode"       "8"
#        Option          "AccelMethod"   "EXA"
        Option          "ColorTiling"   "on"
EndSection

Section "Monitor"
   Identifier   "Generic Monitor"
   Option      "DPMS"
   HorizSync   28-50
   VertRefresh   43-75
EndSection

Section "Screen"
   Identifier   "Default Screen"
   Device      "ATI Radeon Mobility 7500"
   Monitor      "Generic Monitor"
   DefaultDepth   24
   SubSection "Display"
      Depth      1
      Modes      "1280x960" "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      4
      Modes      "1280x960" "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      8
      Modes      "1280x960" "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      15
      Modes      "1280x960" "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      16
      Modes      "1280x960" "1024x768" "800x600" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      24
      Modes      "1280x960" "1024x768" "800x600" "640x480"
   EndSubSection
EndSection

Section "ServerLayout"
   Identifier   "Default Layout"
   Screen      "Default Screen"
   InputDevice   "Generic Keyboard"
   InputDevice   "Configured Mouse"
   InputDevice   "Synaptics Touchpad"
   InputDevice     "stylus" "SendCoreEvents"
   InputDevice     "cursor" "SendCoreEvents"
   InputDevice     "eraser" "SendCoreEvents"
EndSection

Section "DRI"
   Mode   0666
EndSection

Section "Extensions"
        Option "Composite" "enable"
EndSection
finferflu
 
Posts: 8
Joined: 2007-04-12 17:59
Location: Manchester, UK

Postby thamarok » 2007-04-19 14:29

Hmmm... it seems OK. Try these commands:
Code: Select all
chmod 777 /dev/input/wacom
wacdump /dev/input/wacom
ln -s /dev/input/wacom /dev/wacom

You could also try to change /dev/input/wacom with /dev/input/tablet-volito in /etc/X11/xorg.conf and then just:
Code: Select all
chmod 777 /dev/input/tablet-volito
wacdump /dev/input/tablet-volito
thamarok
 

Postby finferflu » 2007-04-20 10:34

No luck!
but thanks for trying...
finferflu
 
Posts: 8
Joined: 2007-04-12 17:59
Location: Manchester, UK

Postby thamarok » 2007-04-20 20:57

Wait, just to make everything clear: Do you have a Volito or Volito2?
I have a Volito2 if it makes a difference.
thamarok
 

Postby finferflu » 2007-04-20 20:59

A Volito2 as well...
finferflu
 
Posts: 8
Joined: 2007-04-12 17:59
Location: Manchester, UK

Next

Return to Hardware

Who is online

Users browsing this forum: No registered users and 11 guests

fashionable