Samba speed much too slow

Kernels & Hardware, configuring network, installing services

Samba speed much too slow

Postby xorgmc » 2016-05-29 12:49


I'm really desperate, maybe somebody here has any ideas left...
I've got a Odroid XU4 ARM Board as a network storage, it runs Debian Jessie. (CPU is a 8-core HMP Samsung Exynos)

It has two 2TB HDDs connected via USB 3.0, configured as raid1 with ext4.
The machine is connected via CAT6 gigabit LAN (measured fine, 90-100MB/s)

I've installed samba and nfs server. The NFS Server performs well, I get the hardware maximum speed (70-90MB/s Read/Write).

But Samba performance is just poor, about 30MB/s. I tried many tweaks posted in odroid forums (setting MTU, cache size, TCP_NODELAY), but nothing could improve it.
The CPU is not overloaded, samba uses about 30-60% CPU usage on one of the fast 2GHz cores. Governor is also set to performance.

As it performs fine with NFS, I think it can't be the hardware, it must be something software/samba-related.

Samba Version is 4.2.10-Debian, I've also tried self-compiled 4.4.3. The kernel is an old 3.10.96 kernel, but it's the same with an upstream 4.6 kernel.

Clients were Ubuntu and Arch Linux, as well as Windows 10 - it's the same everywhere.
Posts: 1
Joined: 2016-05-29 12:40

Return to System configuration

Who is online

Users browsing this forum: L_V, rezapanda and 9 guests