Freeze on "Loading initial ramdisk" after install [SOLVED]

Help with issues regarding installation of Debian

Freeze on "Loading initial ramdisk" after install [SOLVED]

Postby mike723 » 2016-08-13 15:39

After doing a fresh HD installation and rebooting, I see the GRUB menu and can select any items but when it starts booting I'm stuck with:

Loading Linux 4.4.0-31-generic ...
Loading initial ramdisk ...

And then I can't do anything. I'm blocked.

I tried different distributions of Linux like Linux Mint, Ubuntu, Fedora and I'm always blocked at this step.

The hardware is:

Acer Aspire One Cloudbook 11 AO1-132-C9HA
Intel Celeron N3050, 1.6 GHz Dual Core
2 Go RAM DDR3L
32 Go eMMC
Intel HD Graphics

The BIOS is configured on Legacy mode and I installed Linux with MBR (not GPT)

I searched every forum with the same issue and tried every "solution" mentioned but nothing worked for me... :cry:
Last edited by mike723 on 2016-08-15 15:57, edited 1 time in total.
mike723
 
Posts: 7
Joined: 2016-08-13 15:27

Re: Freeze on "Loading initial ramdisk" after fresh install

Postby Head_on_a_Stick » 2016-08-13 15:50

mike723 wrote:Loading Linux 4.4.0-31-generic ...
Loading initial ramdisk ...

That is not a Debian kernel, please explain.

I can't do anything. I'm blocked.

Does <Ctrl>+<Alt>+F2 do anything?

I searched every forum with the same issue and tried every "solution" mentioned

Please list all of the "solution"s you have tried in order to prevent duplication of effort by those who attempt to assist you.

For example, have you tried disabling kernel modesetting?
https://wiki.archlinux.org/index.php/Ke ... odesetting
https://wiki.archlinux.org/index.php/Ke ... eters#GRUB
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 13280
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Freeze on "Loading initial ramdisk" after fresh install

Postby mike723 » 2016-08-13 16:01

That is not a Debian kernel, please explain.


Sorry, I copy pasted the output from my Ubuntu installation attempt. But it was the same issue for every distribution I tried.

Does <Ctrl>+<Alt>+F2 do anything?


No nothing happens.

Please list all of the "solution"s you have tried in order to prevent duplication of effort by those who attempt to assist you.
For example, have you tried disabling kernel modesetting?


Yes I tried :
nomodeset
i915.modeset=0
i915.modeset=1
acpi_osi=Linux
acpi=off
vga=791
vga=792
video=VGA-1:1024x768-24@60

I also tried to add debug, verbose and earlyprintk=vga,keep but I don't get any additional information from that
mike723
 
Posts: 7
Joined: 2016-08-13 15:27

Re: Freeze on "Loading initial ramdisk" after fresh install

Postby pylkko » 2016-08-13 17:15

Do you have the edd=off and noapic parametersthat are needed?
User avatar
pylkko
 
Posts: 1801
Joined: 2014-11-06 19:02

Re: Freeze on "Loading initial ramdisk" after fresh install

Postby mike723 » 2016-08-13 17:36

I added edd=off and noapic but still not working
mike723
 
Posts: 7
Joined: 2016-08-13 15:27

Re: Freeze on "Loading initial ramdisk" after fresh install

Postby dotlj » 2016-08-14 07:41

Please try the Debian Stable CD image. (such as http://cdimage.debian.org/debian-cd/8.5.0/amd64/iso-cd/debian-8.5.0-amd64-CD-1.iso)
Many try the netinstall image but have problems because it lacks non free hardware drivers.
It sounds as though you have checked and set BIOS settings for Linux which is helpful.
Consider your partitioning scheme before starting and make a list of your hardware such as internet interfaces, video card, sound, which might cause problems.
Do you want a minimal install, Desktop install such as Gnome or KDE, or something else such as mail server, file server or ...?
Posting output, error messages and what you did will help.
User avatar
dotlj
 
Posts: 646
Joined: 2009-12-25 17:21

Re: Freeze on "Loading initial ramdisk" after fresh install

Postby mike723 » 2016-08-14 10:29

Please try the Debian Stable CD image. (such as http://cdimage.debian.org/debian-cd/8.5 ... 4-CD-1.iso)


I tried to install Debian from this image but if failed because the installer couldn't detect my hard drive. The only disk detected is my USB key from where I booted this image...

Do you want a minimal install, Desktop install such as Gnome or KDE, or something else such as mail server, file server or ...?


I'm looking for a Desktop install. Every window manager will be ok, not important.
mike723
 
Posts: 7
Joined: 2016-08-13 15:27

Re: Freeze on "Loading initial ramdisk" after fresh install

Postby dotlj » 2016-08-14 12:22

I tried to install Debian from this image but if failed because the installer couldn't detect my hard drive. The only disk detected is my USB key from where I booted this image...


That's helpful. :)
In your BIOS, what are the settings related to hard disks? Are using using AHCI? Are the disks detected by BIOS?
I've installed Debian many times on many machines and haven't seen one yet that didn't detect the hard disks. :(

How far does it go into the installation before it stops? Do you get to the detect disks or partitioning part?
User avatar
dotlj
 
Posts: 646
Joined: 2009-12-25 17:21

Re: Freeze on "Loading initial ramdisk" after fresh install

Postby mike723 » 2016-08-14 12:36

In your BIOS, what are the settings related to hard disks?

Not much information. The only settings related to disk are the boot mode set to Legacy and boot priority set to USB HDD, USB FDD, EMMC : M5253232G

Are using using AHCI? Are the disks detected by BIOS?

I see nothing related to AHCI in my BIOS settings...

How far does it go into the installation before it stops? Do you get to the detect disks or partitioning part?

Well I can pass the detect disks step and see partitioning part but then I'm stuck because the only disk I see is my 1.8GB USB key. Nothing else.
I'm forced to stop the installation process at this point.
mike723
 
Posts: 7
Joined: 2016-08-13 15:27

Re: Freeze on "Loading initial ramdisk" after fresh install

Postby tuxserbia » 2016-08-15 05:51

Maybe this is the problem?

https://www.phoronix.com/scan.php?page= ... Trail-Fail

Some people tried to install Ubuntu on diverse tablets

https://sturmflut.github.io/linux/ubunt ... l-tablets/
https://sturmflut.github.io/linux/ubunt ... version-2/

http://www.jfwhome.com/2014/03/07/perfe ... book-t100/
http://www.jfwhome.com/2016/01/04/lates ... us-t100ta/

https://www.happyassassin.net/fedlet-a- ... l-tablets/

There's also a petition

https://www.change.org/p/tablet-makers- ... il-tablets

For the EMMC, there wont be an AHCI, because there is no SATA, so it should be under /dev/mmcblk* or something similar.

If you could try some distro with a newer kernel, arch, even Ubuntu 16.04.1, both 32bit and 64bit.
User avatar
tuxserbia
 
Posts: 46
Joined: 2015-07-31 13:10
Location: Italy

Re: Freeze on "Loading initial ramdisk" after fresh install

Postby mike723 » 2016-08-15 13:35

Maybe this is the problem?


I tried adding intel_idle.max_cstate=1 but this didn't fixed the issue. Still not booting

I'm not familiar with Bay Trail... Is that some kind of of processor model? (I have Intel Celeron as stated in my first post)

If you could try some distro with a newer kernel, arch, even Ubuntu 16.04.1, both 32bit and 64bit.


I tried Ubuntu 16.04.1 64bit but still not booting after install.
mike723
 
Posts: 7
Joined: 2016-08-13 15:27

Re: Freeze on "Loading initial ramdisk" after fresh install

Postby tuxserbia » 2016-08-15 14:31

They all part of one happy atom(ic) family

https://en.wikipedia.org/wiki/Silvermont

Lots of trashing on the internet about this, conspiracy theory lovers blame wintel. On the other hand, you have a chromebook, so maybe its a start of a new one - googtel, or just an incompetent team hired by intel foss group.

Maybe you could try that 32bit UEFI trick.

For storage, is it on dev/mmc or?
User avatar
tuxserbia
 
Posts: 46
Joined: 2015-07-31 13:10
Location: Italy

Re: Freeze on "Loading initial ramdisk" after fresh install

Postby mike723 » 2016-08-15 15:57

Thank you all for your help.
I finally managed to successfully install and boot Ubuntu 16.04.1 64bit

I had to install it in UEFI mode and I followed this tutorial for configuring BIOS settings :

http://bernaerts.dyndns.org/linux/74-ub ... udbook-431
mike723
 
Posts: 7
Joined: 2016-08-13 15:27

Re: Freeze on "Loading initial ramdisk" after install [SOLVE

Postby tuxserbia » 2016-08-15 16:34

Really glad to hear that. Good job!
User avatar
tuxserbia
 
Posts: 46
Joined: 2015-07-31 13:10
Location: Italy


Return to Installation

Who is online

Users browsing this forum: No registered users and 7 guests

fashionable