Font viewer not showing fonts

Everything about X, Gnome, KDE, ... and everything running on it

Font viewer not showing fonts

Postby anmys » 2017-02-27 15:40

I am running debian testing with mate 1.16 version. When I use mate-font-viewer to check out a font file, it just displays a blank, black area. No error messages are printed on the terminal. If it matters, there is no problem with the font file as I can use it in all other programs.

I also tried by clearing off all the $HOME/.* files and restarting the programs. Same result :-( Even changing the desktop/window manager does not help.

Any pointers to solve the problem will be helpful.
Last edited by anmys on 2017-03-01 21:39, edited 1 time in total.
anmys
 
Posts: 10
Joined: 2011-11-30 05:06

Re: Font viewer not showing fonts

Postby GarryRicketson » 2017-02-27 17:03

What terminal are you using ?, I mean like xterm, eterm,xfce terminal, mate,..(you say mate,but that does not mean the mate terminal,...)
A long time ago, on older Debian version, I thought the gnome, and also the
mate terminals did not work, all I could see is a black screen , no curser, etc,..
I got looking at the configuration,...
Looked at "edit">preferences> colours , and what I found was that it was
using a default , black background, black text, and black cursor.
So that was pretty obvious, once I changed it to a white back ground ,black text and black cursor ,.. the terminal was working, it was just I couldn't see anything because it was all black.
I don't know if the "mate-font" viewer, and on the newer Debian versions has the same options for setting colours,background ,etc, but it might be worth looking into.
"What we expect you have already Done"

Before doing anything, read the Debian documentation:
Debian Documentation
How to ask the smart way
Debian Foro Español
======================
For the Birds
User avatar
GarryRicketson
 
Posts: 4369
Joined: 2015-01-20 22:16
Location: Durango, Mexico

Re: Font viewer not showing fonts

Postby anmys » 2017-02-27 23:50

There seems to be some misunderstanding of my problem. I am not talking about the terminal, but the mate-font-viewer window. In case it matters, I am using terminator.
anmys
 
Posts: 10
Joined: 2011-11-30 05:06

Re: Font viewer not showing fonts

Postby GarryRicketson » 2017-02-28 01:59

Ok, well I do understand that, but any way, , can you explain exactly how you
are starting "mate-font-viewer" ?
No error messages are printed on the terminal.

Is what made me think you are trying to run it from the terminal,...
In any event, since I do have "mate" , I tried it, and can not seem to duplicate
the problem, however mine is the old stable Debian, (Wheezy),...
I did have a little problem starting it from the terminal, so I looked
at :
Code: Select all
 man mate-font-viewer

Based on what it said , I started it using the command:
Code: Select all
mate-control-center

Then from there, "Appearance", > Fonts
I had no problem viewing all the available fonts,....of course, since Debian testing, no longer works the same as the older versions,
and
I am running debian testing with mate 1.16 version.

Mine is mate 1.8,.... so nothing is the same, sorry,... maybe later if I have a chance I will look at the newer version that is on a VM, and see if it has this problem.
"What we expect you have already Done"

Before doing anything, read the Debian documentation:
Debian Documentation
How to ask the smart way
Debian Foro Español
======================
For the Birds
User avatar
GarryRicketson
 
Posts: 4369
Joined: 2015-01-20 22:16
Location: Durango, Mexico

Re: Font viewer not showing fonts

Postby debiman » 2017-02-28 07:00

i can offer a workaround, if not a solution.
save this script to $HOME/bin/fontview:
Code: Select all
#!/bin/sh

fg="#123"
bg="#fed"

convert -background "$bg" -fill "$fg" -density \
"$(xdpyinfo | sed -n 's/resolution:\(.*\)dots per inch/\1/p')" \
"$@" PNG:- | feh -^ "$@" -N -
then make it the default application to open font files.
you need imagemagick and feh (though the latter can be replaced with another imageviewer).

of course it would be nicer to solve this from within mate.
User avatar
debiman
 
Posts: 1545
Joined: 2013-03-12 07:18

Re: Font viewer not showing fonts

Postby anmys » 2017-02-28 12:28

GarryRicketson wrote:Ok, well I do understand that, but any way, , can you explain exactly how you
are starting "mate-font-viewer" ?

I tried including a screenshot, but could not as the server kept giving a message about quota for the day being exceeded. I am inclding a link to the image on flickr here. Hopefully, it explains the problem I am facing.

https://flic.kr/p/RhV8av
anmys
 
Posts: 10
Joined: 2011-11-30 05:06

Re: Font viewer not showing fonts

Postby stevepusser » 2017-02-28 19:56

Could it have something to do with the GTK 3 theme you are using? Arc has good support for the newer GTK 3, try installing arc-theme and switching to that to test it.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Krita 3.3.2.1, Pale Moon 27.6.0, Audacity 2.2.0, mpv 0.27.0, Corebird 1.7.1, Firefox 57.0, SMPlayer 17.11.2
User avatar
stevepusser
 
Posts: 8905
Joined: 2009-10-06 05:53

Re: Font viewer not showing fonts

Postby anmys » 2017-03-01 00:03

stevepusser wrote:Could it have something to do with the GTK 3 theme you are using? Arc has good support for the newer GTK 3, try installing arc-theme and switching to that to test it.


I use Openbox. Would gtk3 theme matter under that?
anmys
 
Posts: 10
Joined: 2011-11-30 05:06

Re: Font viewer not showing fonts

Postby stevepusser » 2017-03-01 01:08

Mate uses GTK, but I'm unsure whether the font viewer is using GTK 2 or 3. I think mate-1.16 in Debian is a mixture, and mate-2.0 aims to be fully GTK 3.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Krita 3.3.2.1, Pale Moon 27.6.0, Audacity 2.2.0, mpv 0.27.0, Corebird 1.7.1, Firefox 57.0, SMPlayer 17.11.2
User avatar
stevepusser
 
Posts: 8905
Joined: 2009-10-06 05:53

Re: Font viewer not showing fonts

Postby anmys » 2017-03-01 07:34

stevepusser wrote:Mate uses GTK, but I'm unsure whether the font viewer is using GTK 2 or 3. I think mate-1.16 in Debian is a mixture, and mate-2.0 aims to be fully GTK 3.


I tried this:
Code: Select all
$ ldd `which mate-font-viewer` | grep gtk
   libgtk-3.so.0 => /usr/lib/x86_64-linux-gnu/libgtk-3.so.0 (0x00007ffb449f7000)
   libcanberra-gtk3.so.0 => /usr/lib/x86_64-linux-gnu/libcanberra-gtk3.so.0 (0x00007ffb420c2000)


Am I correct in assuming that it is using gtk3?
anmys
 
Posts: 10
Joined: 2011-11-30 05:06

Re: Font viewer not showing fonts

Postby debiman » 2017-03-01 19:16

anmys wrote:Am I correct in assuming that it is using gtk3?

yes.
User avatar
debiman
 
Posts: 1545
Joined: 2013-03-12 07:18

Re: Font viewer not showing fonts

Postby stevepusser » 2017-03-02 21:16

Do you have the MATE settings manager installed? If so, check to see what theme (style) you have set in there and see if installing the arc theme and using it makes any difference.

If that doesn't help, my next guess would be that something in openbox needs to be configured, but I'm lost after that.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Krita 3.3.2.1, Pale Moon 27.6.0, Audacity 2.2.0, mpv 0.27.0, Corebird 1.7.1, Firefox 57.0, SMPlayer 17.11.2
User avatar
stevepusser
 
Posts: 8905
Joined: 2009-10-06 05:53


Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 5 guests

fashionable