Scheduled Maintenance: We are aware of an issue with Google, AOL, and Yahoo services as email providers which are blocking new registrations. We are trying to fix the issue and we have several internal and external support tickets in process to resolve the issue. Please see: viewtopic.php?t=158230

 

 

 

[Debian 9] LACP bonding no speed above 100Mb/s?

New to Debian (Or Linux in general)? Ask your questions here!
Post Reply
Message
Author
florius
Posts: 1
Joined: 2017-07-05 08:18

[Debian 9] LACP bonding no speed above 100Mb/s?

#1 Post by florius »

Hi,

I'm running Proxmox 5 (based on Debian 9) and trying to get bonding to work.
But unfortunately for some reason I am not getting any speed above 100Mb/s.

My config is as follow:

Code: Select all

/# cat /etc/network/interfaces
auto lo
iface lo inet loopback

iface eno1 inet manual

iface eno2 inet manual

iface eno3 inet manual

iface eno4 inet manual

auto bond1
iface bond1 inet manual
        slaves eno3 eno4
        bond_miimon 100
        bond_mode 802.3ad

auto bond0
iface bond0 inet manual
        slaves eno1 eno2
        bond_miimon 100
        bond_mode 802.3ad

auto vmbr0
iface vmbr0 inet static
        address  X.X.X.X
        netmask  255.255.255.0
        gateway  X.X.X.X
        bridge_ports bond0
        bridge_stp off
        bridge_fd 0

auto vmbr1
iface vmbr1 inet static
        address  10.0.0.1
        netmask  255.255.255.0
        bridge_ports bond1
        bridge_stp off
        bridge_fd 0
Both public (I have removed the IP's for safety reasons!) and internal should both be bonded according to '/proc/net/bonding/bondX':

Code: Select all

# cat /proc/net/bonding/bond0
Ethernet Channel Bonding Driver: v3.7.1 (April 27, 2011)

Bonding Mode: IEEE 802.3ad Dynamic link aggregation
Transmit Hash Policy: layer2 (0)
MII Status: up
MII Polling Interval (ms): 100
Up Delay (ms): 0
Down Delay (ms): 0

802.3ad info
LACP rate: slow
Min links: 0
Aggregator selection policy (ad_select): stable
System priority: 65535
System MAC address: f0:4d:a2:00:58:8f
Active Aggregator Info:
        Aggregator ID: 1
        Number of ports: 2
        Actor Key: 9
        Partner Key: 51
        Partner Mac Address: 00:15:60:fe:46:80

Slave Interface: eno1
MII Status: up
Speed: 1000 Mbps
Duplex: full
Link Failure Count: 0
Permanent HW addr: f0:4d:a2:00:58:8f
Slave queue ID: 0
Aggregator ID: 1
Actor Churn State: none
Partner Churn State: none
Actor Churned Count: 0
Partner Churned Count: 0
details actor lacp pdu:
    system priority: 65535
    system mac address: f0:4d:a2:00:58:8f
    port key: 9
    port priority: 255
    port number: 1
    port state: 61
details partner lacp pdu:
    system priority: 18048
    system mac address: 00:15:60:fe:46:80
    oper key: 51
    port priority: 0
    port number: 1
    port state: 61

Slave Interface: eno2
MII Status: up
Speed: 1000 Mbps
Duplex: full
Link Failure Count: 0
Permanent HW addr: f0:4d:a2:00:58:91
Slave queue ID: 0
Aggregator ID: 1
Actor Churn State: none
Partner Churn State: none
Actor Churned Count: 0
Partner Churned Count: 0
details actor lacp pdu:
    system priority: 65535
    system mac address: f0:4d:a2:00:58:8f
    port key: 9[code]
port priority: 255
port number: 2
port state: 61
details partner lacp pdu:
system priority: 18048
system mac address: 00:15:60:fe:46:80
oper key: 51
port priority: 0
port number: 2
port state: 61
[/code]

I use a HP Procurve HP2824:

Code: Select all

interface 1
   no lacp
exit
interface 2
   no lacp
exit
interface 5
   no lacp
exit
interface 6
   no lacp
exit
trunk 1-2 Trk1 LACP
trunk 5-6 Trk2 LACP
snmp-server community "public" Unrestricted
vlan 1
   name "DEFAULT_VLAN"
   untagged 16-17,23-24
   ip address dhcp-bootp
   no untagged 3-4,7-15,18-22,Trk1-Trk2
   exit
vlan 40
   name "OOB"
   untagged 3-4,7-8,11-12,21
   ip address 10.0.0.254 255.255.255.0
   exit
vlan 300
   name "IPMI"
   untagged 13-15,18-19
   tagged 24
   exit
vlan 133
   name "VLAN133"
   untagged 9-10,22,Trk1-Trk2
   tagged 24
   exit
vlan 135
   name "VLAN135"
   untagged 20
   tagged 24
   exit
spanning-tree Trk1 priority 4
spanning-tree Trk2 priority 4
Config is as above. I test it via scp downloading an ISO file from one server to another, and tried both public and internal. (Perhaps it's the testing method, as it is a single file?)

Let me know, thank you!

delfer
Posts: 1
Joined: 2017-12-06 12:20

Re: [Debian 9] LACP bonding no speed above 100Mb/s?

#2 Post by delfer »

You can not achieve speed over 100Mb/s downloading from single client, because it is not possible to send TCP packets from multiple interfaces and preserve packet sequence.
But you can download/upload using multiple clients and achieve total speed more, thank just single interface. Load balancing algorithm (mac/ip-based) depends on your switch.

Post Reply