odd password issue in Testing [Solved]

Help with issues regarding installation of Debian

odd password issue in Testing [Solved]

Postby tpprynn » 2017-10-04 07:08

Hello. I've installed the latest 'CD1' iso of Debian Testing, Xfce desktop, 64 bit, on an MSI mini-pc. It's mostly working outstandingly well for a computer that has been sluggish with nearly everything, better than Debian 9 or Xubuntu 16.04, but for some tasks the install is refusing my password, though certainly typed correctly.

I skipped the root account during install as I usually do without issue, in favour of using sudo, and I can start some things like Synaptic with no problem and can use sudo fine in the terminal. But if I try to install WPS Office with Gdebi for example it will not accept my password. The same goes for trying to use gksu. (Does using 'sudo mousepad' have any bad effect rather than 'gksu mousepad'?) I vaguely remember that the previous version of Debian had one iso that briefly messed up something that sounds related to do with root, but doing a search here of relevant terms throws up only threads from four or more years ago. Can this be put right without, possibly, waiting for a later iso or do I need to just work round this? (I did get WPS Office installed in the end by running 'sudo gdebi-gtk' from the terminal but wonder if improvising my way to the goal might cause some currently unseen issue.)

I don't know if my sudoers file is relevant, having only touched that once since 2008:

# This file MUST be edited with the 'visudo' command as root.
# Please consider adding local content in /etc/sudoers.d/ instead of
# directly modifying this file.
# See the man page for details on how to write a sudoers file.
Defaults env_reset
Defaults mail_badpass
Defaults secure_path="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin"

# Host alias specification

# User alias specification

# Cmnd alias specification

# User privilege specification

# Allow members of group sudo to execute any command

# See sudoers(5) for more information on "#include" directives:

#includedir /etc/sudoers.d

Thanks for any responses.


I have put this right with gksu-properties. Entering this into the terminal brings up the option to change from su to sudo, which seems to have worked. I've never had to do that before but if it's not a bug it may make some sense as an ex-Ubuntu user.
Posts: 94
Joined: 2011-04-11 18:09

Return to Installation

Who is online

Users browsing this forum: No registered users and 8 guests