Too small fonts Stretch/KDE

Everything about X, Gnome, KDE, ... and everything running on it

Too small fonts Stretch/KDE

Postby linuxsat » 2017-12-05 08:39

Hi,

I installed Debian Stretch 9.2 with KDE/Plasma Desktop a couple of weeks ago, I have some little issues, one is the following.

Some application as: system-settings, firefox, thunderbird use very tiny fonts size (looks like 6pt) in their main windows, and channging the size of the fonts in the system-settings do not change them. The size can be changed in the menus, title,.... but not in th the main window. I tried also when possible to change the fonts directly in applications but it do not works.

thanks for any answer,
linuxsat
 
Posts: 18
Joined: 2017-10-20 14:28

Re: Too small fonts Stretch/KDE

Postby L_V » 2017-12-05 09:39

You should install kde-config-gtk-style kde-config-gtk-style-preview to adjust gtk programs.
And then launch:
Code: Select all
kcmshell5 fonts
kcmshell5 kde-gtk-config

Or look in systemsettings.
L_V
 
Posts: 717
Joined: 2007-03-19 09:04

Re: Too small fonts Stretch/KDE

Postby bw123 » 2017-12-05 09:58

I noticed "scale display" at the bottom of the page in systemsettings> display and monitor> displays but I haven't messed with it.
Last edited by bw123 on 2017-12-05 10:22, edited 1 time in total.
User avatar
bw123
 
Posts: 2479
Joined: 2011-05-09 06:02
Location: TN_USA

Re: Too small fonts Stretch/KDE

Postby L_V » 2017-12-05 10:01

@bw123
Assumption: you don't use the right graphics card driver.
L_V
 
Posts: 717
Joined: 2007-03-19 09:04

Re: Too small fonts Stretch/KDE

Postby bw123 » 2017-12-05 10:15

L_V wrote:@bw123
Assumption: you don't use the right graphics card driver.



thanks I will try and fix that
Last edited by bw123 on 2017-12-05 10:22, edited 2 times in total.
User avatar
bw123
 
Posts: 2479
Joined: 2011-05-09 06:02
Location: TN_USA

Re: Too small fonts Stretch/KDE

Postby L_V » 2017-12-05 10:18

@bw123
Your problem is not plasma, but graphic card driver you should first solve (not in a "Too small fonts Stretch/KDE" thread).
L_V
 
Posts: 717
Joined: 2007-03-19 09:04

Re: Too small fonts Stretch/KDE

Postby linuxsat » 2017-12-07 07:45

Thanks for your answers,
L_V wrote:You should install kde-config-gtk-style kde-config-gtk-style-preview to adjust gtk programs.
And then launch:
Code: Select all
kcmshell5 fonts
kcmshell5 kde-gtk-config

Or look in systemsettings.


the kde-config-gtk-style-preview package was missing, so I install it, but no matter what I choose in:
Systemsettings> Appearence > Applicationstyle > Gnome Applicationstyle (GTK), changes the fonts in the main windows. Changes are taken into account for
menus, titlebars, ... only

About bw123's remark
I noticed "scale display" at the bottom of the page in systemsettings> display and monitor> displays but I haven't messed with it.

I think that scale display affect the whole screen, I saw a thread about a resolution problem, but the whole fonts was concerned. I think, it is not a resolution
problem here but probably that I cannot access to some of the fonts used.
linuxsat
 
Posts: 18
Joined: 2017-10-20 14:28

Re: Too small fonts Stretch/KDE

Postby L_V » 2017-12-07 18:19

Do you have a ~/.gtkrc-2.0 file ?
If yes, please post the content.
L_V
 
Posts: 717
Joined: 2007-03-19 09:04

Re: Too small fonts Stretch/KDE

Postby linuxsat » 2017-12-08 06:47

here it is

Code: Select all
# File created by KDE Gtk Config
# Configs for GTK2 programs

include "/home/toor/.themes/kde42-oxygen/gtk-2.0/gtkrc"
style "user-font"
{
   font_name="Noto Sans Regular"
}
widget_class "*" style "user-font"
gtk-font-name="Noto Sans Regular 14"
gtk-theme-name="kde42-oxygen"
gtk-icon-theme-name="oxygen"
gtk-fallback-icon-theme="breeze"
gtk-cursor-theme-name="Oxygen 05 Vibrant Red"
gtk-toolbar-style=GTK_TOOLBAR_ICONS
gtk-menu-images=1
gtk-button-images=1
gtk-primary-button-warps-slider=0

linuxsat
 
Posts: 18
Joined: 2017-10-20 14:28

Re: Too small fonts Stretch/KDE

Postby L_V » 2017-12-08 08:29

gtk-theme-name="kde42-oxygen" => not provided by Debian.

Try with gtk2-engines-oxygen or gtk2-engines-qtcurve
Your gtk2 theme font size is here => gtk-font-name="Noto Sans Regular 14"

"the size can be changed in the menus, title,.... but not in th the main window."

Did you try with a new profile ?
firefox -P
L_V
 
Posts: 717
Joined: 2007-03-19 09:04

Re: Too small fonts Stretch/KDE

Postby linuxsat » 2017-12-09 09:23

L_V wrote:gtk-theme-name="kde42-oxygen" => not provided by Debian.

Yes it is provided by kde contributors, I found it using the regular system-settings app (no frankenDebianization here!).

L_V wrote:Try with gtk2-engines-oxygen or gtk2-engines-qtcurve
Your gtk2 theme font size is here => gtk-font-name="Noto Sans Regular 14"

Thanks for that, I was not aware of that packages. Unfortunately it does not changes things....
The fonts choice there seems not apply to the main part of the concerned windows (?)

L_V wrote:Did you try with a new profile ?

I fact I installed new theme (the oxygen42) exactly to make such a test. The problem
was already there just after the installation with the default "Breeze" theme.

I also tried to change font (one by one) everywhere using the system-settings without effect.
Is it possible that some fonts were unchangeable?
linuxsat
 
Posts: 18
Joined: 2017-10-20 14:28

Re: Too small fonts Stretch/KDE

Postby L_V » 2017-12-09 14:14

There is no direct interaction between global KDE font system setting with gtk applications.
Did you try with a live CD session to investigate ?
Are you sure your graphic driver is the correct one ?
L_V
 
Posts: 717
Joined: 2007-03-19 09:04

Re: Too small fonts Stretch/KDE

Postby linuxsat » 2017-12-11 07:39

L_V wrote:There is no direct interaction between global KDE font system setting with gtk applications.

Ok, so I suspect that some configuration file somwhere in the system superseed the configuration done with the KDE tools.
i think like that, because of other small config problems. for instance, in "dolphin" part of my settings are not taken into account (i will probably open another
thread for that in the future). Are you aware of the existance of such "master" config files?

L_V wrote:Did you try with a live CD session to investigate ?

Not yet, I will do so!

L_V wrote:Are you sure your graphic driver is the correct one ?

Yes, in fact, the problem was there just after the install. Then, I installed "Bumblebee" with the driver recommended for my (secondary Nvidia) card. I also
read the system log, nothing seems wrong there, but I'am maybe not sufficiently skilled?
linuxsat
 
Posts: 18
Joined: 2017-10-20 14:28


Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 8 guests

fashionable