Debian 9.3 no grub after fresh install. [SOLVED]

New to Debian (Or Linux in general)? Ask your questions here!

Debian 9.3 no grub after fresh install. [SOLVED]

Postby SilvioTO » 2017-12-17 12:02

Just installed Debian 9.3 on Acer Aspire V3-372 series, but at reboot only windows 10 start, without grub.
Before the installation (from usb stick) I disabled in uefi the secure boot option. During the installation process, apparently, all went fine, and now I don't know where to start to solve the problem.

thanks for help!
Last edited by SilvioTO on 2017-12-18 11:50, edited 2 times in total.
SilvioTO
 
Posts: 15
Joined: 2015-11-26 08:35

Re: Debian 9.3 no grub after fresh install.

Postby Dai_trying » 2017-12-17 13:53

You will probably need to press F12 at boot-up to get the option of which OS to boot (which you probably needed to do to use the usb stick for installation), although you can change it so that Debian boots before Win10 using efibootmgr or maybe your uefi settings (like the old bios settings) can do the same. I can adjust my boot sequence either way on UEFI system.
Dai_trying
 
Posts: 548
Joined: 2016-01-07 12:25

Re: Debian 9.3 no grub after fresh install.

Postby Head_on_a_Stick » 2017-12-17 19:12

If the fine advice offered by Dai_trying does not work then perhaps your motherboard's firmware will only start Microsoft's bootmgfw.efi bootloader, this is a distressingly common UEFI bug.

See Rod Smith's excellent site for an explanation:

https://www.rodsbooks.com/efi-bootloade ... ive-naming

I use this method to solve the problem:

viewtopic.php?p=659660#p659660
User avatar
Head_on_a_Stick
 
Posts: 8004
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Debian 9.3 no grub after fresh install.

Postby SilvioTO » 2017-12-18 11:50

With your precious suggestions and about 3 hours of investigations, I fix the problem.
Cause: probably the UEFI bug mentioned by Head_on_a_Stick, since the Dai_trying solution doesn't work.
Tryed a bios update without luck.

Solution that worked perfectly for me:

1 - Disable Secure Boot in UEFI (Important!);
2 - In Windows, open command prompt as administrator;
3 - At the command prompt, digit the following command:
Code: Select all
bcdedit /set {bootmgr} path \EFI\debian\grubx64.efi

This change the tefault Windows loader to grub. I hope this solution is permanent, despite windows updates.

A big big thanks!
SilvioTO
 
Posts: 15
Joined: 2015-11-26 08:35


Return to Beginners Questions

Who is online

Users browsing this forum: No registered users and 7 guests

fashionable