Firefox-ESR / Beta

Everything about X, Gnome, KDE, ... and everything running on it

Firefox-ESR / Beta

Postby gregg_a_g » 2018-01-29 23:54

Hi, Longtime Debian user running "testing" for several years. Last Saturday I did some maintenance on my wife's desktop and now Chromium and Firefox are exhibiting very strange behavior.
If I start Chromium, a "Tab" appears, with the title "New Tab Chromium", but no window shows up even if I click on the drop down arrow on the tab. I see that about 6 processes are running as "Chromium"
as well as "chrome-sandbox".

If I start Firefox-ESR I see two processes running as firefox-esr, but nothing appears anywhere on the desktop. If I kill the second process, a "normal" Firefox window appears and all appears normal.
I tried Firefox-Beta and got the same results. Can't get Chromium to show up at all.

Here is my sources.list. I normally run "sudo apt-get update", and then "sudo apt-get upgrade". Don't have any other issues right now, but the browser thing is really odd.
Anyone else have this kind of issue recently?

Kind regards,
Gregg G.


#
# deb cdrom:[Debian GNU/Linux 8 _Jessie_ - Official Snapshot amd64 LIVE/INSTALL Binary 20160124-16:11]/ stretch main contrib non-free

deb http://ftp.us.debian.org/debian/ stretch main contrib non-free
deb-src http://ftp.us.debian.org/debian/ stretch main contrib non-free

deb http://security.debian.org/ stretch/updates main contrib non-free
deb-src http://security.debian.org/ stretch/updates main contrib non-free

# stretch-updates, previously known as 'volatile'
deb http://ftp.us.debian.org/debian/ stretch-updates main contrib non-free
deb-src http://ftp.us.debian.org/debian/ stretch-updates main contrib non-free

deb http://ftp.us.debian.org/debian/ testing main contrib non-free
deb-src http://ftp.us.debian.org/debian/ testing main contrib non-free

deb http://security.debian.org/ testing/updates main contrib non-free
deb-src http://security.debian.org/ testing/updates main contrib non-free

# testing-updates, previously known as 'volatile'
deb http://ftp.us.debian.org/debian/ testing-updates main contrib non-free
deb-src http://ftp.us.debian.org/debian/ testing-updates main contrib non-free
gregg_a_g
 
Posts: 4
Joined: 2009-04-05 14:44

Re: Firefox-ESR / Beta

Postby acewiza » 2018-01-30 00:49

A common remedy I've used when things get long in the tooth like that is to delete the application's user profile from the home directory or possibly under ~/.config

Back up bookmarks or other app data you wish to preserve first.
Nobody would ever ask questions If everyone possessed encyclopedic knowledge of the man pages.
User avatar
acewiza
 
Posts: 358
Joined: 2013-05-28 12:38
Location: Out West

Re: Firefox-ESR / Beta

Postby stevepusser » 2018-01-30 01:01

Since you're running a FrankenDebian, the problems could be due to that. What careful pinning precautions have you taken to prevent your creation from running amok?
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: mvp 0.29.0, Pale Moon 28.0.0, wine-staging 3.13, qBittorrent 4.1.2, Linux kernel 4.17.14, virtualbox 5.2.18
User avatar
stevepusser
 
Posts: 9799
Joined: 2009-10-06 05:53

Re: Firefox-ESR / Beta

Postby gregg_a_g » 2018-01-30 01:52

Hi, stevepusser -

By FrankenDebian you mean because I should ONLY have "testing" instead of "Stretch" AND "testing"?
I guess I thought I needed to have both, but I can see now how that could cause a problem. Perhaps miraculously,
never really had an issue before.

I'll fix the sources.list and see if that helps.

One additional symptom I just discovered. Wifey was trying to edit a LibreOffice document and said "nothing's happening" (as she
continued to click the mouse rapidly about 50 times... After I killed the 50+ ooSplash processes I tried to start LibreWriter. The splash
screen appeared for a long time but froze there. I noticed that there were 2 instances of soffice.bin running. I killed the 2nd one and
then the splash screen continued as normal to LibreWriter. Maybe it's all tied to my honked up sources.list.

FYI, I deleted the user profiles and that didn't help at all.

Kind regards,
Gregg G.
gregg_a_g
 
Posts: 4
Joined: 2009-04-05 14:44

Re: Firefox-ESR / Beta

Postby kopper » 2018-01-30 11:22

gregg_a_g wrote:I'll fix the sources.list and see if that helps. .


That would be miraculous if it would save your system, even more so than running FrankenDebian without (obvious) problems for a while. By far the easiest and less hand-holdy method to fix it would be reinstall and restore from backups.
Debian 9.5 Stable with i3
Secure your stuff: Securing Debian Manual
Don't break your stuff: Source List Management DontBreakDebian
kopper
 
Posts: 116
Joined: 2016-09-30 14:30


Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 5 guests

fashionable