[Solved]Mariadb couldn't start. [Error]: Can't init tc log.

Here you can discuss every aspect of Debian. Note: not for support requests!

[Solved]Mariadb couldn't start. [Error]: Can't init tc log.

Postby zoujunc » 2017-09-06 01:25

After upgrading from Jessie to Stretch, I couldn't start my mariadb.service. The error message is '[ERROR]: Can't init tc log'.

After some digging, I find the answer.
I think the problem has been caused due to my /var partition. I had let the partition with /var on get full. I cleaned some space but until i deleted /var/lib/mysql/tc.log, mysql wouldn't start.

Note: If you use 'sudo apt-get upgrade', it will prompt that "mariadb-server-10.1 left unconfigured".
Every little bit matters!
Posts: 19
Joined: 2014-05-29 09:15

Re: [Solved]Mariadb couldn't start. [Error]: Can't init tc l

Postby bretsky84 » 2018-02-10 20:39

THIS! Thank you so much, I ran into this exact issue and this solved it!
Posts: 1
Joined: 2018-02-10 20:37

Return to General Discussion

Who is online

Users browsing this forum: No registered users and 12 guests