System hangs during "failed to evaluate _DSM"

Everything about X, Gnome, KDE, ... and everything running on it

System hangs during "failed to evaluate _DSM"

Postby pierrecdn » 2018-03-29 07:44

Hi,

These days, since the latest buster updates (around mid-march, but my apt-history is quite huge), I have very frequent 1s system freezes.
The mouse is blocked, keyboard is crazy (one keystroke sent multiple times during these events), sometimes gnome crashes, etc. It makes the whole thing partially unusable.

Each time I get a hang, I also have this in dmesg:

ACPI: \_SB_.PCI0.PEG0.VID_: failed to evaluate _DSM


kernel 4.14.0-3 and 4.15 are the same regarding the issue.

I also found the exact same symptom on an archlinux discussion https://www.reddit.com/r/archlinux/comm ... d_freezes/, but trying to downgrade mesa-vdpau-drivers didn't solve anything.
Does anyone has a clue on what's going on? I was unable to find something on a debian-related forum, on bugs.debian.org, etc.

EDIT: in fact, the issue started to appear with Gnome 3.28, but I was also unable to found something clear describing the issue.

Thanks,
Last edited by pierrecdn on 2018-04-01 14:59, edited 1 time in total.
pierrecdn
 
Posts: 8
Joined: 2018-03-29 07:25

Re: System hangs during "failed to evaluate _DSM"

Postby None1975 » 2018-03-29 14:45

Hello. You run Bumblebee? Then check this.
OS: Debian 9.5 / WM: Xmonad
Debian Wiki | DontBreakDebian, My config files in github
Linux User #607425
User avatar
None1975
 
Posts: 673
Joined: 2015-11-29 18:23
Location: Lithuania, Vilnius

Re: System hangs during "failed to evaluate _DSM"

Postby debiman » 2018-03-29 14:50

no mention of the affected hardware, let alone a valid description, neither here nor on that reddit!
no explanation as to why the "solution" would help! could be voodoo just as well!

PS: yes, a preliminary search seems to indicate it has sth to do with bumblebee:
"https://www.startpage.com/do/dsearch?query=ACPI%3A+\_SB_.PCI0.RP05.PEGP%3A+failed+to+evaluate+_DSM"
User avatar
debiman
 
Posts: 3027
Joined: 2013-03-12 07:18

Re: System hangs during "failed to evaluate _DSM"

Postby pierrecdn » 2018-03-30 19:25

I used to run bumblebee but completely removed it, by having a look at these threads. No difference.
I noticed that I got the Gnome 3.28 upgrade as well as mesa-vpdau to 17.3.7, anyone aware of specific issues?

Hardware: Dell Precision M4700, Nvidia Quadro K2000M
pierrecdn
 
Posts: 8
Joined: 2018-03-29 07:25

Re: System hangs during "failed to evaluate _DSM"

Postby pierrecdn » 2018-04-01 14:20

I've downgraded to kernel 4.9 just to check that it's not involved, since I've seen a lot of discussion regarding 4.15 & 4.14.

The dmesg output is different, but the behavior is the same (periodic & frequent ~1s freeze).

[ 522.266034] ACPI Warning: \_SB.PCI0.PEG0.VID._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20160831/nsarguments-95)
[ 522.271152] ACPI: \_SB_.PCI0.PEG0.VID_: failed to evaluate _DSM
[ 522.271164] ACPI Warning: \_SB.PCI0.PEG0.VID._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20160831/nsarguments-95)
[ 522.271906] nouveau 0000:01:00.0: DRM: suspending console...
[ 522.271909] nouveau 0000:01:00.0: DRM: suspending display...
[ 522.271926] nouveau 0000:01:00.0: DRM: evicting buffers...
[ 522.272338] nouveau 0000:01:00.0: DRM: waiting for kernel channels to go idle...
[ 522.272363] nouveau 0000:01:00.0: DRM: suspending client object trees...
[ 522.278480] nouveau 0000:01:00.0: DRM: suspending kernel object tree...
[ 546.025962] nouveau 0000:01:00.0: DRM: resuming kernel object tree...
[ 546.353958] nouveau 0000:01:00.0: DRM: resuming client object trees...
[ 546.354152] nouveau 0000:01:00.0: DRM: resuming display...
[ 546.354221] nouveau 0000:01:00.0: DRM: resuming console...


I'm 100% sure that when I was in 4.9 (a while ago now) I didn't experience this issue.

So it's a package that is responsible, still searching around nouveau, nvidia, ACPI, ... Any advice apreciated.
pierrecdn
 
Posts: 8
Joined: 2018-03-29 07:25

Re: System hangs during "failed to evaluate _DSM"

Postby pierrecdn » 2018-04-01 14:57

OK so actually it seems fixed by doing
Code: Select all
WaylandEnable=false

in /etc/gdm3/daemon.conf

Also, no more "failed to evaluate _DSM" logs, except 1 during boot.

So I guess that the upgrade to Gnome 3.28 (https://www.phoronix.com/scan.php?page= ... 8-Features) had this side-effect in my case (especially thinking about the "Hybrid GPU Support").
I'll try now to understand where does it comes from precisely, I almost don't know anything about the Display/Desktop subsystem in Linux and Debian.
pierrecdn
 
Posts: 8
Joined: 2018-03-29 07:25

Re: System hangs during "failed to evaluate _DSM"

Postby Meow » 2018-04-01 16:55

That's interesting... There is some Wayland support in Debian already.
And it causes quite some problems due to the new bugs it introduces.
I removed part of that, and noticed that gdm3 was removed by that also, indicating that it depends on Wayland.

Sadly there are other bugs that are being introduced for the sake of Wayland compatibility that cannot be fixed by uninstalling some packages.
Cleaning xorg from libinput, which was included just to be Wayland-compatible, for example would require reconfiguration and full rebuild :x
User avatar
Meow
 
Posts: 20
Joined: 2015-04-13 23:32


Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 5 guests

fashionable