Laptop won't boot on kernel 4.9;0-5 or -6

Kernels & Hardware, configuring network, installing services

Laptop won't boot on kernel 4.9;0-5 or -6

Postby logiflow » 2018-05-26 20:33

My laptop will no longer boot on either kernel 4.9.0-5 or 4.9.0-6. I have a Dell Latitude E6430 ATG with 1) an Intel 3rd Gen Core processor Graphics Controller and 2) an NVIDIA G108GLM (NVS 5200M) graphics controller running Debian 9.4. In an attempt to connect my HDMI port to my TV, I used the command "apt-get install bumblebee-nvidia primus" as shown on the webpage. That didn't work---I got no log-in page.

I then uninstalled (purged) bumblebee and primus, and tried to install nouveau, but was told that it was already installed.

When I try to boot in recovery mode (4.9.0-5), I see a stream of sentences moving up the screen faster than I can read, but one appears to say "FAILED to start load Kernel Module". When I view the log, I see a group of four red notes referring to nvidia. Each group appears twice in the log:
1: Error running install command for nvidia_drm
2: Failed to insert "nvidia_drm: Operation not permitted
3: Failed to start Load Kernel Modules
4: Error running install command for nvidia

There are also some bluetooth errors, but I don't use bluetooth anyway.
The log ends with the statement that "The start-up result is done."
With that statement in the log, and since the console seems to work, I don't know if the machine has failed to boot or has just failed to start Gnome, or X, or whatever the graphical interface is. The laptop is useless to me without that graphical interface, and I would greatly appreciate any information that would allow me to correct this problem.
Thank you.
Posts: 13
Joined: 2014-05-08 20:38

Re: Laptop won't boot on kernel 4.9;0-5 or -6

Postby arochester » 2018-05-26 21:01

An oldie, but a goodie - ... ktop-back/


That might get something of a GUI back.
Posts: 1701
Joined: 2010-12-07 19:55

Re: Laptop won't boot on kernel 4.9;0-5 or -6

Postby stevepusser » 2018-05-27 01:03

It sounds like it's an Optimus setup, where the Intel gpu always handles the displays. The Nvidia gpu only does 3d rendering in the background when ordered to--this means you keep using the Intel for any output, including HDMI.

It seems like you created an xorg.conf file which specifies the Nvidia driver, which breaks your video output. You don't need one with Bumblebee. But some Dells don't work with Bumblebee like they're supposed to, also.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: LibreOffice 7.0.0, QMPlay2 20.07.04, Pale Moon 28.12.0, KeepassXC 2.6.0, Arqiver 0.6.0+git, Foliate 2.4.2
User avatar
Posts: 11891
Joined: 2009-10-06 05:53

Re: Laptop won't boot on kernel 4.9;0-5 or -6

Postby kevinthefixer » 2018-05-27 19:08

Might be possible to fix that. Recommend a clean install, just to keep things, well, clean. And leave the video drivers alone after that!
Posts: 190
Joined: 2018-05-05 22:30

Re: Laptop won't boot on kernel 4.9;0-5 or -6

Postby logiflow » 2018-05-29 19:17

Thanks for your inputs. I haven't made any progress yet, but have encountered some problems that I didn't expect:
[list=]1. I can't find an xorg.conf file anywhere.
2. I'm not sure that the "find" command searches everywhere xorg.conf could be.
3. I don't know how to list the contents of a text file without a display.
4. The command "aptitude build-dep" in Solution Two of doesn't specify a package as is required
5. The command Xorg -configure fails. See the following output:[/list]

Code: Select all
root@DELLDEB:/# Xorg -configure

X.Org X Server 1.19.2
Release Date:  2017-03-02
X Protocol Version 11, Revision 0
Build Operating System:  Linux 4.9.0-4-amd64 x86_64 Debian
Current Operating System: Linux DELLDEB 4.9.0-6-amd64 #1 SMP Debian 4.9.88-1+deb9u1 (2018-05-07) x86-64
Kernel command line:  BOOT_IMAGE=/vmlinuz-4.9.0-6-amd64 root=/dev/mapper/DELLDEB--vg-root ro quiet
Build Date: 16 October 2017  08:19:45AM
xorg-server 2:1.19.2-1+deb9u2 (
Current version of pixman: 0.34.0
      Before reporting problems, check
       to make sure you have the latest version.
Markers:  (--) probed, (**) from config file, (==) default setting,
               (++) from command line, (!!) notice, (II) informational,
              (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file:  "/var/log/Xorg.0.log", Time:  Tue May 29 13:26:51 2018
List of video drivers:
Posts: 13
Joined: 2014-05-08 20:38

Re: Laptop won't boot on kernel 4.9;0-5 or -6

Postby logiflow » 2018-05-29 19:30

To continue: (why this thing posted before I was finished, I don't know)
Code: Select all
(++)  Using config file:  "/root/"
(==)  Using system conig directory "/usr/share/X11/xorg.conf.d"
Number off created screens does not match number of detected devices.
     Configuration failed.
(EE)  Server terminated with error (2).  Closing log file.

After typing the code, it looks like the xorg.conf.xx files were used instead of just the xorg.conf file, and that they were in the wrong directories. What is the best way to correct this, and to get rid of nvidia?
Posts: 13
Joined: 2014-05-08 20:38

Re: Laptop won't boot on kernel 4.9;0-5 or -6

Postby bw123 » 2018-05-29 19:42

Don't worry about the build-dep or the Xorg -configure. Try to let X do it's thing automatically if possible.

Code: Select all
# find / -name xorg.conf
# cat /usr/share/doc/xserver-xorg-video-intel/xorg.conf
Section "Device"
        Identifier "Intel"
        Driver "intel"
#       Option "AccelMethod" "uxa"

rename or mv any you find besides this one.
User avatar
Posts: 3786
Joined: 2011-05-09 06:02

Re: Laptop won't boot on kernel 4.9;0-5 or -6

Postby logiflow » 2018-05-29 21:04

Thanks for your quick response, bw123. I used your code and saw exactly what you showed. Yet when I reboot, I still get references to nvidia in the boot journal, and no GUI. The nvidia references:
Code: Select all
    DELLDEB kernel:  nvidia:  loading out-of-tree module taints kernel.
    DELLDEB kernel:  nvidia:  module license 'NVIDIA' taints kernel.
    DELLDEB kernel:  Disabling lock debugging due to kernel taint.
    DELLDEB kernel:  nvidia 0000:01:00.0: enabling device (0004 -> 0007)
    DELLDEB kernel:  nvidia-nvlink: Nvlink Core is being initialized, major device number 247
    DELLDEB kernel:  NVRM: loading NVIDIA UNIX x86_64 Kernel Module 375.82 Wed Jul 19 21:16:49 PDT 2017 (using threaded interrupts)
    DELLDEB kernel:  nvidia-modeset:  Loading NVIDIA Kernel Mode Setting Driver for UNIX platforms 375.82 Wed Jul 19 20:35:11PDT 2017

As I recall, NVIDIA doesn't want an xorg.conf file and apparently the booting process doesn't look at the one you show in your reply. I think there must be some NVIDIA stuff somewhere that purging NVIDIA with apt-get doesn't purge. Do you think copying the xorg.conf file to the /etc/X11 directory would supersede the NVIDIA stuff during boot? Or, do you have any idea of how to get rid of NVIDIA stuff?
Posts: 13
Joined: 2014-05-08 20:38

Re: Laptop won't boot on kernel 4.9;0-5 or -6

Postby bw123 » 2018-05-29 21:16

I really could not say. There are instructions that may or may not help in the wiki on how to remove nvidia in case of failure. I think you should probably update-initramfs at some point? ... of_failure

also this
Troubleshooting * The NVIDIA driver conflicts with the nouveau DRM driver (580894). The nouveau kernel module is blacklisted by the glx-alternative-nvidia or nvidia-kernel-common packages.

So I guess check for a blacklist, there a couple of ways it might be done I think. modprobe.d and a modules file as I recall...

There's also a newer nvidia-driver in backports. May or may not help.

Sorry about your troubles, this is why I'll never own an nvidia board. I've read literally hundreds of these threads. Sad state for such a great company. They need some help.
User avatar
Posts: 3786
Joined: 2011-05-09 06:02

Re: Laptop won't boot on kernel 4.9;0-5 or -6

Postby logiflow » 2018-05-30 01:29

Thanks a MILLION, bw123! The steps in the "" website that you showed in your reply worked!

I consider this problem SOLVED.

One thing I would like to point out: Something altered my
file. Where I had entries of
, the file now reads
. In other words, everywhere I had "ftp" in a source address, there is now "httpredir" instead. This caused me to get messages about not being able to access sources when I used the --reinstall option in the commands. It still worked, but I think I'll have to redo my sources.list to keep Debian up to date.

Thanks again.
Posts: 13
Joined: 2014-05-08 20:38

Return to System configuration

Who is online

Users browsing this forum: No registered users and 7 guests