Cant fix packages!!! I need help!

If it doesn't relate to Debian, but you still want to share it, please do it here

Cant fix packages!!! I need help!

Postby Awesomegamer656 » 2018-07-02 20:31

im using the command
Code: Select all
sudo apt-get -f install
this is what it shows:
Code: Select all
The following packages have unmet dependencies:
 apt-utils : Depends: apt (= 1.4.8) but 1.0.9.8.4 is installed
             Depends: libapt-pkg5.0 (>= 1.3~rc2) but it is not installable
             Depends: libstdc++6 (>= 5.2) but 4.9.2-10+deb8u1 is installed
 aptitude : Depends: aptitude-common (= 0.6.11-1) but 0.8.7-1 is installed
            Recommends: aptitude-doc-en but it is not installed or
                        aptitude-doc
            Recommends: libparse-debianchangelog-perl but it is not installed
 cclive : Depends: libboost-date-time1.54.0 but it is not installable
 gstreamer1.0-plugins-bad : Depends: libopencv-core2.4 but it is not installed
 gvfs-backends : Depends: libgphoto2-6 (>= 2.5.10) but 2.5.4-1.1 is installed
                 Depends: libgphoto2-port12 (>= 2.5.10) but it is not installable
                 Depends: libimobiledevice6 (>= 1.1.5) but it is not installable
                 Depends: libmtp9 (>= 1.1.12) but 1.1.8-1+b1 is installed
                 Depends: libnfs8 (>= 1.9.7) but it is not installable
                 Depends: libplist3 (>= 1.11) but it is not installable
                 Recommends: gnome-keyring but it is not installed
 idle3 : Depends: idle-python3.5 but it is not installable
 libalgorithm-diff-xs-perl : Depends: perlapi-5.20.0
 libapt-inst2.0 : Depends: libapt-pkg5.0 (>= 1.1~exp9) but it is not installable
                  Depends: libstdc++6 (>= 5.2) but 4.9.2-10+deb8u1 is installed
 libboost-date-time1.55-dev : Depends: libboost-date-time1.55.0 (= 1.55.0+dfsg-3) but it is not installed
 libboost-date-time1.62.0 : Depends: libstdc++6 (>= 5.2) but 4.9.2-10+deb8u1 is installed
 libboost-filesystem1.62.0 : Depends: libstdc++6 (>= 5.2) but 4.9.2-10+deb8u1 is installed
 libboost-iostreams1.62.0 : Depends: libstdc++6 (>= 5.2) but 4.9.2-10+deb8u1 is installed
 libboost-program-options1.62.0 : Depends: libstdc++6 (>= 5.2) but 4.9.2-10+deb8u1 is installed
 libboost-system1.62.0 : Depends: libstdc++6 (>= 5.2) but 4.9.2-10+deb8u1 is installed
 libclass-c3-xs-perl : Depends: perlapi-5.20.0
 libcmis-0.4-4 : Depends: libboost-date-time1.55.0 but it is not installed
 libdatetime-perl : Depends: perlapi-5.20.0
 libfile-fcntllock-perl : Depends: perlapi-5.20.0
 libicu57 : Depends: libstdc++6 (>= 5.2) but 4.9.2-10+deb8u1 is installed
 libkolab0 : Depends: libkolabxml1 (>= 1.0.1) but it is not installed
 liblist-moreutils-perl : Depends: perlapi-5.20.0
 libopencv-calib3d2.4 : Depends: libopencv-core2.4 but it is not installed
 libopencv-contrib2.4 : Depends: libopencv-core2.4 but it is not installed
 libopencv-features2d2.4 : Depends: libopencv-core2.4 but it is not installed
 libopencv-flann2.4 : Depends: libopencv-core2.4 (= 2.4.9.1+dfsg-1+deb8u1) but it is not installed
 libopencv-highgui2.4 : Depends: libopencv-core2.4 but it is not installed
 libopencv-imgproc2.4 : Depends: libopencv-core2.4 (= 2.4.9.1+dfsg-1+deb8u1) but it is not installed
 libopencv-legacy2.4 : Depends: libopencv-core2.4 but it is not installed
 libopencv-ml2.4 : Depends: libopencv-core2.4 (= 2.4.9.1+dfsg-1+deb8u1) but it is not installed
 libopencv-objdetect2.4 : Depends: libopencv-core2.4 but it is not installed
 libopencv-video2.4 : Depends: libopencv-core2.4 but it is not installed
 libparams-validate-perl : Depends: perlapi-5.20.0
 libproxy1v5 : Depends: libstdc++6 (>= 5.2) but 4.9.2-10+deb8u1 is installed
 libreoffice-base : Depends: libreoffice-base-core (= 1:5.2.7-1+deb9u4) but 1:4.3.3-2+rpi4 is installed
                    Depends: libreoffice-base-drivers (= 1:5.2.7-1+deb9u4) but 1:4.3.3-2+rpi4 is installed
                    Depends: libreoffice-core (= 1:5.2.7-1+deb9u4) but 1:4.3.3-2+rpi4 is installed
                    Depends: libstdc++6 (>= 5) but 4.9.2-10+deb8u1 is installed
                    Depends: uno-libs3 (>= 5.1.0~alpha) but 4.3.3-2+rpi4 is installed
                    Recommends: libreoffice-java-common (>= 1:5.2.7~) but 1:4.3.3-2+rpi4 is installed
 libreoffice-calc : Depends: libreoffice-base-core (= 1:5.2.7-1+deb9u4) but 1:4.3.3-2+rpi4 is installed
                    Depends: libreoffice-core (= 1:5.2.7-1+deb9u4) but 1:4.3.3-2+rpi4 is installed
                    Depends: coinor-libcoinmp1v5 but it is not installable
                    Depends: coinor-libcoinutils3v5 but it is not installable
                    Depends: liborcus-0.11-0 but it is not installable
                    Depends: libstdc++6 (>= 5.2) but 4.9.2-10+deb8u1 is installed
                    Depends: libwps-0.4-4 but it is not installable
                    Depends: uno-libs3 (>= 5.1.0~alpha) but 4.3.3-2+rpi4 is installed
 libreoffice-common : Recommends: xfonts-mathml but it is not installable
                      Breaks: libreoffice-style-galaxy (>= 1:4.4~) but 1:5.2.7-1+deb9u4 is installed
 libreoffice-core : Depends: libboost-date-time1.55.0 but it is not installed
 libreoffice-draw : Depends: libreoffice-core (= 1:5.2.7-1+deb9u4) but 1:4.3.3-2+rpi4 is installed
                    Depends: libpagemaker-0.0-0 but it is not installed
                    Depends: libstdc++6 (>= 5.2) but 4.9.2-10+deb8u1 is installed
                    Depends: uno-libs3 (>= 5.1.0~alpha) but 4.3.3-2+rpi4 is installed
 libreoffice-impress : Depends: libreoffice-core (= 1:5.2.7-1+deb9u4) but 1:4.3.3-2+rpi4 is installed
                       Depends: libglew2.0 (>= 1.12.0) but it is not installable
                       Depends: libstdc++6 (>= 5) but 4.9.2-10+deb8u1 is installed
                       Depends: uno-libs3 (>= 5.1.0~alpha) but 4.3.3-2+rpi4 is installed
 libreoffice-style-galaxy : Depends: libreoffice-common (= 1:5.2.7-1+deb9u4) but 1:4.3.3-2+rpi4 is installed
 libreoffice-writer : Depends: libreoffice-base-core (= 1:5.2.7-1+deb9u4) but 1:4.3.3-2+rpi4 is installed
                      Depends: libreoffice-core (= 1:5.2.7-1+deb9u4) but 1:4.3.3-2+rpi4 is installed
                      Depends: libstdc++6 (>= 5.2) but 4.9.2-10+deb8u1 is installed
                      Depends: libwps-0.4-4 but it is not installable
                      Depends: uno-libs3 (>= 5.1.0~alpha) but 4.3.3-2+rpi4 is installed
 libsocket6-perl : Depends: perlapi-5.20.0
 libstdc++-6-dev : Depends: libstdc++6 (>= 6.3.0-18+deb9u1) but 4.9.2-10+deb8u1 is installed
 libtext-iconv-perl : Depends: perlapi-5.20.0
 libtext-soundex-perl : Depends: perlapi-5.20.0
 libudev-dev : Depends: libudev1 (= 232-25+deb9u3) but 215-17+deb8u7 is installed
 libusb-1.0-0-dev : Depends: libusb-1.0-0 (= 2:1.0.21-1) but 2:1.0.19-1 is installed
                    Recommends: libusb-1.0-doc but it is not installed
 python-gi-dev : Depends: python-gi (= 3.22.0-2) but 3.14.0-1 is installed
 python-gobject-2-dev : Depends: python-gobject-2 (>= 2.28.6-13) but 2.28.6-12 is installed
 python3-apt : Depends: libapt-pkg5.0 (>= 1.4~beta3) but it is not installable
               Depends: libstdc++6 (>= 5.2) but 4.9.2-10+deb8u1 is installed
 python3-automationhat : Depends: python3-rpi.gpio but it is not installed
 python3-blinkt : Depends: python3-rpi.gpio but it is not installed
 python3-cap1xxx : Depends: python3-rpi.gpio but it is not installed
 python3-cffi : Depends: python3-cffi-backend (< 1.9.1-2+c) but it is not installable
                Depends: python3-cffi-backend (>= 1.9.1-2) but it is not installable
 python3-cryptography : Depends: python3-cffi-backend-api-min (<= 9729) but it is not installable
                        Depends: python3-cffi-backend-api-max (>= 9729) but it is not installable
                        Depends: python3-idna (>= 2.0) but it is not installable
                        Depends: python3-pyasn1 (>= 0.1.8) but it is not installed
 python3-dev : Depends: libpython3-dev (= 3.5.3-1) but 3.4.2-2 is installed
               Depends: python3.5-dev (>= 3.5.3-1~) but it is not installable
 python3-envirophat : Depends: python3-rpi.gpio but it is not installed
 python3-gi : Depends: libgirepository-1.0-1 (>= 1.44.0) but 1.42.0-2.2 is installed
 python3-motephat : Depends: python3-rpi.gpio but it is not installed
 python3-phatbeat : Depends: python3-rpi.gpio but it is not installed
 python3-pil : Depends: libwebp6 (>= 0.5.1) but it is not installable
               Depends: libwebpdemux2 (>= 0.5.1) but it is not installable
               Depends: libwebpmux2 (>= 0.5.1) but it is not installable
 python3-pt-inventor : Depends: python3-rpi.gpio but it is not installed
 python3-pyqt4 : Depends: libstdc++6 (>= 5) but 4.9.2-10+deb8u1 is installed
 python3-rainbowhat : Depends: python3-rpi.gpio but it is not installed
 python3-systemd : Depends: libsystemd0 (>= 230) but 215-17+deb8u7 is installed
 python3-uno : Depends: libreoffice-core (= 1:5.2.7-1+deb9u4) but 1:4.3.3-2+rpi4 is installed
               Depends: libstdc++6 (>= 5) but 4.9.2-10+deb8u1 is installed
               Depends: uno-libs3 (>= 5.1.0~alpha) but 4.3.3-2+rpi4 is installed
 python3-zmq : Depends: libzmq5 (>= 4.1.2) but it is not installable
 software-properties-kde : Depends: python3-pyqt5 but it is not installed
                           Depends: python3-software-properties (= 0.96.20.2-1) but 0.92.25debian1 is installed
 wolframscript : Depends: libboost-date-time1.55.0 but it is not installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies
Awesomegamer656
 
Posts: 10
Joined: 2018-06-29 23:52

Re: Cant fix packages!!! I need help!

Postby Head_on_a_Stick » 2018-07-02 20:36

Firstly, please remove the exclamation marks and redundant plea from the thread title, they are superfluous and unseemly.

Secondly, for any dependency related problem, always post your sources:
Code: Select all
apt policy
User avatar
Head_on_a_Stick
 
Posts: 8010
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Cant fix packages!!! I need help!

Postby bw123 » 2018-07-02 21:15

...
apt-utils : Depends: apt (= 1.4.8) but 1.0.9.8.4 is installed
...


translation:
jessie ver is installed, but it needs stretch ver
https://packages.debian.org/search?keywords=apt

don't make frankendebian and make everybody on here watch while you destroy your computer.

it's a waste of people's time.
User avatar
bw123
 
Posts: 3414
Joined: 2011-05-09 06:02
Location: TN_USA

Re: Cant fix packages!!! I need help!

Postby stevepusser » 2018-07-02 23:48

Probably be from the other thread where I suggested trying to install Jessie's boost 1.55 on Stretch raspian for Emulationstation. That now seems to have not been the best advice :( , and RetroPie is the better option.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Kdenlive 18.08.1, Pale Moon 28.1.0, wine-staging 3.17, qBittorrent 4.1.3, Liquorix kernel 4.18-13, Audacity 2.3.0
User avatar
stevepusser
 
Posts: 10012
Joined: 2009-10-06 05:53


Return to Offtopic

Who is online

Users browsing this forum: No registered users and 3 guests

fashionable