Touchpad stops working randomly.

Getting your soundcard to work, using Debian on non-i386 hardware, etc

Touchpad stops working randomly.

Postby Coline » 2018-02-25 09:04


The touchpad of my Acer Swift 1 stops working randomly. I don't really know what to do about that.

  • It happens when I'm using Firefox (but I only use this PC for that, so...)
  • I was using xserver-xorg-input-libinput when the problems first appears.
  • I have installed xserver-xorg-input-synaptics, but the problem still appears.
  • It doesn't stop working a lot...Maybe 3 times in the past week.
  • I don't do something special.
  • I can't move the cursor.
  • The "Tap button" doesn't work but I didn't try the physical button for the moment
  • I didn't try to connect a mouse. (I'm going to test next time)
  • If I close the lid, the PC goes in suspend and when I wake the PC, the touchpad works.
  • I tried to let the PC in idle (maybe a power manager thing...), but it doesn't create the bug...
  • The keyboard works when the problem appears.

I don't really know what to look and what to do. Could it be a hardware problem ? (The PC is new)

Thanks for your suggestions ! :)
Posts: 66
Joined: 2014-09-09 04:51

Re: Touchpad stops working randomly.

Postby bw123 » 2018-02-25 11:06

Coline wrote:Could it be a hardware problem ?
User avatar
Posts: 3786
Joined: 2011-05-09 06:02

Re: Touchpad stops working randomly.

Postby Coline » 2018-02-25 12:12

Thanks for the word "freezing". I didn't think about this one when I was searching for similar issues. :)

So, I guess the problem is "hardware". I can't do anything to make it work perfectly. I think I have to send the laptop to the manufacturer...:(

I can't find a lot of similar problems on Windows. It seems like a Linux-issue...

EDIT : Actually, when I use synclient, it says : Couldn't find synaptics propreties. No synaptics driver loaded.
I thought installing xserver-xorg-input-synaptics would be enough, but I was wrong.
I've created a file : /etc/X11/xorg.conf.d/50-synaptics.conf, it works.
Posts: 66
Joined: 2014-09-09 04:51

Re: Touchpad stops working randomly.

Postby debiman » 2018-02-27 07:05

maybe this isn't a synaptics touchpad?
it requires a different driver?
User avatar
Posts: 3064
Joined: 2013-03-12 07:18

Re: Touchpad stops working randomly.

Postby emariz » 2018-02-27 13:25

libinput10 and libinput-bin landed at Testing last week, what caused issues on my laptop (lack of precision being the worst.) There are no bug reports on the Debian Bug Tracker, but there are countless bug reports upstream. [1]
This system uses the driver xserver-xorg-input-libinput.

I had to downgrade both libraries (from version 1.10.0-1 to 1.9.4-2) using Debian Snapshot [2], and then put them on hold within Aptitude.

This may be related to your problem.

1. ... t=libinput
Posts: 2926
Joined: 2008-10-17 07:59

Re: Touchpad stops working randomly.

Postby pylkko » 2018-02-27 18:02

Could also be a grounding issue with the laptop power supply. I have seen something like this happen on an old laptop with a bad psu. The touchpad would stop working apparently randomly and sometimes slow down or other such thing. Then it would work normally whenever the power supply was not attached and the laptop was on battery. After switching the PSU to a new one (with supposedly proper capacitance grounding) it worked again. This problem may be hard to diagnose, as in this case that I am referring to, the problems would occur only when the psu was inserted in some power sockets, but not in other ones.
User avatar
Posts: 1769
Joined: 2014-11-06 19:02

Re: Touchpad stops working randomly.

Postby macky » 2018-12-29 17:18

Hello I have this similar issue in windows but I think it's a similar thing your problem, it's must be an update made such us os update or kernel update,

"Only my experience on windows":
I have experience such thing when I upgrade from windows 8 to windows 10 my laptop touchpad didn't work and there's no driver available for it, so I'm guessing that's a similar thing happened to you, did you update any from your machine? If it's there's should be a new repository for a new driver a proper one that will match to your current system and it needed to be manually update, or you can:

Code: Select all
aptitude update or sudo apt-get update

Then check if will work again.
Posts: 7
Joined: 2018-11-11 16:18

Return to Hardware

Who is online

Users browsing this forum: No registered users and 8 guests