bad firmware for Qualcomm Atheros QCA9377

Getting your soundcard to work, using Debian on non-i386 hardware, etc

bad firmware for Qualcomm Atheros QCA9377

Postby jack25 » 2019-01-06 18:53

Hi,
I just installed debian stretch (9.6.0) on my asus vivobook and having a firmware for my wifi card seem to be required.

Code: Select all
root@vivo:/home/jacques# lspci | grep Ath
02:00.0 Network controller: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter (rev 31)


So i installed firmware-atheros (latest version: 20180825+dfsg-1~bpo9+1)

the required firmware is indeed present in my /lib/firmware/ath10k/QCA9377 !

however I still have trouble while booting, and still no WiFi

Code: Select all
root@vivo:/home/jacques# dmesg|grep -iE 'firmware|ath'
[    0.041331] Spectre V2 : Enabling Restricted Speculation for firmware calls
[    8.869648] ath10k_pci 0000:02:00.0: pci irq msi oper_irq_mode 2 irq_mode 0 reset_mode 0
[    9.230823] ath10k_pci 0000:02:00.0: firmware: failed to load ath10k/pre-cal-pci-0000:02:00.0.bin (-2)
[    9.231542] ath10k_pci 0000:02:00.0: Direct firmware load for ath10k/pre-cal-pci-0000:02:00.0.bin failed with error -2
[    9.231551] ath10k_pci 0000:02:00.0: firmware: failed to load ath10k/cal-pci-0000:02:00.0.bin (-2)
[    9.232315] ath10k_pci 0000:02:00.0: Direct firmware load for ath10k/cal-pci-0000:02:00.0.bin failed with error -2
[    9.249508] ath10k_pci 0000:02:00.0: firmware: direct-loading firmware ath10k/QCA9377/hw1.0/firmware-5.bin
[    9.249512] ath10k_pci 0000:02:00.0: qca9377 hw1.1 target 0x05020001 chip_id 0x003821ff sub 1a3b:2231
[    9.249514] ath10k_pci 0000:02:00.0: kconfig debug 0 debugfs 0 tracing 0 dfs 0 testmode 0
[    9.249926] ath10k_pci 0000:02:00.0: firmware ver WLAN.TF.1.0-00002-QCATFSWPZ-5 api 5 features ignore-otp crc32 c3e0d04f
[    9.300838] [drm] GuC firmware load skipped
[    9.311526] ath10k_pci 0000:02:00.0: board id is not exist in otp, ignore it
[    9.456090] i915 0000:00:02.0: firmware: direct-loading firmware i915/kbl_dmc_ver1_01.bin
[    9.778411] ath10k_pci 0000:02:00.0: firmware: direct-loading firmware ath10k/QCA9377/hw1.0/board-2.bin
[    9.778578] ath10k_pci 0000:02:00.0: board_file api 2 bmi_id N/A crc32 8aedfa4a
[   12.012513] ath10k_pci 0000:02:00.0: firmware crashed! (uuid n/a)
[   12.012537] ath10k_pci 0000:02:00.0: qca9377 hw1.1 target 0x05020001 chip_id 0x003821ff sub 1a3b:2231
[   12.012538] ath10k_pci 0000:02:00.0: kconfig debug 0 debugfs 0 tracing 0 dfs 0 testmode 0
[   12.012952] ath10k_pci 0000:02:00.0: firmware ver WLAN.TF.1.0-00002-QCATFSWPZ-5 api 5 features ignore-otp crc32 c3e0d04f
[   12.013113] ath10k_pci 0000:02:00.0: board_file api 2 bmi_id N/A crc32 8aedfa4a
[   12.013114] ath10k_pci 0000:02:00.0: htt-ver 0.0 wmi-op 4 htt-op 3 cal otp max-sta 32 raw 0 hwcrypto 1
[   12.015414] ath10k_pci 0000:02:00.0: firmware register dump:
[   12.015431] ath10k_pci 0000:02:00.0: [00]: 0x05020001 0x00000000 0x00A0F77C 0x00000000
[   12.015450] ath10k_pci 0000:02:00.0: [04]: 0x00A0F77C 0x00060130 0x00000010 0xFFFFE000
[   12.015469] ath10k_pci 0000:02:00.0: [08]: 0x0042136C 0x0040EA1B 0x00400000 0x00400000
[   12.015488] ath10k_pci 0000:02:00.0: [12]: 0x00000000 0x00000000 0x00952CD0 0x00952CE6
[   12.015507] ath10k_pci 0000:02:00.0: [16]: 0x00000002 0x01010101 0x00000003 0x0000000A
[   12.015526] ath10k_pci 0000:02:00.0: [20]: 0x00000328 0x00429880 0x009A37AC 0x00000032
[   12.015545] ath10k_pci 0000:02:00.0: [24]: 0x800A0D0A 0x0040EA88 0x00420170 0x004173B0
[   12.015563] ath10k_pci 0000:02:00.0: [28]: 0x00401F64 0x00401F68 0x00000000 0x00417550
[   12.015582] ath10k_pci 0000:02:00.0: [32]: 0x00401FC0 0x94D3C5D0 0x0040AB9B 0x00000003
[   12.015601] ath10k_pci 0000:02:00.0: [36]: 0x800A0907 0x00000001 0x0000085B 0x339011B2
[   12.015620] ath10k_pci 0000:02:00.0: [40]: 0x0000FFFE 0x0000000A 0x009BFE28 0x009BE0DC
[   12.015638] ath10k_pci 0000:02:00.0: [44]: 0x800A0D0A 0x0040EA88 0x00420170 0x004173B0
[   12.015657] ath10k_pci 0000:02:00.0: [48]: 0x00400000 0x00400000 0x00000001 0xFFFFFFFF
[   12.015676] ath10k_pci 0000:02:00.0: [52]: 0x800A0614 0x0040EAA8 0x0041FA10 0x00420170
[   12.015695] ath10k_pci 0000:02:00.0: [56]: 0x00400000 0x00421370 0x00419980 0x004212E8
[   13.024105] ath10k_pci 0000:02:00.0: failed to receive control response completion, polling..
[   14.044151] ath10k_pci 0000:02:00.0: ctl_resp never came in (-110)
[   14.044220] ath10k_pci 0000:02:00.0: failed to connect to HTC: -110
[   14.047345] ath10k_pci 0000:02:00.0: could not init core (-110)
[   14.047458] ath10k_pci 0000:02:00.0: could not probe fw (-110)
[   14.068135] ath10k_pci 0000:02:00.0: cannot restart a device that hasn't been started


So to my understanding ath10k/pre-cal-pci-0000:02:00.0.bin seems to bee missing (a find / on my computer does not show any..).
Do you have any idea on how I could have it work?

Thank you in advance
jack25
 
Posts: 1
Joined: 2019-01-06 18:33



Return to Hardware

Who is online

Users browsing this forum: No registered users and 6 guests

fashionable
cron