[SOLVED] Debian Stretch 9.4 automatic volume reduction

If none of the more specific forums is the right place to ask

Re: Debian Stretch 9.4 automatic volume reduction

Postby debiman » 2018-10-05 18:37

thank you for your patience, bw123.
i gave up around here...
User avatar
debiman
 
Posts: 3064
Joined: 2013-03-12 07:18

Re: Debian Stretch 9.4 automatic volume reduction

Postby that1guy » 2018-10-05 19:49

bw123 wrote:Okay, here's my advice:

On a clean debian stable install:
Confirm the volume is changed when headphone plugged in after purging pulseaudio

p.s. yea i'm your daddy

p.p.s.stillwaiting to find out what the ubuntu thing(s) you installed when you wasn't paying attention? might be in /var/log/apt/history.log


well since you're not getting paid to help, I can see why you enjoy trying to provoke reactions in others.

Proof: You'll respond to this.


debiman wrote:thank you for your patience, bw123.
i gave up around here...


Cool, have a nice day.
that1guy
 
Posts: 19
Joined: 2018-09-28 23:59

Re: Debian Stretch 9.4 automatic volume reduction

Postby that1guy » 2019-01-13 02:35

Just reinstalled debian, and the same issue persists. I played a youtube video on firefox on a fresh startup, as soon as plugged in my speaker jack, the volume dropped down low after about 1 second. Same thing with headphones and anything audio related. I am not finding any solutions anywhere, let alone anyone else going through the same thing.
that1guy
 
Posts: 19
Joined: 2018-09-28 23:59

SOLVED

Postby that1guy » 2019-01-13 08:21

Ok mark this as solved.

command:

apt-get -t stretch-backports install linux-image-amd64

I discovered this by avoiding the old method of making my wifi work like I would during previous installments of debian by using many commands. All I had to do was update the one thing above, and I got my wifi working AND the volume reduction is gone. :lol: If others had this problem, there's the solution.

After install debian stretch 9, my wifi wouldn't work. So i'd find a work around forcing the firmware to be install through terminal.

Taken directly from another post in another forum:

If it has been added only starting from the 4.14 kernel (and not backported), then Debian 9's 4.9 kernel is not good enough (indeed there's no CONFIG_R8822BE option enabled in Debian 4.9.0-8-amd64 kernel when looking in the config file).

You already got the package having the firmware from stretch-backports, but that's not enough: you must also add the stretch-backports repository and get the newer kernel from it, which will make use of the firmware.

In an non chicken-and-eggs problem that would be, once set up after following previously linked instructions:

apt-get -t stretch-backports install linux-image-amd64
that1guy
 
Posts: 19
Joined: 2018-09-28 23:59

Re: Debian Stretch 9.4 automatic volume reduction

Postby kevinthefixer » 2019-01-13 22:36

So please edit your OP's title to reflect its solved status. While you're at it, could you tell us what audio hardware you have?
Code: Select all
inxi -A
kevinthefixer
 
Posts: 190
Joined: 2018-05-05 22:30

Re: Debian Stretch 9.4 automatic volume reduction

Postby that1guy » 2019-01-13 23:24

kevinthefixer wrote:So please edit your OP's title to reflect its solved status. While you're at it, could you tell us what audio hardware you have?
Code: Select all
inxi -A


inxi isn't a valid command on my system;

arecord -l
**** List of CAPTURE Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC295 Analog [ALC295 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0

and...

lspci | grep -i audio
00:1f.3 Audio device: Intel Corporation Sunrise Point-LP HD Audio (rev 21)
that1guy
 
Posts: 19
Joined: 2018-09-28 23:59

Re: [SOLVED] Debian Stretch 9.4 automatic volume reduction

Postby kevinthefixer » 2019-01-14 00:50

Code: Select all
apt install inxi

Somehow I'm not surprised it's Intel audio. inxi can come in very useful.
kevinthefixer
 
Posts: 190
Joined: 2018-05-05 22:30

Previous

Return to General Questions

Who is online

Users browsing this forum: No registered users and 14 guests

fashionable