[SOLVED] Libreoffice broken install

Everything about X, Gnome, KDE, ... and everything running on it

[SOLVED] Libreoffice broken install

Postby Snaerulfr » 2019-02-04 23:57

Hi!
I recently ran an upgrade of libreoffice with apt, but libreoffice-common did not upgrade. This has led to me being completely unable to do anything at all with my libreoffice install, including using purge or remove. While I can still (thankfully) use the software itself, this is bugging me beyond belief. Is there anything I can do?
I should add that --fix-broken install did nothing. I have root.
Thanks
Last edited by Snaerulfr on 2019-02-05 22:37, edited 1 time in total.
Snaerulfr
 
Posts: 10
Joined: 2019-02-04 23:54
Location: /eur/nor/bergen

Re: Libreoffice broken install

Postby shep » 2019-02-05 00:50

Libreoffice is a large, complex application. If your upgrade was incomplete an easy way to fix is to autoremove libreoffice and re-install. I would also peruse the server specified in your /etc/apt/sources.list to see if it has the upgraded libreoffice-common package. Your server may have been in the process of syncing during your upgrade.
shep
 
Posts: 306
Joined: 2011-03-15 15:22

Re: Libreoffice broken install

Postby Head_on_a_Stick » 2019-02-05 07:15

What does this say
Code: Select all
apt policy
apt policy libreoffice-common
aptitude purge --simulate libreoffice-common
User avatar
Head_on_a_Stick
 
Posts: 10382
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Libreoffice broken install

Postby Snaerulfr » 2019-02-05 08:39

shep - I tried that, it didn't work.

Head_on_a_stick -
apt policy yielded the following:
Code: Select all
Package files:
 100 /var/lib/dpkg/status
     release a=now
 500 http://packages.microsoft.com/repos/vscode stable/main amd64 Packages
     release o=vscode stable,a=stable,n=stable,l=vscode stable,c=main,b=amd64
     origin packages.microsoft.com
 500 http://repo.steampowered.com/steam precise/steam i386 Packages
     release o=Valve Software LLC,n=precise,l=Steam,c=steam,b=i386
     origin repo.steampowered.com
 500 http://repo.steampowered.com/steam precise/steam amd64 Packages
     release o=Valve Software LLC,n=precise,l=Steam,c=steam,b=amd64
     origin repo.steampowered.com
 500 http://repository.spotify.com stable/non-free i386 Packages
     release v=0.4,o=Spotify LTD,a=stable,n=stable,l=Spotify Public Repository,c=non-free,b=i386
     origin repository.spotify.com
 500 http://repository.spotify.com stable/non-free amd64 Packages
     release v=0.4,o=Spotify LTD,a=stable,n=stable,l=Spotify Public Repository,c=non-free,b=amd64
     origin repository.spotify.com
 500 https://repo.skype.com/deb stable/main amd64 Packages
     release o=. stable,a=stable,n=stable,l=. stable,c=main,b=amd64
     origin repo.skype.com
 500 http://dl.google.com/linux/chrome/deb stable/main amd64 Packages
     release v=1.0,o=Google LLC,a=stable,n=stable,l=Google,c=main,b=amd64
     origin dl.google.com
 500 http://ftp.uk.debian.org/debian stretch-updates/main i386 Packages
     release o=Debian,a=stable-updates,n=stretch-updates,l=Debian,c=main,b=i386
     origin ftp.uk.debian.org
 500 http://ftp.uk.debian.org/debian stretch-updates/main amd64 Packages
     release o=Debian,a=stable-updates,n=stretch-updates,l=Debian,c=main,b=amd64
     origin ftp.uk.debian.org
 500 http://security.debian.org/debian-security stretch/updates/non-free i386 Packages
     release v=9,o=Debian,a=stable,n=stretch,l=Debian-Security,c=non-free,b=i386
     origin security.debian.org
 500 http://security.debian.org/debian-security stretch/updates/non-free amd64 Packages
     release v=9,o=Debian,a=stable,n=stretch,l=Debian-Security,c=non-free,b=amd64
     origin security.debian.org
 500 http://security.debian.org/debian-security stretch/updates/contrib i386 Packages
     release v=9,o=Debian,a=stable,n=stretch,l=Debian-Security,c=contrib,b=i386
     origin security.debian.org
 500 http://security.debian.org/debian-security stretch/updates/contrib amd64 Packages
     release v=9,o=Debian,a=stable,n=stretch,l=Debian-Security,c=contrib,b=amd64
     origin security.debian.org
 500 http://security.debian.org/debian-security stretch/updates/main i386 Packages
     release v=9,o=Debian,a=stable,n=stretch,l=Debian-Security,c=main,b=i386
     origin security.debian.org
 500 http://security.debian.org/debian-security stretch/updates/main amd64 Packages
     release v=9,o=Debian,a=stable,n=stretch,l=Debian-Security,c=main,b=amd64
     origin security.debian.org
 500 http://httpredir.debian.org/debian stretch/non-free i386 Packages
     release v=9.7,o=Debian,a=stable,n=stretch,l=Debian,c=non-free,b=i386
     origin httpredir.debian.org
 500 http://httpredir.debian.org/debian stretch/non-free amd64 Packages
     release v=9.7,o=Debian,a=stable,n=stretch,l=Debian,c=non-free,b=amd64
     origin httpredir.debian.org
 500 http://httpredir.debian.org/debian stretch/contrib i386 Packages
     release v=9.7,o=Debian,a=stable,n=stretch,l=Debian,c=contrib,b=i386
     origin httpredir.debian.org
 500 http://httpredir.debian.org/debian stretch/contrib amd64 Packages
     release v=9.7,o=Debian,a=stable,n=stretch,l=Debian,c=contrib,b=amd64
     origin httpredir.debian.org
 500 http://httpredir.debian.org/debian stretch/main i386 Packages
     release v=9.7,o=Debian,a=stable,n=stretch,l=Debian,c=main,b=i386
     origin httpredir.debian.org
 500 http://httpredir.debian.org/debian stretch/main amd64 Packages
     release v=9.7,o=Debian,a=stable,n=stretch,l=Debian,c=main,b=amd64
     origin httpredir.debian.org
 500 http://ftp.uk.debian.org/debian stretch/non-free i386 Packages
     release v=9.7,o=Debian,a=stable,n=stretch,l=Debian,c=non-free,b=i386
     origin ftp.uk.debian.org
 500 http://ftp.uk.debian.org/debian stretch/non-free amd64 Packages
     release v=9.7,o=Debian,a=stable,n=stretch,l=Debian,c=non-free,b=amd64
     origin ftp.uk.debian.org
 500 http://ftp.uk.debian.org/debian stretch/contrib i386 Packages
     release v=9.7,o=Debian,a=stable,n=stretch,l=Debian,c=contrib,b=i386
     origin ftp.uk.debian.org
 500 http://ftp.uk.debian.org/debian stretch/contrib amd64 Packages
     release v=9.7,o=Debian,a=stable,n=stretch,l=Debian,c=contrib,b=amd64
     origin ftp.uk.debian.org
 500 http://ftp.uk.debian.org/debian stretch/main i386 Packages
     release v=9.7,o=Debian,a=stable,n=stretch,l=Debian,c=main,b=i386
     origin ftp.uk.debian.org
 500 http://ftp.uk.debian.org/debian stretch/main amd64 Packages
     release v=9.7,o=Debian,a=stable,n=stretch,l=Debian,c=main,b=amd64
     origin ftp.uk.debian.org
Pinned packages:


apt policy libreoffice-common yielded:
Code: Select all
libreoffice-common:
  Installed: 1:5.2.7-1+deb9u4
  Candidate: 1:5.2.7-1+deb9u5
  Version table:
     1:5.2.7-1+deb9u5 500
        500 http://security.debian.org/debian-security stretch/updates/main amd64 Packages
        500 http://security.debian.org/debian-security stretch/updates/main i386 Packages
 *** 1:5.2.7-1+deb9u4 500
        500 http://ftp.uk.debian.org/debian stretch/main amd64 Packages
        500 http://ftp.uk.debian.org/debian stretch/main i386 Packages
        500 http://httpredir.debian.org/debian stretch/main amd64 Packages
        500 http://httpredir.debian.org/debian stretch/main i386 Packages
        100 /var/lib/dpkg/status


and aptitude purge --simulate libreoffice-common yielded:
Code: Select all
The following packages will be REMOVED:
  libreoffice-common{p} libreoffice-style-galaxy{u}
The following partially installed packages will be configured:
  gir1.2-lokdocview-0.1 liblibreofficekitgtk libreoffice libreoffice-help-en-gb{b} libreoffice-help-en-us{b}
  libreoffice-java-common{b} libreoffice-l10n-en-gb{b} libreoffice-librelogo libreoffice-report-builder{b}
  libreoffice-script-provider-bsh{b} libreoffice-script-provider-js{b} libreoffice-script-provider-python{b}
  libreoffice-sdbc-hsqldb libreoffice-style-tango{b} libreofficekit-data{b}
0 packages upgraded, 0 newly installed, 2 to remove and 1 not upgraded.
Need to get 0 B of archives. After unpacking 89.2 MB will be freed.
The following packages have unmet dependencies:
 libreoffice-script-provider-js : Depends: libreoffice-common (= 1:5.2.7-1+deb9u5) but it is not going to be installed
 libreofficekit-data : Depends: libreoffice-common (= 1:5.2.7-1+deb9u5) but it is not going to be installed
 libreoffice-java-common : Depends: libreoffice-common (= 1:5.2.7-1+deb9u5) but it is not going to be installed
 libreoffice-core : Depends: libreoffice-common (> 1:5.2.7) but it is not going to be installed
 libreoffice-l10n-en-gb : Depends: libreoffice-common (= 1:5.2.7-1+deb9u5) but it is not going to be installed
 libreoffice-script-provider-python : Depends: libreoffice-common (= 1:5.2.7-1+deb9u5) but it is not going to be installed
 libreoffice-ogltrans : Depends: libreoffice-common but it is not going to be installed
 libreoffice-evolution : Depends: libreoffice-common (>= 1:3.4.0~) but it is not going to be installed
 libreoffice-script-provider-bsh : Depends: libreoffice-common (= 1:5.2.7-1+deb9u5) but it is not going to be installed
 libreoffice-report-builder : Depends: libreoffice-common (= 1:5.2.7-1+deb9u5) but it is not going to be installed
 libreoffice-style-tango : Depends: libreoffice-style-default which is a virtual package, provided by:
                                    - libreoffice-style-galaxy (1:5.2.7-1+deb9u5), but it is not going to be installed
                                    - libreoffice-style-galaxy (1:5.2.7-1+deb9u4), but it is not going to be installed

                           Depends: libreoffice-common (= 1:5.2.7-1+deb9u5) but it is not going to be installed
 libreoffice-help-en-gb : Depends: libreoffice-style-default which is a virtual package, provided by:
                                   - libreoffice-style-galaxy (1:5.2.7-1+deb9u5), but it is not going to be installed
                                   - libreoffice-style-galaxy (1:5.2.7-1+deb9u4), but it is not going to be installed

                          Depends: libreoffice-common (= 1:5.2.7-1+deb9u5) but it is not going to be installed
 libreoffice-help-en-us : Depends: libreoffice-l10n-en-us which is a virtual package, provided by:
                                   - libreoffice-common (1:5.2.7-1+deb9u5), but it is not going to be installed
                                   - libreoffice-common (1:5.2.7-1+deb9u4), but it is not going to be installed

                          Depends: libreoffice-style-default which is a virtual package, provided by:
                                   - libreoffice-style-galaxy (1:5.2.7-1+deb9u5), but it is not going to be installed
                                   - libreoffice-style-galaxy (1:5.2.7-1+deb9u4), but it is not going to be installed

                          Depends: libreoffice-common (= 1:5.2.7-1+deb9u5) but it is not going to be installed
The following actions will resolve these dependencies:

     Keep the following packages at their current version:                             
1)     libreoffice-style-galaxy [1:5.2.7-1+deb9u5 (now, stable)]                       

     Upgrade the following packages:                                                   
2)     libreoffice-common [1:5.2.7-1+deb9u4 (now, stable) -> 1:5.2.7-1+deb9u5 (stable)]



Accept this solution? [Y/n/q/?] y
The following packages will be upgraded:
  libreoffice-common
The following partially installed packages will be configured:
  gir1.2-lokdocview-0.1 liblibreofficekitgtk libreoffice libreoffice-help-en-gb libreoffice-help-en-us libreoffice-java-common
  libreoffice-l10n-en-gb libreoffice-librelogo libreoffice-report-builder libreoffice-script-provider-bsh
  libreoffice-script-provider-js libreoffice-script-provider-python libreoffice-sdbc-hsqldb libreoffice-style-galaxy
  libreoffice-style-tango libreofficekit-data
1 packages upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
Need to get 23.6 MB of archives. After unpacking 0 B will be used.

Note: Using 'Simulate' mode.
Do you want to continue? [Y/n/?] y
Would download/install/remove packages.


I don't understand what any of this means!
Snaerulfr
 
Posts: 10
Joined: 2019-02-04 23:54
Location: /eur/nor/bergen

Re: Libreoffice broken install

Postby Snaerulfr » 2019-02-05 11:03

I realise I should have posted the initial error message I got when using
sudo apt install libreoffice-common

Code: Select all
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Suggested packages:
  libreoffice-style-breeze libreoffice-style-hicontrast libreoffice-style-oxygen libreoffice-style-sifr
The following packages will be upgraded:
  libreoffice-common
1 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
16 not fully installed or removed.
Need to get 23.6 MB of archives.
After this operation, 0 B of additional disk space will be used.
Get:1 http://security.debian.org/debian-security stretch/updates/main amd64 libreoffice-common all 1:5.2.7-1+deb9u5 [23.6 MB]
0% [1 libreoffice-common 11.1 kB/23.6 MB 0%]y                   
Fetched 23.6 MB in 2s (9,346 kB/s)             
Reading changelogs... Done
(Reading database ... 394451 files and directories currently installed.)
Preparing to unpack .../libreoffice-common_1%3a5.2.7-1+deb9u5_all.deb ...
Unpacking libreoffice-common (1:5.2.7-1+deb9u5) over (1:5.2.7-1+deb9u4) ...
dpkg: error processing archive /var/cache/apt/archives/libreoffice-common_1%3a5.2.7-1+deb9u5_all.deb (--unpack):
 unable to open '/usr/lib/libreoffice/share/config/soffice.cfg/modules/swriter/toolbar/oleobjectbar.xml.dpkg-new': Operation not permitted
rmdir: failed to remove '/var/lib/libreoffice/share/prereg/': No such file or directory
rmdir: failed to remove '/var/lib/libreoffice/share/': No such file or directory
rmdir: failed to remove '/var/lib/libreoffice/program/': No such file or directory
rmdir: failed to remove '/var/lib/libreoffice': No such file or directory
rmdir: failed to remove '/var/lib/libreoffice': No such file or directory
Errors were encountered while processing:
 /var/cache/apt/archives/libreoffice-common_1%3a5.2.7-1+deb9u5_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Snaerulfr
 
Posts: 10
Joined: 2019-02-04 23:54
Location: /eur/nor/bergen

Re: Libreoffice broken install

Postby Head_on_a_Stick » 2019-02-05 12:39

All those foreign repositories may cause significant problems, though I can't say for sure if this is the cause.

What about
Code: Select all
aptitude why-not libreoffice-common

I'll have to come back to this again later, I'm posting on my phone and it is v painful...
User avatar
Head_on_a_Stick
 
Posts: 10382
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Libreoffice broken install

Postby Snaerulfr » 2019-02-05 12:49

I don't mind, thank you very much for your help so far!

Here's what why-not gave me. Doesn't seem to say much, and actually seems to contradict what's happening in reality.
Code: Select all
Automatically installed, current version 1:5.2.7-1+deb9u4, priority optional
The candidate version 1:5.2.7-1+deb9u5 has priority optional
No dependencies require to remove libreoffice-common
Snaerulfr
 
Posts: 10
Joined: 2019-02-04 23:54
Location: /eur/nor/bergen

Re: Libreoffice broken install

Postby Head_on_a_Stick » 2019-02-05 13:23

Let's try
Code: Select all
# aptitude upgrade

If it asks any questions, keep saying "no" until it tells you there are no other options, at which point quit the operation and post the full output here, thanks!

I'm flailing around a bit here, somebody else may post more cogent advice (hopefully).
User avatar
Head_on_a_Stick
 
Posts: 10382
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Libreoffice broken install

Postby Snaerulfr » 2019-02-05 13:38

Code: Select all
snaerulfr@debian:~$ sudo aptitude upgrade
[sudo] password for snaerulfr:
The following packages will be upgraded:
  libgd3 libreoffice-common
The following partially installed packages will be configured:
  desktop-file-utils gir1.2-lokdocview-0.1 gnome-icon-theme gnome-menus hicolor-icon-theme liblibreofficekitgtk libreoffice
  libreoffice-help-en-gb libreoffice-help-en-us libreoffice-java-common libreoffice-l10n-en-gb libreoffice-librelogo
  libreoffice-report-builder libreoffice-script-provider-bsh libreoffice-script-provider-js libreoffice-script-provider-python
  libreoffice-sdbc-hsqldb libreoffice-style-galaxy libreoffice-style-tango libreofficekit-data man-db mime-support
  shared-mime-info
2 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 132 kB/23.7 MB of archives. After unpacking 1,024 B will be used.
Do you want to continue? [Y/n/?] n
Abort.


is my output here
Snaerulfr
 
Posts: 10
Joined: 2019-02-04 23:54
Location: /eur/nor/bergen

Re: Libreoffice broken install

Postby Snaerulfr » 2019-02-05 13:41

If you intended for me to continue, here's the output:

Code: Select all
snaerulfr@debian:~$ sudo aptitude upgrade
The following packages will be upgraded:
  libgd3 libreoffice-common
The following partially installed packages will be configured:
  desktop-file-utils gir1.2-lokdocview-0.1 gnome-icon-theme gnome-menus hicolor-icon-theme liblibreofficekitgtk libreoffice
  libreoffice-help-en-gb libreoffice-help-en-us libreoffice-java-common libreoffice-l10n-en-gb libreoffice-librelogo
  libreoffice-report-builder libreoffice-script-provider-bsh libreoffice-script-provider-js libreoffice-script-provider-python
  libreoffice-sdbc-hsqldb libreoffice-style-galaxy libreoffice-style-tango libreofficekit-data man-db mime-support
  shared-mime-info
2 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 132 kB/23.7 MB of archives. After unpacking 1,024 B will be used.
Do you want to continue? [Y/n/?] y
Get: 1 http://security.debian.org/debian-security stretch/updates/main amd64 libgd3 amd64 2.2.4-2+deb9u4 [132 kB]
Fetched 132 kB in 0s (584 kB/s)
Reading changelogs... Done
(Reading database ... 394451 files and directories currently installed.)
Preparing to unpack .../libreoffice-common_1%3a5.2.7-1+deb9u5_all.deb ...
Unpacking libreoffice-common (1:5.2.7-1+deb9u5) over (1:5.2.7-1+deb9u4) ...
dpkg: error processing archive /var/cache/apt/archives/libreoffice-common_1%3a5.2.7-1+deb9u5_all.deb (--unpack):
 unable to open '/usr/lib/libreoffice/share/config/soffice.cfg/modules/swriter/toolbar/changes.xml.dpkg-new': Operation not permitted
rmdir: failed to remove '/var/lib/libreoffice/share/prereg/': No such file or directory
rmdir: failed to remove '/var/lib/libreoffice/share/': No such file or directory
rmdir: failed to remove '/var/lib/libreoffice/program/': No such file or directory
rmdir: failed to remove '/var/lib/libreoffice': No such file or directory
rmdir: failed to remove '/var/lib/libreoffice': No such file or directory
Preparing to unpack .../libgd3_2.2.4-2+deb9u4_amd64.deb ...
Unpacking libgd3:amd64 (2.2.4-2+deb9u4) over (2.2.4-2+deb9u3) ...
Errors were encountered while processing:
 /var/cache/apt/archives/libreoffice-common_1%3a5.2.7-1+deb9u5_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
dpkg: dependency problems prevent configuration of libreoffice-help-en-us:
 libreoffice-help-en-us depends on libreoffice-common (= 1:5.2.7-1+deb9u5); however:
  Version of libreoffice-common on system is 1:5.2.7-1+deb9u4.

dpkg: error processing package libreoffice-help-en-us (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libreoffice-style-galaxy:
 libreoffice-style-galaxy depends on libreoffice-common (= 1:5.2.7-1+deb9u5); however:
  Version of libreoffice-common on system is 1:5.2.7-1+deb9u4.

dpkg: error processing package libreoffice-style-galaxy (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libreoffice-script-provider-js:
 libreoffice-script-provider-js depends on libreoffice-common (= 1:5.2.7-1+deb9u5); however:
  Version of libreoffice-common on system is 1:5.2.7-1+deb9u4.

dpkg: error processing package libreoffice-script-provider-js (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libreoffice-java-common:
 libreoffice-java-common depends on libreoffice-common (= 1:5.2.7-1+deb9u5); however:
  Version of libreoffice-common on system is 1:5.2.7-1+deb9u4.

dpkg: error processing package libreoffice-java-common (--configure):
 dependency problems - leaving unconfigured
Processing triggers for mime-support (3.60) ...
dpkg: dependency problems prevent configuration of libreoffice-script-provider-python:
 libreoffice-script-provider-python depends on libreoffice-common (= 1:5.2.7-1+deb9u5); however:
  Version of libreoffice-common on system is 1:5.2.7-1+deb9u4.

dpkg: error processing package libreoffice-script-provider-python (--configure):
 dependency problems - leaving unconfigured
Processing triggers for desktop-file-utils (0.23-1) ...
dpkg: dependency problems prevent configuration of libreoffice-librelogo:
 libreoffice-librelogo depends on libreoffice-script-provider-python; however:
  Package libreoffice-script-provider-python is not configured yet.

dpkg: error processing package libreoffice-librelogo (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libreoffice:
 libreoffice depends on libreoffice-java-common (>= 1:5.2.7~); however:
  Package libreoffice-java-common is not configured yet.

dpkg: error processing package libreoffice (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libreoffice-help-en-gb:
 libreoffice-help-en-gb depends on libreoffice-style-default; however:
  Package libreoffice-style-default is not installed.
  Package libreoffice-style-galaxy which provides libreoffice-style-default is not configured yet.
 libreoffice-help-en-gb depends on libreoffice-common (= 1:5.2.7-1+deb9u5); however:
  Version of libreoffice-common on system is 1:5.2.7-1+deb9u4.

dpkg: error processing package libreoffice-help-en-gb (--configure):
 dependency problems - leaving unconfigured
Setting up libgd3:amd64 (2.2.4-2+deb9u4) ...
dpkg: dependency problems prevent configuration of libreoffice-sdbc-hsqldb:
 libreoffice-sdbc-hsqldb depends on libreoffice-java-common (>= 1:5.2.7~); however:
  Package libreoffice-java-common is not configured yet.

dpkg: error processing package libreoffice-sdbc-hsqldb (--configure):
 dependency problems - leaving unconfigured
Processing triggers for gnome-icon-theme (3.12.0-2) ...
dpkg: dependency problems prevent configuration of libreoffice-l10n-en-gb:
 libreoffice-l10n-en-gb depends on libreoffice-common (= 1:5.2.7-1+deb9u5); however:
  Version of libreoffice-common on system is 1:5.2.7-1+deb9u4.

dpkg: error processing package libreoffice-l10n-en-gb (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libreofficekit-data:
 libreofficekit-data depends on libreoffice-common (= 1:5.2.7-1+deb9u5); however:
  Version of libreoffice-common on system is 1:5.2.7-1+deb9u4.

dpkg: error processing package libreofficekit-data (--configure):
 dependency problems - leaving unconfigured
Processing triggers for libc-bin (2.24-11+deb9u3) ...
dpkg: dependency problems prevent configuration of libreoffice-style-tango:
 libreoffice-style-tango depends on libreoffice-style-default; however:
  Package libreoffice-style-default is not installed.
  Package libreoffice-style-galaxy which provides libreoffice-style-default is not configured yet.
 libreoffice-style-tango depends on libreoffice-common (= 1:5.2.7-1+deb9u5); however:
  Version of libreoffice-common on system is 1:5.2.7-1+deb9u4.

dpkg: error processing package libreoffice-style-tango (--configure):
 dependency problems - leaving unconfigured
Processing triggers for man-db (2.7.6.1-2) ...
Processing triggers for shared-mime-info (1.8-1+deb9u1) ...
Unknown media type in type 'all/all'
Unknown media type in type 'all/allfiles'
dpkg: dependency problems prevent configuration of libreoffice-report-builder:
 libreoffice-report-builder depends on libreoffice-java-common; however:
  Package libreoffice-java-common is not configured yet.
 libreoffice-report-builder depends on libreoffice-common (= 1:5.2.7-1+deb9u5); however:
  Version of libreoffice-common on system is 1:5.2.7-1+deb9u4.

dpkg: error processing package libreoffice-report-builder (--configure):
 dependency problems - leaving unconfigured
Processing triggers for gnome-menus (3.13.3-9) ...
dpkg: dependency problems prevent configuration of libreoffice-script-provider-bsh:
 libreoffice-script-provider-bsh depends on libreoffice-common (= 1:5.2.7-1+deb9u5); however:
  Version of libreoffice-common on system is 1:5.2.7-1+deb9u4.
 libreoffice-script-provider-bsh depends on libreoffice-java-common; however:
  Package libreoffice-java-common is not configured yet.

dpkg: error processing package libreoffice-script-provider-bsh (--configure):
 dependency problems - leaving unconfigured
Processing triggers for hicolor-icon-theme (0.15-1) ...
dpkg: dependency problems prevent configuration of liblibreofficekitgtk:
 liblibreofficekitgtk depends on libreofficekit-data; however:
  Package libreofficekit-data is not configured yet.

dpkg: error processing package liblibreofficekitgtk (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gir1.2-lokdocview-0.1:
 gir1.2-lokdocview-0.1 depends on liblibreofficekitgtk (= 1:5.2.7-1+deb9u5); however:
  Package liblibreofficekitgtk is not configured yet.

dpkg: error processing package gir1.2-lokdocview-0.1 (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 libreoffice-help-en-us
 libreoffice-style-galaxy
 libreoffice-script-provider-js
 libreoffice-java-common
 libreoffice-script-provider-python
 libreoffice-librelogo
 libreoffice
 libreoffice-help-en-gb
 libreoffice-sdbc-hsqldb
 libreoffice-l10n-en-gb
 libreofficekit-data
 libreoffice-style-tango
 libreoffice-report-builder
 libreoffice-script-provider-bsh
 liblibreofficekitgtk
 gir1.2-lokdocview-0.1
                                         
Current status: 1 (-1) upgradable.
Snaerulfr
 
Posts: 10
Joined: 2019-02-04 23:54
Location: /eur/nor/bergen

Re: Libreoffice broken install

Postby Head_on_a_Stick » 2019-02-05 14:07

So what are the permissions on the file it can't open?
Code: Select all
ls -l

^ Run that on the file in question.
User avatar
Head_on_a_Stick
 
Posts: 10382
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Libreoffice broken install

Postby Snaerulfr » 2019-02-05 15:24

Code: Select all
'/usr/lib/libreoffice/share/config/soffice.cfg/modules/swriter/toolbar/changes.xml.dpkg-new'

doesn't exist.
Code: Select all
'/usr/lib/libreoffice/share/config/soffice.cfg/modules/swriter/toolbar/changes.xml'

has permissions:
-rw-r--r--

I've been using sudo on every command each time so should have root anyway.
Snaerulfr
 
Posts: 10
Joined: 2019-02-04 23:54
Location: /eur/nor/bergen

Re: Libreoffice broken install

Postby Head_on_a_Stick » 2019-02-05 18:52

How about ownership? Both of the file and the parent directory.
User avatar
Head_on_a_Stick
 
Posts: 10382
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Libreoffice broken install

Postby Snaerulfr » 2019-02-05 19:25

Both are root.
Snaerulfr
 
Posts: 10
Joined: 2019-02-04 23:54
Location: /eur/nor/bergen

Re: Libreoffice broken install

Postby Head_on_a_Stick » 2019-02-05 19:46

Perhaps relevant:

https://bugs.launchpad.net/ubuntu/+sour ... ug/1739991

https://bugs.launchpad.net/ubuntu/+sour ... ug/1685984

Are you using Sophos?

I would delete the contents of /var/cache/apt/archives and try re-installing the packages.
User avatar
Head_on_a_Stick
 
Posts: 10382
Joined: 2014-06-01 17:46
Location: /dev/chair

Next

Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 11 guests

fashionable