cannot kill pulseaudio

Everything about X, Gnome, KDE, ... and everything running on it

cannot kill pulseaudio

Postby morgon » 2019-02-20 16:00

Hi,

after hating it for a long time I have finally made my peace with pulseaudio.

Or so I had thought.

Now I have again a problem I don't understand:

On my laptop (running testing) pulseaudio is run under my user-account. I don't really know how exactly it get's started (afaik every client that needs pulseaudio will start it if it is not running), but it runs as a child process of the systemd-process (I assume it got re-parented) but trying to stop via systemd does not work. systemd does not seem to know anything about it.

So question 1: How can I find out how it actually get's started.

But my actual problem is that I cannot stop it. Either killing the process or running "pulseaudio -k" will simply result in a new process appearing.

And that is despite I have "autospawn = no" in both /etc/pulse/client.conf and ~/.config/pulse/client.conf

What is going on here? Question 2: How can I stop it?

Many thanks!
morgon
 
Posts: 138
Joined: 2010-08-28 03:04

Re: cannot kill pulseaudio

Postby bw123 » 2019-02-20 16:09

There's a long thread about this, when you search the forum and find it, will you add the link to this post?
thanks.

some of these are good too
https://duckduckgo.com/html/?q=debian+kill+pulseaudio
User avatar
bw123
 
Posts: 3787
Joined: 2011-05-09 06:02

Re: cannot kill pulseaudio

Postby morgon » 2019-02-20 16:41

The standard solution to this problem (which you find either here or with a search engine) is adding "autospawn = no" to the configuration.

This does (for whatever reason) not work on my system.

And please note that I am asking two questions, so as for

bw123 wrote:There's a long thread about this, when you search the forum and find it, will you add the link to this post?


my answer is: I won't link it - because it would not add any value.
morgon
 
Posts: 138
Joined: 2010-08-28 03:04

Re: cannot kill pulseaudio

Postby GarryRicketson » 2019-02-20 18:51

How do you know that , if you have not looked for it ? I think it answers your questions, maybe when I have more time I will look for it for you, I vaguely remember when this same question and discussion was going on, and am pretty sure they got it solved, if you don't mind waiting I will do the searches for you and post a link to it here.
==========edited ========
Ha,ha, this is funny, it, but it was a year ago, and there are others, but the funny thing, in this thread, it is the same OP as now, and a solution was posted, but the OP never responded, don't know if they ever tried what was suggested, it might be worth a try,
http://forums.debian.net/viewtopic.php?f=6&t=134859#p655588
and scroll down, to the last post on that page, :
http://forums.debian.net/viewtopic.php?f=6&t=134859#p655767
by sunrat » 2017-10-06 01:19
Oops, helps to actually uncomment the above-mentioned parameter in daemon.conf:

Code: Select all
cat /proc/asound/card*/pcm*p/sub*/hw_params
access: MMAP_INTERLEAVED
format: S32_LE
subformat: STD
channels: 10
rate: 96000 (96000/1)


Success!

OP, I'm interested in tracking down how pulse starts too, so will do more research later.

And on the next page he gives the answers about how it starts,...
User avatar
GarryRicketson
 
Posts: 5877
Joined: 2015-01-20 22:16
Location: Durango, Mexico

Re: cannot kill pulseaudio

Postby bw123 » 2019-02-20 19:05

The standard solution to this problem (which you find either here or with a search engine) is adding "autospawn = no" to the configuration...


No, that's not a standard solution, it is not enough. The daemon can start all kinds of ways. You would kniow that if you searched.

The easiest way I found is just remove it, do you need a soundserver on your setup?
User avatar
bw123
 
Posts: 3787
Joined: 2011-05-09 06:02

Re: cannot kill pulseaudio

Postby GarryRicketson » 2019-02-20 19:11

The easiest way I found is just remove it,

+100, but if the OP needs it, not a option, but there are other solutions and it did not take long to find some ,...


And if that is not enough, there are plenty of good results:
how to kill pulseaudio on Debian
First hit :
https://wiki.debian.org/PulseAudio
Solving Problems

Restarting the Pulseaudio Daemon

To reread the config files ~/.config/pulse/daemon.conf and /etc/pulse/daemon.conf, do this:
Code: Select all
$ pulseaudio --kill
$ pulseaudio --start


And if that does not work there are still more methods, the OP just needs to keep trying until they find the one that works for them.
User avatar
GarryRicketson
 
Posts: 5877
Joined: 2015-01-20 22:16
Location: Durango, Mexico

Re: cannot kill pulseaudio

Postby morgon » 2019-02-20 20:05

bw123 wrote:No, that's not a standard solution, it is not enough. The daemon can start all kinds of ways. You would kniow that if you searched.


Believe me, it is the standard solution for quite common problem/feature when people find that killing one pulseaudio process it just starts a new one.
I am not talking about how it get's started here.
And this ususally works well, e.g on my PC with an (almost) identical setup.

bw123 wrote:The easiest way I found is just remove it, do you need a soundserver on your setup?


I don't want to remove it. I use it. A lot actually. It's quite powerful software actually.
It's just that sometimes I want to use jack and for that I want to shut pulseaudio down occasionally.

So (as we seem to loose focus here) my questions remain:

How can I find out how pulseaudio get's started on my system?
How can I shut it down if "autospawn = no" does not do the trick?
morgon
 
Posts: 138
Joined: 2010-08-28 03:04

Re: cannot kill pulseaudio

Postby peter_irich » 2019-02-20 20:09

Pulseaudio can be in autostart in users settings.

Peter.
peter_irich
 
Posts: 1260
Joined: 2009-09-10 20:15
Location: Saint-Petersburg, Russian Federation

Re: cannot kill pulseaudio

Postby bw123 » 2019-02-20 20:11

You say it's a standard solution, but then say it;'s not working, and then refuse to try any searches like this?

It's the 5th hit on my search link, did you read it?
http://www.linuxplanet.com/linuxplanet/ ... ls/7130/2/

Garry finds another thread from a yr ago you asking the same question... Did you even read it?
My question now becomes, are you on some serious medication that you forgot to take, or just naturally an idiot?
User avatar
bw123
 
Posts: 3787
Joined: 2011-05-09 06:02

Re: cannot kill pulseaudio

Postby morgon » 2019-02-20 20:23

I did read it, it does exactly what I tried (I tried with and wiithout the demon-binary setting) and it does not work here (it should though).

This is just the "standard" thing to try.

If that is all you have to offer (and it seems you don't know anything about the problem at hand from your own experience) then why don't you look for a nicer playgound?
morgon
 
Posts: 138
Joined: 2010-08-28 03:04

Re: cannot kill pulseaudio

Postby bw123 » 2019-02-20 20:25

morgon wrote:I did read it, it does exactly what I tried (I tried with and wiithout the demon-binary setting) and it does not work here (it should though).

This is just the "standard" thing to try.

If that is all you have to offer (and it seems you don't know anything about the problem at hand from your own experience) then why don't you look for a nicer playgound?


Because this is my playground. Maybe you go somewhere else unless you want me to taunt you relentlessly like this.

?
User avatar
bw123
 
Posts: 3787
Joined: 2011-05-09 06:02

Re: cannot kill pulseaudio

Postby morgon » 2019-02-20 20:27

peter_irich wrote:Pulseaudio can be in autostart in users settings.


I have no autostart. I am using i3 and I don't start it from my own config-files.

It does not get started from systemd either.
morgon
 
Posts: 138
Joined: 2010-08-28 03:04

Re: cannot kill pulseaudio

Postby morgon » 2019-02-20 20:29

bw123 wrote:Because this is my playground.


Do what you want.
It seems you have too much time on your hands, but unfortunately (for me) your contributions are not that helpful.
morgon
 
Posts: 138
Joined: 2010-08-28 03:04

Re: cannot kill pulseaudio

Postby bw123 » 2019-02-20 20:32

morgon wrote:
bw123 wrote:Because this is my playground.


Do what you want.
It seems you have too much time on your hands, but unfortunately (for me) your contributions are not that helpful.


Your contributions are very helpful, even after a year where a solution is offered and you totally ignore it. The idea on a forum is, it's not about you baby, it's about future readers who will find your thread. I want them to understand why your posts are silly. I want them to find solutions where you pretend to find none.
User avatar
bw123
 
Posts: 3787
Joined: 2011-05-09 06:02

Re: cannot kill pulseaudio

Postby Head_on_a_Stick » 2019-02-20 20:37

bw123 wrote:just naturally an idiot

^ This.

I didn't know shit about acpi when I saw our OP's other thread but I managed to find the answer in a few minutes, it was very easy. Too difficult for poor old morgon though, they had to go crawling for help here :lol:

halfwit wrote:sometimes I want to use jack and for that I want to shut pulseaudio down occasionally

You do know you can run PA through JACK, right?

https://wiki.archlinux.org/index.php/Pu ... rough_JACK

There is no need to kill PA at all.
Don't break DebianHow to report bugs

SharpBang GNU/Linux — a pre-configured Openbox/Tint2 desktop running on Debian stable
User avatar
Head_on_a_Stick
 
Posts: 10691
Joined: 2014-06-01 17:46
Location: /dev/chair

Next

Return to Desktop & Multimedia

Who is online

Users browsing this forum: cooler01 and 7 guests

fashionable