Audio output pbm since update

If it doesn't relate to Debian, but you still want to share it, please do it here

Audio output pbm since update

Postby mururoa » 2019-05-04 06:40

Hi there,
Until a few days ago all was ok on my debian + xfce desktop. Then I did a system update.
After the update the default audio card is selected on each system boot.
Before the output selected was 'hdmi 2' and now it's 'IEC 958 Output' wich should be the computer sound card wich is the first working device (IE not unplugged).
If I run the audio selector and select back 'hdmi 2' all is ok but this is dropped on each reboot and I have to select it again :( Real pain for an HTPC.
I've done my homework and tried to add set-default-sink and set-default-source in pulse audio config file and then remove all ~/.config/pulse directory but it did not solve the problem.
It seems to me that pulse audio is utterly complex so I need your help there.
Some hints ?
mururoa
 
Posts: 7
Joined: 2016-11-27 12:58

Re: Audio output pbm since update

Postby Head_on_a_Stick » 2019-05-04 09:06

mururoa wrote:It seems to me that pulse audio is utterly complex

+1, why not just remove it?

Have you tried using pavucontrol instead of configuration files?

You haven't mentioned which version of Debian you are using so please post the output of
Code: Select all
apt policy
User avatar
Head_on_a_Stick
 
Posts: 11218
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Audio output pbm since update

Postby mururoa » 2019-05-04 11:10

In fact it's Devuan 2.0 but I'm 99,99% sure sound packages and files are the same as latest debian.
Is pavucontrol different thant xfce sound configuration GUI ?
And yes I could remove PulseAudio if that is the way to get back sound at each reboot.
mururoa
 
Posts: 7
Joined: 2016-11-27 12:58

Re: Audio output pbm since update

Postby Head_on_a_Stick » 2019-05-04 11:17

mururoa wrote:In fact it's Devuan 2.0

Please continue this discussion over at the Devuan forums, I am also a member there.
User avatar
Head_on_a_Stick
 
Posts: 11218
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Audio output pbm since update

Postby mururoa » 2019-05-04 11:53

Ok.
mururoa
 
Posts: 7
Joined: 2016-11-27 12:58


Return to Offtopic

Who is online

Users browsing this forum: No registered users and 9 guests

fashionable