RTL8723BS wifi no longer functioning

Getting your soundcard to work, using Debian on non-i386 hardware, etc

Re: RTL8723BS wifi no longer functioning

Postby stanhebben » 2019-07-05 22:20

I didn't paste the command, only the output, perhaps hence the confusion... I'll make sure to include the command as well.

So here's the hardware address:

Code: Select all
$ cat /sys/class/net/wlan*/address
00:e0:4c:b7:23:00
stanhebben
 
Posts: 10
Joined: 2019-07-01 08:50

Re: RTL8723BS wifi no longer functioning

Postby trinidad » 2019-07-06 12:41

Bring up your interface as: wlx00e04cb72300. If it loads and works delete wlan0 settings. The difference will be that if a connection is dropped you will be able to reconnect without a shutdown and new boot. There are caveats like I mentioned before i/e the device hardware itself may require a power cycle to restart (which means because the machine is always on you would need to write a script to periodically timeout/disconnect the device and then reconnect it) A lot of these types of devices are not designed to operate for days on end ...even Roku TVs... and generally ISPs drop connections after long periods of inactivity... and most Windows 10 systems too.

TC
You can't believe your eyes if your imagination is out of focus.
trinidad
 
Posts: 57
Joined: 2016-08-04 14:58

Re: RTL8723BS wifi no longer functioning

Postby stanhebben » 2019-07-06 19:38

Alright, so I tried the following on that device:

Code: Select all
sudo ifup wlx00e04cb72300
ifup: unknown interface wlx00e04cb72300


That didn't work, so perhaps I had to configure my interface first by editing /etc/network/interfaces:

Code: Select all
$ cat /etc/network/interfaces
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

source /etc/network/interfaces.d/*

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug enp1s0
iface enp1s0 inet dhcp

allow-hotplug wlx00e04cb72300
iface wlx00e04cb72300 inet dhcp
  wpa-conf /etc/wpa_supplicant.conf


Code: Select all
$ sudo systemctl restart networking
$ sudo ifup wlx00e04cb72300
wpa_supplicant: /sbin/wpa_supplicant daemon failed to start
run-parts: /etc/network/if-pre-up.d/wpasupplicant exited with return code 1
ifup: failed to bring up wlx00e04cb72300
$ sudo journalctl | grep wpa_supplicant
Jul 06 20:16:37 debian wpa_supplicant[16865]: Successfully initialized wpa_supplicant
Jul 06 20:16:37 debian wpa_supplicant[16865]: Could not read interface wlx00e04cb72300 flags: No such device
Jul 06 20:16:37 debian wpa_supplicant[16865]: nl80211: Driver does not support authentication/association or connect commands
Jul 06 20:16:37 debian wpa_supplicant[16865]: nl80211: deinit ifname=wlx00e04cb72300 disabled_11b_rates=0
Jul 06 20:16:37 debian wpa_supplicant[16865]: Could not read interface wlx00e04cb72300 flags: No such device
Jul 06 20:16:37 debian wpa_supplicant[16865]: Could not read interface wlx00e04cb72300 flags: No such device
Jul 06 20:16:37 debian wpa_supplicant[16865]: WEXT: Could not set interface 'wlx00e04cb72300' UP
Jul 06 20:16:37 debian wpa_supplicant[16865]: wlx00e04cb72300: Failed to initialize driver interface


That doesn't seem to work. Tried to reboot the device (sudo reboot) but that didn't help either.
stanhebben
 
Posts: 10
Joined: 2019-07-01 08:50

Re: RTL8723BS wifi no longer functioning

Postby trinidad » 2019-07-07 16:03

Look to see if you have the file /lib/udev/rules.d/73-usb-net-by-mac.rules

TC
You can't believe your eyes if your imagination is out of focus.
trinidad
 
Posts: 57
Joined: 2016-08-04 14:58

Re: RTL8723BS wifi no longer functioning

Postby stanhebben » 2019-07-08 06:07

The file does exist and contains the following:

Code: Select all
$ cat /lib/udev/rules.d/73-usb-net-by-mac.rules
# Use MAC based names for network interfaces which are directly or indirectly
# on USB and have an universally administered (stable) MAC address (second bit
# is 0). Don't do this when ifnames is disabled via kernel command line or
# customizing/disabling 99-default.link (or previously 80-net-setup-link.rules).

IMPORT{cmdline}="net.ifnames"
ENV{net.ifnames}=="0", GOTO="usb_net_by_mac_end"

ACTION=="add", SUBSYSTEM=="net", SUBSYSTEMS=="usb", NAME=="", \
    ATTR{address}=="?[014589cd]:*", \
    TEST!="/etc/udev/rules.d/80-net-setup-link.rules", \
    TEST!="/etc/systemd/network/99-default.link", \
    IMPORT{builtin}="net_id", NAME="$env{ID_NET_NAME_MAC}"

LABEL="usb_net_by_mac_end"
stanhebben
 
Posts: 10
Joined: 2019-07-01 08:50

Previous

Return to Hardware

Who is online

Users browsing this forum: No registered users and 6 guests

fashionable