graphics driver fails

Getting your soundcard to work, using Debian on non-i386 hardware, etc

graphics driver fails

Postby rudolfpolzer » 2019-08-01 22:32

Hello, I made an update from stretch to buster. Now, the graphics driver fails:

lspci -v
...
00:02.0 VGA compatible controller Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller (rev 06) (prog-if 00 [VGA controller])
...
Kernel modules: i915
...

sudo modprobe i915
cec_edid: exports duplicate symbol cec_get_edid_phys_addr (owned by kernel)
modprobe: ERROR: could not insert 'i915': Exec format error
rudolfpolzer
 
Posts: 10
Joined: 2015-08-16 08:36

Re: graphics driver fails

Postby shep » 2019-08-02 00:33

shep
 
Posts: 306
Joined: 2011-03-15 15:22

Re: graphics driver fails

Postby rudolfpolzer » 2019-08-02 05:16

I did as suggested, I removed xserver-xorg-video-intel. xserver-xorg-core is installed. But lspci and modprobe output remain unchanged.
rudolfpolzer
 
Posts: 10
Joined: 2015-08-16 08:36

Re: graphics driver fails

Postby rudolfpolzer » 2019-08-02 09:11

I had suspected that the driver package from v4l used for the sat receiver (the driver saa716x_budget is in use, and this package contains many other drivers, also an i915), did overwrite the driver i915 from Debian. I have no idea how to check or correct that.

But this seems to be wrong: the date of the i915.ko file is the date of the Debian stable freeze and not the date of my saa716x_budget driver compilation.
The blocking symbol seems to be defined in the built in kernel module cec, but I can't find it in the module file i915.ko.

So - why is loading of the module i915 not possible?
Last edited by rudolfpolzer on 2019-08-02 15:06, edited 1 time in total.
rudolfpolzer
 
Posts: 10
Joined: 2015-08-16 08:36

Re: graphics driver fails

Postby Head_on_a_Stick » 2019-08-02 14:43

What does this say
Code: Select all
lspci -k | grep -iA2 vga
User avatar
Head_on_a_Stick
 
Posts: 10377
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: graphics driver fails

Postby rudolfpolzer » 2019-08-02 15:09

lspci -k | grep -iA2 vga
00:02.0 VGA compatible controller: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller (rev 06)
Subsystem: ASUSTeK Computer Inc. Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller
Kernel modules: i915
rudolfpolzer
 
Posts: 10
Joined: 2015-08-16 08:36

Re: graphics driver fails

Postby Head_on_a_Stick » 2019-08-03 13:22

rudolfpolzer wrote:I had suspected that the driver package from v4l used for the sat receiver (the driver saa716x_budget is in use, and this package contains many other drivers, also an i915), did overwrite the driver i915 from Debian.

How exactly did you install that "driver package"?

Does your graphics controller work if you load up a live ISO image?
User avatar
Head_on_a_Stick
 
Posts: 10377
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: graphics driver fails

Postby rudolfpolzer » 2019-08-03 13:29

I installed the sat receiver driver as described in
https://www.linuxtv.org/wiki/index.php/ ... stallation
for the open source driver. But I think the i915 driver was not overwritten by this because the file i915.ko has the Debian freeze date as file date.

The graphics controller works as well when choosing the old kernel during boot as with a live image.
rudolfpolzer
 
Posts: 10
Joined: 2015-08-16 08:36

Re: graphics driver fails

Postby Head_on_a_Stick » 2019-08-03 13:31

rudolfpolzer wrote:I installed the sat receiver driver as described in
https://www.linuxtv.org/wiki/index.php/ ... stallation

Do they have an uninstall target in their Makefile that you can use to remove the driver?
User avatar
Head_on_a_Stick
 
Posts: 10377
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: graphics driver fails

Postby rudolfpolzer » 2019-08-03 13:43

The makefile help output suggests that 'make mrproper' would remove all generated files. I tried that with no success.
But the makefile help output is irritating, because I expect this makefile to compile and install drivers, but some of its possible parameters seem to build a kernel.
I can not estimate what it is really doing.
rudolfpolzer
 
Posts: 10
Joined: 2015-08-16 08:36

Re: graphics driver fails

Postby rudolfpolzer » 2019-08-03 19:34

This is how I made the graphics driver work again, force rebuild all modules:

#mv /lib/modules/$(uname -r) /lib/modules/$(uname -r)-old
#apt reinstall linux-image-$(uname -r)

It was the media driver blocking the graphics driver.
Now, the media driver doesn't work.
rudolfpolzer
 
Posts: 10
Joined: 2015-08-16 08:36


Return to Hardware

Who is online

Users browsing this forum: No registered users and 3 guests

fashionable