Broadcom wireless card doesn't work

Getting your soundcard to work, using Debian on non-i386 hardware, etc

Broadcom wireless card doesn't work

Postby Denteoli » 2019-08-06 15:52

Hello,
I'm having trouble trying to get the wireless card of my laptop to work. The card is a Broadcom Limited BCM4312 802.11b/g LP-PHY (rev 01). This is what lscpi outputs:
Code: Select all
00:00.0 Host bridge: Intel Corporation Mobile 945GSE Express Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GSE Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)
00:1b.0 Audio device: Intel Corporation NM10/ICH7 Family High Definition Audio Controller (rev 01)
00:1c.0 PCI bridge: Intel Corporation NM10/ICH7 Family PCI Express Port 1 (rev 01)
00:1c.1 PCI bridge: Intel Corporation NM10/ICH7 Family PCI Express Port 2 (rev 01)
00:1d.0 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #1 (rev 01)
00:1d.7 USB controller: Intel Corporation NM10/ICH7 Family USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 01)
00:1f.2 SATA controller: Intel Corporation 82801GBM/GHM (ICH7-M Family) SATA Controller [AHCI mode] (rev 01)
02:06.0 CardBus bridge: ENE Technology Inc CB1410 Cardbus Controller (rev 01)
02:08.0 Ethernet controller: Intel Corporation 82562ET/EZ/GT/GZ - PRO/100 VE (LOM) Ethernet Controller Mobile (rev 01)
10:00.0 Network controller: Broadcom Limited BCM4312 802.11b/g LP-PHY (rev 01)


And when I check its PCI ID it shows the following:
Code: Select all
10:00.0 0280: 14e4:4315 (rev 01)


According a Debian Wiki page I have to install the firmware-b43-installer package. I installed it and I followed the instructions, and when I used Wicd it didn't detect any wireless network. I noticed that a button that my laptop has to turn the wifi on doesn't work, even after rebooting. It had Lubuntu 18.04 installed before and it worked. The card is detected by iwconfig, so I have no idea why it's not working.

I'm using Debian 10 Buster on i386 architecture.
Thanks in advance.
Denteoli
 
Posts: 1
Joined: 2019-08-06 15:35

Re: Broadcom wireless card doesn't work

Postby arochester » 2019-08-06 15:58

I have to install the firmware-b43-installer package. I installed it and I followed the instructions


Did you reboot?
arochester
 
Posts: 1523
Joined: 2010-12-07 19:55

Re: Broadcom wireless card doesn't work

Postby Wheelerof4te » 2019-08-06 16:44

Denteoli wrote: I used Wicd

Have you tried with NetworkManager instead? Wicd might use old wlan interface, maybe you need to change it in teh settings.
Also, it doesn't matter if it works on Lubuntu, as Ubuntu is just a Debian snapshot with some tweaks and added non-free firmware.
Wheelerof4te
 
Posts: 1423
Joined: 2015-08-30 20:14

Re: Broadcom wireless card doesn't work

Postby CwF » 2019-08-06 17:12

Wicd will work fine, my preference. Wicd does no auto detection, it does need to be told the interface name. Then, cycle the wifi off/on in wicd and Refresh. Detailed elsewhere is how to set a single name in wicd and use dynamic rules for usb gadgets to be renamed, then wicd always works by cycling and refreshing. Or rename the usb gadget to wlan and wicd will likely work already...
CwF
 
Posts: 443
Joined: 2018-06-20 15:16

Re: Broadcom wireless card doesn't work

Postby Head_on_a_Stick » 2019-08-06 18:36

Have you checked dmesg to see if the firmware is loaded?

Can we please see the output of
Code: Select all
ip link
# dpkg-reconfigure firmware-b43-installer

I would try the wl driver instead but it's proprietary.
User avatar
Head_on_a_Stick
 
Posts: 10377
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Broadcom wireless card doesn't work

Postby 4D696B65 » 2019-08-06 18:49

Head_on_a_Stick wrote:Have you checked dmesg to see if the firmware is loaded?

Can we please see the output of
Code: Select all
ip link
# dpkg-reconfigure firmware-b43-installer

I would try the wl driver instead but it's proprietary.

As far as I know, the blob installed by firmware-b43-installer is proprietary
User avatar
4D696B65
 
Posts: 2427
Joined: 2009-06-28 06:09

Re: Broadcom wireless card doesn't work

Postby Head_on_a_Stick » 2019-08-06 19:30

^ Yes, that's right, good point.
User avatar
Head_on_a_Stick
 
Posts: 10377
Joined: 2014-06-01 17:46
Location: /dev/chair


Return to Hardware

Who is online

Users browsing this forum: No registered users and 7 guests

fashionable