Debian won't boot on a Multiboot ISO USB!

Help with issues regarding installation of Debian

Debian won't boot on a Multiboot ISO USB!

Postby Xeno Idaltu » 2019-08-15 06:30

1) I made a Multiboot ISO USB following this tutorial. ... stros.html

Everything works as expected. With the exception of Debian. I tried to install KDE Debian Buster 10.0.0 without any success. I tried many things I found online and can't get it to work. I even removed all the other ISOs and only concentrated on making Debian work but to no avail! :?

2) Someone already made Debian Stretch work but when I tried it using Buster nothing worked. ... sample#L58 ... ian-netins

At first I wanted to install the Buster KDE Non-Free ISO: ... onfree.iso

3) After all steps failed I decided to just make it work by using the AMD64-Netinst ISO instead: ... etinst.iso

When I boot the laptop I get this message:
vga=ext is deprecated. Use set gfxpayload=text before linux command instead
error file '/boot/debian/install.amd/initrd.gz' not found

This is where I got the Initrd.gz package: ... /initrd.gz

4) Debian's Menu Entry on the grub.cfg file:

Code: Select all
set timeout=10
set default=0

menuentry "KDE Debian Buster ISO" {
set iso="/boot/iso/Debian-10.0.0-AMD64-NetInst.iso"
loopback loop $iso
linux (loop)/install.amd/vmlinuz iso-scan/ask_second_pass=true iso-scan/filename=$iso priority=low vga=normal quiet
initrd (loop)/boot/debian/install.amd/initrd


5) Kubuntu & KDE Manjaro boot without any problem. The grub.cfg file without Debian looks like this:

Code: Select all
set timeout=10
set default=0

menuentry "KDE Manjaro 18.0.4 ISO" {
 export iso_path
 search --set=root --file $iso_path
 probe -u -s rootuuid $root
 export rootuuid
 loopback loop $iso_path
 configfile /boot/grub/loopback.cfg
 loopback --delete loop

menuentry "Kubuntu 18.0.2 ISO" {
 loopback loop /Kubuntu-18.04.2-Desktop-AMD64.iso
 linux (loop)/casper/vmlinuz boot=casper iso-scan/filename=/Kubuntu-18.04.2-Desktop-AMD64.iso noeject noprompt splash --
 initrd (loop)/casper/initrd
User avatar
Xeno Idaltu
Posts: 35
Joined: 2019-08-15 05:36
Location: Free-Source Technocracy

Re: Debian won't boot on a Multiboot ISO USB!

Postby p.H » 2019-08-15 09:45

I strongly doubt that you get this error :
Code: Select all
error file '/boot/debian/install.amd/initrd.gz' not found

with this grub menuentry :
Code: Select all
initrd (loop)/boot/debian/install.amd/initrd

The file names are different : initrd.gz vs initrd.

Also, there is no point in using the initrd.gz file included in the ISO image. It won't work.
You must use the initrd.gz file downloaded from hd-media.
Posts: 1738
Joined: 2017-09-17 07:12

Return to Installation

Who is online

Users browsing this forum: No registered users and 10 guests