XServer + FVWM is blanking unecpected

Everything about X, Gnome, KDE, ... and everything running on it

XServer + FVWM is blanking unecpected

Postby linux4michelleWeb » 2019-08-12 08:04

Good day or whatever,

since an Debian 9 update some weeks ago, I have the problem, that my Desktop (XServer + FVWM) is unexpected blanking.
I have always to use <Ctrl><Alt><F1> and then <ALT><ARROW_LEFT> to get my Desktop back only that it start blanking again in non regular intervals...

I am using already

xset -dpms s off s blank

since quiet a while on my ThinkPad T400 and had NEVER a problem for years, but it seems, Debian has introduced a new bug in an update.

Anyone here which has the same problem?

Note: My T400 has multiboot and Debian 7+8 (I use the Laptop for Software Development) are working perfectly without any problems. Also I can install Debian 9.2 (from DVD) and the error is gone.

Any suggestions?

Thanks in advance
Michelle
linux4michelleWeb
 
Posts: 16
Joined: 2019-07-15 15:41

Re: XServer + FVWM is blanking unecpected

Postby ruwolf » 2019-08-12 19:46

Are there any errors in the syslog?
And what about dmesg?
User avatar
ruwolf
 
Posts: 392
Joined: 2008-02-18 05:04
Location: Slovakia, Banovce nad Bebravou, Matice slovenskej 1260/4-7

Re: XServer + FVWM is blanking unecpected

Postby linux4michelleWeb » 2019-08-12 20:09

It just happen again and I get in my syslog only:

Aug 12 23:17:41 t400 courierd: Purging /var/lib/courier/msgs
Aug 12 23:17:41 t400 courierd: Waiting. shutdown time=Tue Aug 13 00:17:41 2019, wakeup time=Tue Aug 13 00:17:41 2019, queuedelivering=0, inprogress=0
Aug 12 23:39:01 t400 CRON[16238]: (root) CMD ( [ -x /usr/lib/php/sessionclean ] && if [ ! -d /run/systemd/system ]; then /usr/lib/php/sessionclean; fi)
Aug 12 23:40:37 t400 wdm: (II) AIGLX: Suspending AIGLX clients for VT switch

It seems, the last line was me while switching to the console and back...
There is nothing more.

Xorg.0.log has

[ 4454.052] (II) input device 'ThinkPad Extra Buttons', /dev/input/event4 is a keyboard
[ 48244.390] (II) AIGLX: Suspending AIGLX clients for VT switch
[ 48247.927] (II) AIGLX: Resuming AIGLX clients after VT switch
[ 48248.569] (II) modeset(0): EDID vendor "LEN", prod id 16433
[ 48248.569] (II) modeset(0): Printing DDC gathered Modelines:
[ 48248.569] (II) modeset(0): Modeline "1280x800"x0.0 69.50 1280 1332 1396 1416 800 803 806 818 -hsync -vsync (49.1 kHz eP)

This error is realy bizzar
My xsession.log does not show anything either.

First I was thinking the T400 is broken (backlight), but since I could switch to the VT and see it, it is clear software error which trigger this behaviour
linux4michelleWeb
 
Posts: 16
Joined: 2019-07-15 15:41

Re: XServer + FVWM is blanking unecpected

Postby ruwolf » 2019-08-12 21:56

You probably should run command dmesg as root, e.g.
Code: Select all
sudo dmesg
. It is command, which writes you kernel ring buffer, which usually contain much more information about errors than syslog...
User avatar
ruwolf
 
Posts: 392
Joined: 2008-02-18 05:04
Location: Slovakia, Banovce nad Bebravou, Matice slovenskej 1260/4-7

Re: XServer + FVWM is blanking unecpected

Postby linux4michelleWeb » 2019-08-13 06:44

Unfortunately not:

[ 3949.197120] IPv6: ADDRCONF(NETDEV_CHANGE): enp0s25: link becomes ready
[ 6501.852770] [drm:i965_irq_handler [i915]] *ERROR* CPU pipe A FIFO underrun
[ 7039.070564] e1000e: enp0s25 NIC Link is Down
[ 7050.472522] IPv6: ADDRCONF(NETDEV_UP): enp0s25: link is not ready
[ 7053.213003] e1000e: enp0s25 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: Rx/Tx
[ 7053.213173] IPv6: ADDRCONF(NETDEV_CHANGE): enp0s25: link becomes ready
[14033.347928] perf: interrupt took too long (2502 > 2500), lowering kernel.perf_event_max_sample_rate to 79750
[14478.817063] perf: interrupt took too long (3143 > 3127), lowering kernel.perf_event_max_sample_rate to 63500
[15198.159607] perf: interrupt took too long (3938 > 3928), lowering kernel.perf_event_max_sample_rate to 50750
[16208.182606] perf: interrupt took too long (4946 > 4922), lowering kernel.perf_event_max_sample_rate to 40250
[19056.734842] perf: interrupt took too long (6192 > 6182), lowering kernel.perf_event_max_sample_rate to 32250
[49168.716185] e1000e: enp0s25 NIC Link is Down
linux4michelleWeb
 
Posts: 16
Joined: 2019-07-15 15:41

Re: XServer + FVWM is blanking unecpected

Postby Head_on_a_Stick » 2019-08-18 18:55

Please post the full output of
Code: Select all
xset -q
systemd-inhibit --no-p
Don't break DebianHow to report bugs

SharpBang GNU/Linux — a pre-configured Openbox/Tint2 desktop running on Debian stable
User avatar
Head_on_a_Stick
 
Posts: 10599
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: XServer + FVWM is blanking unecpected

Postby linux4michelleWeb » 2019-08-19 04:42

Good morning,

I use already

xset -dpms s off s noblank

since quiet a while and the out put is

Keyboard Control:
auto repeat: on key click percent: 0 LED mask: 00000000
XKB indicators:
00: Caps Lock: off 01: Num Lock: off 02: Scroll Lock: off
03: Compose: off 04: Kana: off 05: Sleep: off
06: Suspend: off 07: Mute: off 08: Misc: off
09: Mail: off 10: Charging: off 11: Shift Lock: off
12: Group 2: off 13: Mouse Keys: off
auto repeat delay: 660 repeat rate: 25
auto repeating keys: 00ffffffdffffbbf
fadfffefffedffff
9fffffffffffffff
fff7ffffffffffff
bell percent: 50 bell pitch: 400 bell duration: 100
Pointer Control:
acceleration: 2/1 threshold: 4
Screen Saver:
prefer blanking: no allow exposures: yes
timeout: 0 cycle: 600
Colors:
default colormap: 0x20 BlackPixel: 0x0 WhitePixel: 0xffffff
Font Path:
/usr/share/fonts/X11/misc,/usr/share/fonts/X11/cyrillic,/usr/share/fonts/X11/100dpi/:unscaled,/usr/share/fonts/X11/75dpi/:unscaled,/usr/share/fonts/X11/Type1,/usr/share/fonts/X11/100dpi,/usr/share/fonts/X11/75dpi,built-ins
DPMS (Energy Star):
Standby: 600 Suspend: 600 Off: 600
DPMS is Disabled


I have changed nothing since years.
First I was thinking, that the Display/Controller of my ThinkPad T400 is broken, but since I can switch to the Console and back to FVWM Desktop, a mechanical or electrical failur is excluded. Also my Debian 7 and Debian 8 installations plus Debian 9.2 from DVD is working.

This Error appeared for me in Debian 9.8.
(I upgraded from 9.4 to 9.8)

Thankyou for your help
Michelle
linux4michelleWeb
 
Posts: 16
Joined: 2019-07-15 15:41


Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 5 guests

fashionable