dependency issue

New to Debian (Or Linux in general)? Ask your questions here!

dependency issue

Postby banditz » 2019-12-21 21:09

hello, i have spent weeks trying to figure out an issue, and i need to turn to some experts. i am not sure what started all this, but i cannot seem to use apt-get or dpkg removal commands. (dpkg -P DOES work, however)

basically, most commands complain about a dependency issue and it seems to be an endless loop, with all the packages pointing at each other. cant remove one until the other is removed, etc.

i have read editing /var/lib/dpkg/status and clearing the DEPENDS: status out works, but i'd rather not do that unless i absolutely have to.

here are some outputs:

sudo dpkg --audit
The following packages have been unpacked but not yet configured.
They must be configured using dpkg --configure or the configure
menu option in dselect for them to work:
gstreamer1.0-plugins-bad:armhf GStreamer plugins from the "bad" set
libgstreamer-plugins-bad1.0-0:armhf GStreamer development files for libraries from t
libwebkit2gtk-4.0-37:armhf Web content engine library for GTK
libyelp0:armhf Library for the GNOME help browser
yelp Help browser for GNOME


okay, lets try one:
dpkg --configure yelp
dpkg: dependency problems prevent configuration of yelp:
yelp depends on libwebkit2gtk-4.0-37 (>= 2.5.3); however:
Package libwebkit2gtk-4.0-37:armhf is not configured yet.
yelp depends on libyelp0 (= 3.31.90-1); however:
Package libyelp0:armhf is not configured yet.

dpkg: error processing package yelp (--configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
yelp


okay, what about apt?
apt --fix-broken install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
idle-python2.7 libboost-date-time1.62.0 libboost-filesystem1.61.0 libboost-iostreams1.61.0 libboost-system1.61.0 libde265-0 libgltf-0.0-0v5 libmspack0 libnautilus-extension1a libopencv-calib3d2.4v5 libopencv-core2.4v5
libopencv-features2d2.4v5 libopencv-flann2.4v5 libopencv-highgui2.4-deb0 libopencv-imgproc2.4v5 libopencv-objdetect2.4v5 libopencv-video2.4v5 liborcus-0.11-0 libreoffice-gtk2 libreoffice-ogltrans libreoffice-pdfimport libuu0
libwebrtc-audio-processing1
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
gstreamer1.0-gl libgstreamer-gl1.0-0
The following NEW packages will be installed:
gstreamer1.0-gl libgstreamer-gl1.0-0
0 upgraded, 2 newly installed, 0 to remove and 1029 not upgraded.
5 not fully installed or removed.
Need to get 0 B/2,615 kB of archives.
After this operation, 2,985 kB of additional disk space will be used.
Do you want to continue? [Y/n] Y
WARNING: The following packages cannot be authenticated!
libgstreamer-gl1.0-0 gstreamer1.0-gl
Install these packages without verification? [y/N] y
/usr/share/apt-listchanges/apt_listchanges.py:523: FutureWarning: Possible nested set at position 25
email_re = re.compile(r'([a-zA-Z0-9_\+\-\.]+)@(([[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.)|(([a-zA-Z0-9\-]+\.)+))([a-zA-Z]{2,4}|[0-9]{1,3})(\]?)')
(Reading database ... 153938 files and directories currently installed.)
Preparing to unpack .../libgstreamer-gl1.0-0_1.14.4-2_armhf.deb ...
Unpacking libgstreamer-gl1.0-0:armhf (1.14.4-2) ...
dpkg: error processing archive /var/cache/apt/archives/libgstreamer-gl1.0-0_1.14.4-2_armhf.deb (--unpack):
trying to overwrite '/usr/lib/arm-linux-gnueabihf/libgstgl-1.0.so.0', which is also in package libgstreamer-plugins-bad1.0-0:armhf 1:1.10.4-dmo2
Preparing to unpack .../gstreamer1.0-gl_1.14.4-2_armhf.deb ...
Unpacking gstreamer1.0-gl:armhf (1.14.4-2) ...
dpkg: error processing archive /var/cache/apt/archives/gstreamer1.0-gl_1.14.4-2_armhf.deb (--unpack):
trying to overwrite '/usr/lib/arm-linux-gnueabihf/gstreamer-1.0/libgstopengl.so', which is also in package gstreamer1.0-plugins-bad:armhf 1:1.10.4-dmo2
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
/var/cache/apt/archives/libgstreamer-gl1.0-0_1.14.4-2_armhf.deb
/var/cache/apt/archives/gstreamer1.0-gl_1.14.4-2_armhf.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)



long story short, i've tried other commands like:
apt-get install -f
dpkg --configure -a
apt-get autoremove


etc...they all lead back to the dependency issue. tearing hair out :(

this is on a raspi running what i think is debian 9 stretch? i am still learning linux, have a long way to go, so please be patient. if you need to see any outputs or have any suggestions please let me know. thank you
banditz
 
Posts: 3
Joined: 2019-12-21 20:55

Re: dependency issue

Postby L_V » 2019-12-21 21:40

banditz wrote:Beginners Questions /
i have read editing /var/lib/dpkg/status and clearing the DEPENDS: status out works, but i'd rather not do that unless i absolutely have to.
they all lead back to the dependency issue. tearing hair out

In which documentation did you find that dependencies are managed by editing /var/lib/dpkg/status ?
Do you know better than Debian which packages are necessary ?
Just to have a look (I am curious)
Code: Select all
find /etc/apt -name '*.list' -print -exec grep "^deb " {} \;
L_V
 
Posts: 1270
Joined: 2007-03-19 09:04

Re: dependency issue

Postby banditz » 2019-12-21 21:47

L_V wrote:
banditz wrote:Beginners Questions /
i have read editing /var/lib/dpkg/status and clearing the DEPENDS: status out works, but i'd rather not do that unless i absolutely have to.
they all lead back to the dependency issue. tearing hair out

In which documentation did you find that dependencies are managed by editing /var/lib/dpkg/status ?
Do you know better than Debian which packages are necessary ?
Just to have a look (I am curious)
Code: Select all
find /etc/apt -name '*.list' -print -exec grep "^deb " {} \;


sorry, i should have clarified-- the part where i said "i have read" meant i saw it on another forum post. i have not edited anything, only grasping for answers, thats all! :)

thanks for your reply, here is the output from your find command:

/etc/apt/sources.list
deb http://raspbian.raspberrypi.org/raspbian/ stretch main contrib non-free rpi
deb http://www.deb-multimedia.org stretch main non-free
deb http://ftp.debian.org/debian/ stable main contrib non-free
deb http://ftp.de.debian.org/debian stretch main
/etc/apt/sources.list.d/plexmediaserver.list
deb https://downloads.plex.tv/repo/deb ./public main
/etc/apt/sources.list.d/raspi.list
deb http://archive.raspberrypi.org/debian/ stretch main ui
banditz
 
Posts: 3
Joined: 2019-12-21 20:55

Re: dependency issue

Postby L_V » 2019-12-21 21:50

and this
Code: Select all
apt install -fs
apt list --installed | grep dmo
L_V
 
Posts: 1270
Joined: 2007-03-19 09:04

Re: dependency issue

Postby dilberts_left_nut » 2019-12-21 22:32

and stable != stretch any more.
AdrianTM wrote:There's no hacker in my grandma...
User avatar
dilberts_left_nut
 
Posts: 5074
Joined: 2009-10-05 07:54
Location: enzed

Re: dependency issue

Postby banditz » 2019-12-22 01:19

L_V wrote:and this
Code: Select all
apt install -fs
apt list --installed | grep dmo


pi@raspberrypi: $ sudo apt install -fs

Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
idle-python2.7 libboost-date-time1.62.0 libboost-filesystem1.61.0 libboost-iostreams1.61.0 libboost-system1.61.0 libde265-0 libgltf-0.0-0v5 libmspack0 libnautilus-extension1a libopencv-calib3d2.4v5 libopencv-core2.4v5
libopencv-features2d2.4v5 libopencv-flann2.4v5 libopencv-highgui2.4-deb0 libopencv-imgproc2.4v5 libopencv-objdetect2.4v5 libopencv-video2.4v5 liborcus-0.11-0 libreoffice-gtk2 libreoffice-ogltrans libreoffice-pdfimport libuu0
libwebrtc-audio-processing1
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
gstreamer1.0-gl libgstreamer-gl1.0-0
The following NEW packages will be installed:
gstreamer1.0-gl libgstreamer-gl1.0-0
0 upgraded, 2 newly installed, 0 to remove and 1029 not upgraded.
5 not fully installed or removed.
Inst libgstreamer-gl1.0-0 (1.14.4-2 Debian:10.2/stable [armhf])
Inst gstreamer1.0-gl (1.14.4-2 Debian:10.2/stable [armhf])
Conf libgstreamer-gl1.0-0 (1.14.4-2 Debian:10.2/stable [armhf])
Conf gstreamer1.0-gl (1.14.4-2 Debian:10.2/stable [armhf])
Conf yelp (3.31.90-1 Debian:10.2/stable [armhf])
Conf libyelp0 (3.31.90-1 Debian:10.2/stable [armhf])
Conf gstreamer1.0-plugins-bad (1:1.10.4-dmo2 Unofficial Multimedia Packages:9.11/oldstable [armhf])
Conf libwebkit2gtk-4.0-37 (2.26.1-3~deb10u1 Debian:10.2/stable [armhf])
Conf libgstreamer-plugins-bad1.0-0 (1:1.10.4-dmo2 Unofficial Multimedia Packages:9.11/oldstable [armhf])


pi@raspberrypi: $ sudo apt list --installed | grep dmo

ffmpeg/oldstable,now 10:3.3.9-dmo1+deb9u1 armhf [installed]
gstreamer1.0-libav/oldstable,now 1.10.4-1 armhf [installed,upgradable to: 1:1.10.4-dmo1]
gstreamer1.0-plugins-bad/oldstable,now 1:1.10.4-dmo2 armhf [installed]
libaacs0/oldstable,now 0.8.1-2 armhf [installed,upgradable to: 0.9.0-dmo1]
libass9/oldstable,now 2:0.13.7-dmo1 armhf [installed,automatic]
libavcodec57/oldstable,now 10:3.3.9-dmo1+deb9u1 armhf [installed,automatic]
libavdevice57/oldstable,now 10:3.3.9-dmo1+deb9u1 armhf [installed,automatic]
libavfilter6/oldstable,now 10:3.3.9-dmo1+deb9u1 armhf [installed,automatic]
libavformat57/oldstable,now 10:3.3.9-dmo1+deb9u1 armhf [installed,automatic]
libavresample3/oldstable,now 10:3.3.9-dmo1+deb9u1 armhf [installed,automatic]
libavutil55/oldstable,now 10:3.3.9-dmo1+deb9u1 armhf [installed,automatic]
libbasicusageenvironment1/oldstable,now 2016.11.28-1+deb9u2 armhf [installed,upgradable to: 2:2017.04.26-dmo1+deb9u2]
libbdplus0/oldstable,now 0.1.2-2 armhf [installed,upgradable to: 0.1.2-dmo1+deb8u1]
libbluray2/stable,now 1:1.0.2-1 armhf [installed,upgradable to: 2:1.0.0-dmo1]
libchromaprint1/oldstable,now 1.4.2-1 armhf [installed,upgradable to: 1:1.4.2-dmo1]
libdvbpsi10/oldstable,now 1.3.0-5 armhf [installed,upgradable to: 1:1.3.1-dmo1]
libebml4v5/now 1.3.4-1 armhf [installed,upgradable to: 1:1.3.9-dmo0+deb9u1]
libfaac0/oldstable,now 1:1.28-dmo5 armhf [installed,automatic]
libfdk-aac1/oldstable,now 1:0.1.5-dmo2 armhf [installed,automatic]
libgroupsock8/oldstable,now 2016.11.28-1+deb9u2 armhf [installed,upgradable to: 2:2017.04.26-dmo1+deb9u2]
libgstreamer-plugins-bad1.0-0/oldstable,now 1:1.10.4-dmo2 armhf [installed,automatic]
libilbc2/oldstable,now 2.0.2-dmo4 armhf [installed,automatic]
libkvazaar3/oldstable,now 1:1.1.0-dmo1 armhf [installed,automatic]
libmatroska6v5/oldstable,now 1.4.5-2 armhf [installed,upgradable to: 1:1.4.5-dmo1]
libmjpegutils-2.1-0/oldstable,now 1:2.1.0+debian-5 armhf [installed,upgradable to: 2:2.1.0-dmo9]
libmp3lame0/oldstable,now 1:3.99.5-dmo6 armhf [installed,automatic]
libmpeg2encpp-2.1-0/oldstable,now 1:2.1.0+debian-5 armhf [installed,upgradable to: 2:2.1.0-dmo9]
libmplex2-2.1-0/oldstable,now 1:2.1.0+debian-5 armhf [installed,upgradable to: 2:2.1.0-dmo9]
libnfs8/oldstable,now 1.11.0-2 armhf [installed,upgradable to: 1.11.0-dmo1]
libopenh264-2/oldstable,now 1.6.0-dmo3 armhf [installed,automatic]
libpostproc54/oldstable,now 10:3.3.9-dmo1+deb9u1 armhf [installed,automatic]
librtmp1/oldstable,now 2.4+20151223.gitfa8646d.1-1 armhf [installed,upgradable to: 2:2.4~20160119.gitfa8646dae-dmo5]
libswresample2/oldstable,now 10:3.3.9-dmo1+deb9u1 armhf [installed,automatic]
libswscale4/oldstable,now 10:3.3.9-dmo1+deb9u1 armhf [installed,automatic]
libtwolame0/oldstable,now 0.3.13-2 armhf [installed,upgradable to: 1:0.3.13-dmo3]
libusageenvironment3/oldstable,now 2016.11.28-1+deb9u2 armhf [installed,upgradable to: 2:2017.04.26-dmo1+deb9u2]
libvidstab1.0/oldstable,now 2:0.98b-dmo1+deb8u1 armhf [installed,automatic]
libvlc-bin/now 3.0.6-0+rpt4+deb9u1 armhf [installed,upgradable to: 1:3.0.8-dmo0+deb9u4]
libvlc5/now 3.0.6-0+rpt4+deb9u1 armhf [installed,upgradable to: 1:3.0.8-dmo0+deb9u4]
libvlccore9/now 3.0.6-0+rpt4+deb9u1 armhf [installed,upgradable to: 1:3.0.8-dmo0+deb9u4]
libx264-150/oldstable,now 3:0.150.2833+gitdf79067-dmo1 armhf [installed,automatic]
libx265-116/oldstable,now 1:2.4-dmo1 armhf [installed,automatic]
libxvidcore4/oldstable,now 2:1.3.4-1 armhf [installed,upgradable to: 3:1.3.4-dmo1]
vlc-bin/now 3.0.6-0+rpt4+deb9u1 armhf [installed,upgradable to: 1:3.0.8-dmo0+deb9u4]
vlc-data/now 3.0.6-0+rpt4+deb9u1 all [installed,upgradable to: 1:3.0.8-dmo0+deb9u4]
vlc-l10n/now 3.0.6-0+rpt4+deb9u1 all [installed,upgradable to: 1:3.0.8-dmo0+deb9u4]
vlc-plugin-base/now 3.0.6-0+rpt4+deb9u1 armhf [installed,upgradable to: 1:3.0.8-dmo0+deb9u4]
vlc-plugin-notify/now 3.0.6-0+rpt4+deb9u1 armhf [installed,upgradable to: 1:3.0.8-dmo0+deb9u4]
vlc-plugin-qt/now 3.0.6-0+rpt4+deb9u1 armhf [installed,upgradable to: 1:3.0.8-dmo0+deb9u4]
vlc-plugin-samba/now 3.0.6-0+rpt4+deb9u1 armhf [installed,upgradable to: 1:3.0.8-dmo0+deb9u4]
vlc-plugin-skins2/now 3.0.6-0+rpt4+deb9u1 armhf [installed,upgradable to: 1:3.0.8-dmo0+deb9u4]
vlc-plugin-video-output/now 3.0.6-0+rpt4+deb9u1 armhf [installed,upgradable to: 1:3.0.8-dmo0+deb9u4]
vlc-plugin-video-splitter/now 3.0.6-0+rpt4+deb9u1 armhf [installed,upgradable to: 1:3.0.8-dmo0+deb9u4]
vlc-plugin-visualization/now 3.0.6-0+rpt4+deb9u1 armhf [installed,upgradable to: 1:3.0.8-dmo0+deb9u4]
vlc/now 3.0.6-0+rpt4+deb9u1 armhf [installed,upgradable to: 1:3.0.8-dmo0+deb9u4]
xserver-xorg-video-fbturbo/stable,now 1.20170324~143242 armhf [installed,upgradable to: 2:0.4.0+2016-05-05-dmo5]


pi@raspberrypi: $ sudo apt autoremove

Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
libwebkit2gtk-4.0-37 : Depends: libgstreamer-gl1.0-0 (>= 1.14.0) but it is not installed
Recommends: gstreamer1.0-gl but it is not installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
banditz
 
Posts: 3
Joined: 2019-12-21 20:55

Re: dependency issue

Postby L_V » 2019-12-22 10:05

Who asked you to execute "sudo apt remove" ???
On how many forums are you asking help with the risk of mixing commands you should not ?

Where did you find the documentation which explains that deb-multimedia.org was necessary to you ?
Your major problem is first packages coming from deb-multimedia.org.

You have to replace all of them by packages coming from Debian.
Example VLC is available at Debian: https://packages.debian.org/stretch/vlc

I am not going to support till the end, but using aptitude instead of apt or apt-get should be more convenient to solve such situation.

Remove or comment this line from /etc/apt/sources.list
Code: Select all
# deb http://www.deb-multimedia.org stretch main non-free

Code: Select all
apt update

You can try replacing VLC to start and see what happen, wishing you good luck
Code: Select all
apt install vlc=3.0.8-0+deb9u1

=>>> Please use "code" to report commands.
L_V
 
Posts: 1270
Joined: 2007-03-19 09:04

Re: dependency issue

Postby Head_on_a_Stick » 2019-12-22 11:04

banditz wrote:
Code: Select all
deb http://raspbian.raspberrypi.org/raspbian/ stretch main contrib non-free rpi

Perhaps ask on the Raspbian forums?

And note that you're now running a buster based system, not stretch.
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 12497
Joined: 2014-06-01 17:46
Location: /dev/chair


Return to Beginners Questions

Who is online

Users browsing this forum: No registered users and 10 guests

fashionable