Headset issue - no sound after recent testing update

Everything about X, Gnome, KDE, ... and everything running on it

Headset issue - no sound after recent testing update

Postby DarkPhoenix » 2020-01-12 16:06

I am using a laptop with a headset. After last upgrade and a reboot which followed it I have issues with getting the headset's sound + mic working. But first, some info on my setup.

My related system specs:
- Alienware 17 R5 laptop / motherboard, 2 separate 3.5 mm sockets for headphones and mic
- Audio: Intel Corporation Cannon Lake PCH cAVS (rev 10)
- The headset with 2 separate 3.5 mm connectors (headphones + mic)
- OS: I am using debian testing + unstable on my system (all but 2-3 packages are from testing). Updating system somewhat regularly, but rebooting only every now and then. Pulse Audio is used by Gnome, which is my DE.

Now, back to my problem. When I plug in headphone jack (audio output), Gnome presents me with a choice: headphones, headset, or mic. This was a new thing after the reboot - never got it before. According to these preferences it seems to choose input and output audio devices, which are exposed in Gnome control center. I chose headset and output is working alright. But for input laptop's built-in mic was used instead. So i opened sound options and tried to find out how to make it work.

Output has 2 options:
- speakers - built-in audio (uses speakers built into laptop)
- headphones - built-in audio (uses headphone speakers)

Input has 3:
- internal microphone - built-in audio (uses mic built into laptop)
- headset microphone - built-in audio (doesn't seem to be a valid option for my configuration)
- microphone - built-in audio (uses headset mic)

The actual problem is that when i select "headphones - built-in audio" for output and "microphone - built-in audio" for input, my audio input works, but i do not get any output into my headset speakers. Hardware works, as far as I understand, because combination of "headphones - built-in audio" output and "internal microphone - built-in audio" input correctly plays audio via headset.

So i need to understand where do i have to look to find out which component is to blame, and which logs do I have to provide to make a useful bug report?

The only part which is definitely relevant is last upgrade log, which hints that newer kernel might be an issue:

Code: Select all
Start-Date: 2020-01-12  16:14:34
Commandline: apt-get dist-upgrade
Requested-By: dfx (1000)
Install: linux-headers-5.4.0-2-common:amd64 (5.4.8-1, automatic), libtorrent21:amd64 (0.13.8-2, automatic), linux-headers-5.4.0-2-amd64:amd64 (5.4.8-1, automatic), linux-kbuild-5.4:amd64 (5.4.8-1, automatic), linux-image-5.4.0-2-amd64:amd64 (5.4.8-1, automatic)
Upgrade: evolution-data-server-common:amd64 (3.34.1-1, 3.34.1-2), libclutter-1.0-0:amd64 (1.26.2+dfsg-12, 1.26.2+dfsg-13), libplist3:amd64 (2.1.0-3, 2.1.0-4), libcom-err2:amd64 (1.45.4-1, 1.45.5-2), libcom-err2:i386 (1.45.4-1, 1.45.5-2), libedataserverui-1.2-2:amd64 (3.34.1-1+b1, 3.34.1-2), libqt5multimediagsttools5:amd64 (5.12.5-1, 5.12.5-1+b1), gir1.2-mutter-5:amd64 (3.34.2-2, 3.34.3-1), gnupg-utils:amd64 (2.2.17-3, 2.2.19-1), rustc:amd64 (1.40.0+dfsg1-1, 1.40.0+dfsg1-5), linux-libc-dev:amd64 (5.3.15-1, 5.4.8-1), gpg-wks-client:amd64 (2.2.17-3, 2.2.19-1), gir1.2-clutter-1.0:amd64 (1.26.2+dfsg-12, 1.26.2+dfsg-13), gnupg-l10n:amd64 (2.2.17-3, 2.2.19-1), python-yaml:amd64 (5.2-1, 5.3-1), libedata-cal-2.0-1:amd64 (3.34.1-1+b1, 3.34.1-2), libkmod2:amd64 (26-3, 26+20191223-1), libqt5multimedia5:amd64 (5.12.5-1, 5.12.5-1+b1), e2fsprogs:amd64 (1.45.4-1, 1.45.5-2), gpg-wks-server:amd64 (2.2.17-3, 2.2.19-1), openssh-sftp-server:amd64 (1:8.1p1-2, 1:8.1p1-4), gpg:amd64 (2.2.17-3, 2.2.19-1), evolution-data-server:amd64 (3.34.1-1+b1, 3.34.1-2), libstd-rust-dev:amd64 (1.40.0+dfsg1-1, 1.40.0+dfsg1-5), libmutter-5-0:amd64 (3.34.2-2, 3.34.3-1), libpipeline1:amd64 (1.5.2-1, 1.5.2-2), libmagic1:amd64 (1:5.37-6, 1:5.38-3), libpq5:amd64 (12.1-1, 12.1-2), kmod:amd64 (26-3, 26+20191223-1), mutter-common:amd64 (3.34.2-2, 3.34.3-1), rust-gdb:amd64 (1.40.0+dfsg1-1, 1.40.0+dfsg1-5), dirmngr:amd64 (2.2.17-3, 2.2.19-1), libss2:amd64 (1.45.4-1, 1.45.5-2), python3-pycurl:amd64 (,, libqt5multimediawidgets5:amd64 (5.12.5-1, 5.12.5-1+b1), libext2fs2:amd64 (1.45.4-1, 1.45.5-2), libebackend-1.2-10:amd64 (3.34.1-1+b1, 3.34.1-2), libqt5multimedia5-plugins:amd64 (5.12.5-1, 5.12.5-1+b1), libmagic-mgc:amd64 (1:5.37-6, 1:5.38-3), libebook-1.2-20:amd64 (3.34.1-1+b1, 3.34.1-2), libimobiledevice6:amd64 (1.2.1~git20190929.60823f9-2, 1.2.1~git20191129.9f79242-1), ssh:amd64 (1:8.1p1-2, 1:8.1p1-4), linux-image-amd64:amd64 (5.3.15-1, 5.4.8-1), python-pkg-resources:amd64 (41.2.0-1, 44.0.0-1), gnome-shell-common:amd64 (3.34.2-1, 3.34.3-1), gpgv:amd64 (2.2.17-3, 2.2.19-1), python3-yaml:amd64 (5.2-1, 5.3-1), linux-headers-amd64:amd64 (5.3.15-1, 5.4.8-1), python3-pkg-resources:amd64 (41.2.0-1, 44.0.0-1), python-setuptools:amd64 (41.2.0-1, 44.0.0-1), openssh-server:amd64 (1:8.1p1-2, 1:8.1p1-4), libstd-rust-1.40:amd64 (1.40.0+dfsg1-1, 1.40.0+dfsg1-5), openssh-client:amd64 (1:8.1p1-2, 1:8.1p1-4), libgcab-1.0-0:amd64 (1.3-1, 1.4-1), file:amd64 (1:5.37-6, 1:5.38-3), libebook-contacts-1.2-3:amd64 (3.34.1-1+b1, 3.34.1-2), libedata-book-1.2-26:amd64 (3.34.1-1+b1, 3.34.1-2), rtorrent:amd64 (0.9.7-1+b1, 0.9.8-1), libecal-2.0-1:amd64 (3.34.1-1+b1, 3.34.1-2), linux-compiler-gcc-9-x86:amd64 (5.3.15-1, 5.4.8-1), gnome-shell:amd64 (3.34.2-1, 3.34.3-1), logsave:amd64 (1.45.4-1, 1.45.5-2), gnupg:amd64 (2.2.17-3, 2.2.19-1), libcamel-1.2-62:amd64 (3.34.1-1+b1, 3.34.1-2), libclutter-1.0-common:amd64 (1.26.2+dfsg-12, 1.26.2+dfsg-13), gpg-agent:amd64 (2.2.17-3, 2.2.19-1), libedataserver-1.2-24:amd64 (3.34.1-1+b1, 3.34.1-2), gpgconf:amd64 (2.2.17-3, 2.2.19-1), python3-setuptools:amd64 (41.2.0-1, 44.0.0-1), mutter:amd64 (3.34.2-2, 3.34.3-1), gpgsm:amd64 (2.2.17-3, 2.2.19-1)
End-Date: 2020-01-12  16:16:48
Last edited by DarkPhoenix on 2020-01-12 19:27, edited 3 times in total.
User avatar
Posts: 10
Joined: 2008-03-16 10:49

Re: Help with debugging a headset configuration issue

Postby DarkPhoenix » 2020-01-12 17:35

I tried reverting to older kernel. The version I was using (linux-image-5.3.0-2-amd64 5.3.9-3) was unavailable, so I downloaded a bit newer one (linux-image-5.3.0-3-amd64 5.3.15-1) and tried it. In Gnome control center, several options for input and output were gone. Whenever I plugged output jack of my headset, the system just switched single available option automatically (e.g. from "speakers - built-in audio" to "headphones - built-in audio"). Nevertheless, when I had headset plugged in, output did not work (neither built-in speakers nor headphones), but input was taken from the headset mic.

Installed my previously used kernel version now (linux-image-5.3.0-2-amd64 5.3.9-3) and it works exactly like linux-image-5.3.0-3-amd64 5.3.15-1. When the headset is plugged in, the headset mic is used but the headset cannot be used to play any audio output.
User avatar
Posts: 10
Joined: 2008-03-16 10:49

Re: Headset issue - no sound after recent testing update

Postby stevepusser » 2020-01-12 20:35

How about trying a 5.4 kernel?
MX Linux packager and developer
User avatar
Posts: 12009
Joined: 2009-10-06 05:53

Re: Headset issue - no sound after recent testing update

Postby DarkPhoenix » 2020-01-12 21:27

As the apt log shows - I installed 5.4 kernel and rebooted before I first faced this issue. It is the first version which allows me to select input/output audio device manually in gnome control center, and it still has the issue with inability to use external mic as input and headphones as output.

But I guess I will try 5.5 from experimental...
edit: nevermind, the system does not boot up with it
User avatar
Posts: 10
Joined: 2008-03-16 10:49

Re: Headset issue - no sound after recent testing update

Postby DarkPhoenix » 2020-01-26 12:06

Had some time to debug this issue a little. Kernel now is 5.4.0-3-amd64 #1 SMP Debian 5.4.13-1 (2020-01-19) x86_64 GNU/Linux. Decided to find out if it's pulse audio or not. What i did:

1) Figure out mapping between devices, Gnome control panel names and ALSA mixer names:

Code: Select all
Builtin speakers:
  Control panel name: Speakers - Built-in Audio
  ALSA mixer name: Speaker

  Control panel name: Headphones - Built-in Audio
  ALSA mixer name: Headphone

Code: Select all
Laptop mic:
  Control panel name: Internal Microphone - Built-in Audio
  ALSA mixer name: Internal Mic

Headset mic:
  Control panel name: Microphone - Built-in Audio
  ALSA mixer name: Headphone Mic

Some stub mic which is impossible to use with my hardware:
  Control panel name: Headset Microphone - Built-in Audio
  ALSA mixer name: Headset Mic

2) Avoid using Gnome (which as far as i understand has pulseaudio dependency - was hard for me to figure out how to stop it from being relaunched), then:
Code: Select all
cd /etc/alsa/conf.d/
sudo mv 50-pulseaudio.conf 50-pulseaudio.conf.bak
sudo mv 99-pulse.conf 99-pulse.conf.bak

Then reboot and:
Code: Select all
pulseaudio -k
aplay ~/Downloads/file_example_WAV_1MG.wav &

I checked that pulseaudio is not launched via "ps aux | grep pulse" after starting aplay.
3) Headset was plugged in with both jacks. While audio file was being played, in alsa mixer I opened Capture section and switched between "Internal Mic" and "Headphone Mic". Whenever I switch to "Headphone Mic" playback to Headset is muted, whenever i switch away from it - it reappears again.

So, this is either some kernel issue or some ALSA configuration issue. Any advices on how to proceed? Just file a bug report in Debian bug tracker?
User avatar
Posts: 10
Joined: 2008-03-16 10:49

Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 15 guests