Trying to upgrade to Buster from Stretch now Bullseye

Help with issues regarding installation of Debian

Trying to upgrade to Buster from Stretch now Bullseye

Postby HappyGilmore » 2020-01-09 18:39

Question, yesterday I was using to try to update to Buster to see if they fixed my video card issue that was there when they first release buster.

I did the upgrade through the gui not the command just because it was easier, which might have been my down fall on this.

After the upgrade, no video card issues at all, I was that is awesome. Only thing bad I noticed was oracle virtual box program was removed from my programs listed that happen to me last time too. Not the issue I am asking about.

The issue I am asking about how did I get Bullseye/SID installed when I did not think you could go to bulleye because of source list I have pasted below.

No I can not install Oracle Virtual Box, I think on Bullseye.

deb http://ftp.us.debian.org/debian/ stretch main
#deb-src http://ftp.us.debian.org/debian/ stretch main

deb http://security.debian.org/debian-security stretch/updates main contrib
#deb-src http://security.debian.org/debian-security stretch/updates main contrib

deb http://ftp.de.debian.org/debian sid main

deb https://download.virtualbox.org/virtualbox/debian stretch contrib
HappyGilmore
 
Posts: 30
Joined: 2019-07-17 20:01

Re: Trying to upgrade to Buster from Stretch now Bullseye

Postby Head_on_a_Stick » 2020-01-09 18:51

You appear to be running sid. Good luck with that :mrgreen:
User avatar
Head_on_a_Stick
 
Posts: 12001
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Trying to upgrade to Buster from Stretch now Bullseye

Postby HappyGilmore » 2020-01-09 19:05

Head_on_a_Stick wrote:You appear to be running sid. Good luck with that :mrgreen:


It is working fine really, no issues.
HappyGilmore
 
Posts: 30
Joined: 2019-07-17 20:01

Re: Trying to upgrade to Buster from Stretch now Bullseye

Postby Head_on_a_Stick » 2020-01-09 19:07

Yeah, as the skydiver with the broken parachute kept saying to himself:
So far, so good...

:mrgreen:
User avatar
Head_on_a_Stick
 
Posts: 12001
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Trying to upgrade to Buster from Stretch now Bullseye

Postby CwF » 2020-01-20 01:34

CwF
 
Posts: 657
Joined: 2018-06-20 15:16

Re: Trying to upgrade to Buster from Stretch now Bullseye

Postby HappyGilmore » 2020-02-25 19:50

I did get oracle virtualbox to installed on my laptop.
I just need to change the etc/apt/sources.list for virtual box to buster
then did apt-get update
then apt -install virtualbox 6.1 work fine
HappyGilmore
 
Posts: 30
Joined: 2019-07-17 20:01

Re: Trying to upgrade to Buster from Stretch now Bullseye

Postby stevepusser » 2020-02-25 22:16

Stay tuned in, folks!

Image
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Kodi 18.6, Strawberry 0.6.11, Muse 3.1.0, Chromium with va-api, Audacity 2.4.1, Kdenlive 20.04
User avatar
stevepusser
 
Posts: 11693
Joined: 2009-10-06 05:53

Re: Trying to upgrade to Buster from Stretch now Bullseye

Postby None1975 » 2020-02-26 13:07

HappyGilmore wrote:I just need to change the etc/apt/sources.list for virtual box to buster
then did apt-get update



Image
OS: Debian 10.3 Buster / WM: xmonad
Debian Wiki | DontBreakDebian, My config files on github
User avatar
None1975
 
Posts: 1010
Joined: 2015-11-29 18:23
Location: Lithuania, Vilnius

Re: Trying to upgrade to Buster from Stretch now Bullseye

Postby stevepusser » 2020-02-26 20:29

Head_on_a_Stick wrote:Yeah, as the skydiver with the broken parachute kept saying to himself:
So far, so good...

:mrgreen:


You can now make this even more topical by having Mad Mike saying this throughout his last "flight" (warning, not graphic at all, but does show his death at a great remove): https://www.youtube.com/watch?v=zZOXh_GB9sc

What, too soon? :? I'm not even adding what his epitaph will read!

His publicist later admitted that all the Flat Earth crap was a shtick, since earlier straight fundraising attempts raised only a pittance.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Kodi 18.6, Strawberry 0.6.11, Muse 3.1.0, Chromium with va-api, Audacity 2.4.1, Kdenlive 20.04
User avatar
stevepusser
 
Posts: 11693
Joined: 2009-10-06 05:53

Re: Trying to upgrade to Buster from Stretch now Bullseye

Postby sunrat » 2020-02-26 21:19

Wow! Both to Mad Mike's demise and to OPs Frankendebian.

@HappyGilmore - if you remove the stretch sources and edit the sid sources then do full-upgrade you may just get away with it. Of course you'll be running Sid so welcome to a life of eternal upgrades and occasional breakages. Be prepared to do full-upgrade at least once a week and download several hundreds of megabytes each time.
“ computer users can be divided into 2 categories:
Those who have lost data
...and those who have not lost data YET ”
Remember to BACKUP!
User avatar
sunrat
 
Posts: 3074
Joined: 2006-08-29 09:12
Location: Melbourne, Australia


Return to Installation

Who is online

Users browsing this forum: No registered users and 13 guests

fashionable