Loading on Macbook Pro ends with error on radeon graphics

Help with issues regarding installation of Debian

Loading on Macbook Pro ends with error on radeon graphics

Postby jeromezooce » 2020-11-07 21:03

Hello !

I made a successful installation of Debian 10.6 32 bits on my 2007 MacBook Pro "Core Duo" 2.16 GHz (T2600).
Debian version installed is: i386/iso-hybrid/debian-live-10.6.0-i386-gnome.iso.

After some fixing such as installing the firmware-linux-nonfree and firmware-amd-graphics packages, I now boot and get the following message:
"fb: switching to radeondrmfb from EFI VGA"

My understanding is that it is switching from the default/basic VGA to using the Radeon GPU, but fails.
Once this message displayed, the system is stuck.

What could I do to unblock the situation?

Details on hardware:
[*] MacBook Pro "Core Duo" 2.16 GHz includes an ATI Mobility Radeon X1600 graphics processor with 256 MB of GDDR3 video memory and dual-link DVI functionality
[*] lspci -nn says: [AMD/ATI] RV530/M56-P [Mobility Radeon X1600] [1002:71c5]


Any help or suggestion is greatly appreciated.
jeromezooce
 
Posts: 3
Joined: 2020-11-07 19:55

Re: Loading on Macbook Pro ends with error on radeon graphic

Postby Head_on_a_Stick » 2020-11-08 08:01

jeromezooce wrote:Once this message displayed, the system is stuck.

Did you try switching to a console (TTY) screen? Adding 2 (or 3, or 4) as a kernel command line parameter will stop the graphical display from starting. Once you have a console login you can check the kernel driver and logs.
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 12770
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Loading on Macbook Pro ends with error on radeon graphic

Postby jeromezooce » 2020-11-08 11:27

Head_on_a_Stick wrote:
jeromezooce wrote:Once this message displayed, the system is stuck.

Did you try switching to a console (TTY) screen?

Yes I tried that, this is the way I know system is stuck. No answer for Ctrl+alt+Fx (x being 2,3,4,..)
I used the TTY console to install firmware-nonfree previously. Here, it does not come out.
jeromezooce
 
Posts: 3
Joined: 2020-11-07 19:55

Re: Loading on Macbook Pro ends with error on radeon graphic

Postby jeromezooce » 2020-11-16 08:54

On this post, here an update.

With a late 2006 MBP and Radeon, there is a bug that is not on the driver.
The solution would be to recompile the kernel and it seems to me a complex process.
Here is the post that helps to understand.
https://apple.stackexchange.com/questions/405913/newly-installed-debian-stuck-on-loading-on-macbook-pro-core-2-duo-2-16

I would need assistance on this if someone is happy to give support.
Thanks you
Jerome
jeromezooce
 
Posts: 3
Joined: 2020-11-07 19:55

Re: Loading on Macbook Pro ends with error on radeon graphic

Postby Head_on_a_Stick » 2020-11-20 18:06

Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 12770
Joined: 2014-06-01 17:46
Location: /dev/chair


Return to Installation

Who is online

Users browsing this forum: No registered users and 9 guests

fashionable