Applications not launching from menu [SOLVED]

If none of the more specific forums is the right place to ask

Re: Applications not launching from menu

Postby CwF » 2021-02-05 17:47

Head_on_a_Stick wrote:@CwF: I think we should try to narrow down the source of the problem before applying a hacky workaround. The menu entries should work without having to bypass polkit.

Well, not quite hacky, more like official DE-agnostic method.. It does not 'bypass' polkit, it USES it! It completes the chain - the chain that is broken in more than one DE! That's why I ask the way I did and pointed towards the agent, which is not required...unless you want one.

The qualifier is simple, only user desktop. The mechanism is not required, so I propose the logical to not fix what we don't need!
CwF
 
Posts: 945
Joined: 2018-06-20 15:16

Re: Applications not launching from menu

Postby shloz » 2021-02-05 17:49

Head_on_a_Stick wrote:Let's check the error messages for a fresh session.

Log out and back in again and run
Code: Select all
rm ~/.xsession-errors

Then attempt to launch synaptic from the menu and post the content of ~/.xsession-errors here but please use code tags instead of just pasting the output directly into your post.

And I really do think we need to see the output of
Code: Select all
apt policy

Please read the "Don't Break Debian" link I provided earlier — most problems of this nature are due to user misconfiguration.

@CwF: I think we should try to narrow down the source of the problem before applying a hacky workaround. The menu entries should work without having to bypass polkit.

I logged out and back in, ran rm ~/.xsession-errors, tried to launch synaptic, but there's no ~/.xsession-errors file (assuming it's supposed to be in my home/sz/ as per the ~)
The following is the output of apt policy:
Code: Select all
sz@x240:~$ apt policy
Package files:
 100 /var/lib/dpkg/status
     release a=now
 500 http://deb.debian.org/debian buster-updates/non-free amd64 Packages
     release o=Debian,a=stable-updates,n=buster-updates,l=Debian,c=non-free,b=amd64
     origin deb.debian.org
 500 http://deb.debian.org/debian buster-updates/main amd64 Packages
     release o=Debian,a=stable-updates,n=buster-updates,l=Debian,c=main,b=amd64
     origin deb.debian.org
 500 http://security.debian.org/debian-security buster/updates/non-free amd64 Packages
     release v=10,o=Debian,a=stable,n=buster,l=Debian-Security,c=non-free,b=amd64
     origin security.debian.org
 500 http://security.debian.org/debian-security buster/updates/main amd64 Packages
     release v=10,o=Debian,a=stable,n=buster,l=Debian-Security,c=main,b=amd64
     origin security.debian.org
 500 http://deb.debian.org/debian buster/non-free amd64 Packages
     release v=10.7,o=Debian,a=stable,n=buster,l=Debian,c=non-free,b=amd64
     origin deb.debian.org
 500 http://deb.debian.org/debian buster/contrib amd64 Packages
     release v=10.7,o=Debian,a=stable,n=buster,l=Debian,c=contrib,b=amd64
     origin deb.debian.org
 500 http://deb.debian.org/debian buster/main amd64 Packages
     release v=10.7,o=Debian,a=stable,n=buster,l=Debian,c=main,b=amd64
     origin deb.debian.org
Pinned packages:
shloz
 
Posts: 11
Joined: 2021-02-05 15:10

Re: Applications not launching from menu

Postby Head_on_a_Stick » 2021-02-05 17:54

CwF wrote:It does not 'bypass' polkit, it USES it!

Touché.
I should have wrote:The menu entries should work without having to bypass the polkit authentication mechanism.

shloz wrote:there's no ~/.xsession-errors file

No, of course, silly me — the errors wouldn't be written there.

Open a terminal and follow the journal to see the errors as they're written:
Code: Select all
journalctl --follow

If your user isn't in the systemd-journal group then the command will have to be run as root.

EDIT: your sources are fine btw.
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 13450
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Applications not launching from menu

Postby shloz » 2021-02-05 17:57

OK here's the error when I try to launch synaptic from the menu:
Code: Select all
Feb 05 13:45:25 x240 pkexec[2103]: sz: The value for environment variable TERM contains suscipious content [USER=root] [TTY=unknown] [CWD=/home/sz] [COMMAND=/usr/sbin/synaptic]
shloz
 
Posts: 11
Joined: 2021-02-05 15:10

Re: Applications not launching from menu

Postby Head_on_a_Stick » 2021-02-05 18:01

shloz wrote:
Code: Select all
The value for environment variable TERM contains suscipious content

^ I put this into a search engine:

https://www.digitalfoundations.com.au/b ... t-in-lxqt/

Does that help?
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 13450
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Applications not launching from menu

Postby shloz » 2021-02-05 18:04

I had set the default terminal in LXQT session settings to Alacritty, now I changed it back to qterminal and everything works! Thanks for all the help. The TERM in the error message made me think of that...
shloz
 
Posts: 11
Joined: 2021-02-05 15:10

Re: Applications not launching from menu

Postby shloz » 2021-02-05 18:06

How do I mark this as "solved"?
shloz
 
Posts: 11
Joined: 2021-02-05 15:10

Re: Applications not launching from menu

Postby Head_on_a_Stick » 2021-02-05 18:07

Edit the title of the thread (in your first post) and prepend [SOLVED].
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 13450
Joined: 2014-06-01 17:46
Location: /dev/chair

Previous

Return to General Questions

Who is online

Users browsing this forum: No registered users and 17 guests

fashionable