[Solved] Error when updating zfs-zed

Kernels & Hardware, configuring network, installing services

[Solved] Error when updating zfs-zed

Postby toquinho » 2021-02-23 13:24

Hello,

Today I tried to update my system (buster) and noticed some new zfs packages which I installed with apt-get dist-upgrade. The upgrade ended with an error message:

Code: Select all
depmod...

DKMS: install completed.
Setting up libuutil3linux (2.0.2-1~bpo10+1) ...
Setting up libzfs4linux (2.0.2-1~bpo10+1) ...
Setting up libzpool4linux (2.0.2-1~bpo10+1) ...
Setting up zfsutils-linux (2.0.2-1~bpo10+1) ...
Installing new version of config file /etc/default/zfs ...
Installing new version of config file /etc/zfs/zfs-functions ...
zfs-import-scan.service is a disabled or a static unit not running, not starting it.
Processing triggers for initramfs-tools (0.133+deb10u1) ...
update-initramfs: Generating /boot/initrd.img-4.19.0-14-amd64
Processing triggers for libc-bin (2.28-10) ...
Processing triggers for systemd (241-7~deb10u6) ...
Processing triggers for man-db (2.8.5-2) ...
Setting up zfs-zed (2.0.2-1~bpo10+1) ...
Installing new version of config file /etc/init.d/zfs-zed ...
Installing new version of config file /etc/zfs/zed.d/zed-functions.sh ...
Installing new version of config file /etc/zfs/zed.d/zed.rc ...
ln: failed to create symbolic link '/etc/zfs/zed.d/history_event-zfs-list-cacher.sh': File exists
dpkg: error processing package zfs-zed (--configure):
 installed zfs-zed package post-installation script subprocess returned error exit status 1
Processing triggers for systemd (241-7~deb10u6) ...
Errors were encountered while processing:
 zfs-zed
E: Sub-process /usr/bin/dpkg returned an error code (1)


The link /etc/zfs/zed.d/history_event-zfs-list-cacher.sh exists and points to a file that does not exist:

Code: Select all
root@TRILLIAN:~# ls -l /etc/zfs/zed.d/history_event-zfs-list-cacher.sh
lrwxrwxrwx 1 root root 51 Nov 11 14:34 /etc/zfs/zed.d/history_event-zfs-list-cacher.sh -> /usr/lib/zfs/zed.d/history_event-zfs-list-cacher.sh
root@TRILLIAN:~# ls -l /usr/lib/zfs/zed.d/history_event-zfs-list-cacher.sh
ls: cannot access '/usr/lib/zfs/zed.d/history_event-zfs-list-cacher.sh': No such file or directory


How can I fix this? Is it safe to reboot the system in its current state?

Thanks a lot for any advice.

Toquinho


PS:
Code: Select all
root@TRILLIAN:~# uname -a
Linux TRILLIAN 4.19.0-14-amd64 #1 SMP Debian 4.19.171-2 (2021-01-30) x86_64 GNU/Linux
Last edited by toquinho on 2021-03-02 17:04, edited 1 time in total.
toquinho
 
Posts: 50
Joined: 2014-06-24 16:50

Re: Error when updating zfs-zed

Postby Head_on_a_Stick » 2021-02-23 14:21

toquinho wrote:How can I fix this?

Delete the dangling symlink and try to upgrade the package again.

This may be worth a bug report.

toquinho wrote:Is it safe to reboot the system in its current state?

I would think so, the upgrade didn't go through. But I don't use zfs so I might be wrong.
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 13450
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Error when updating zfs-zed

Postby toquinho » 2021-02-23 15:20

Thanks a lot. This helped. After deleting the symlink I could upgrade the package without errors. I filed a bug report and will wait for the maintainer's response before marking the problem as solved.
toquinho
 
Posts: 50
Joined: 2014-06-24 16:50

Re: Error when updating zfs-zed

Postby stevepusser » 2021-02-23 16:03

How are you getting buster-backports as "standard" upgrades?
MX Linux packager and developer
User avatar
stevepusser
 
Posts: 12286
Joined: 2009-10-06 05:53

Re: Error when updating zfs-zed

Postby Head_on_a_Stick » 2021-02-23 16:10

^ That's completely normal if the package was originally installed from backports.

See the Release file:
Code: Select all
NotAutomatic: yes
ButAutomaticUpgrades: yes

http://deb.debian.org/debian/dists/bust ... ts/Release
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 13450
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Error when updating zfs-zed

Postby toquinho » 2021-02-23 18:58

Yes, I installed the version from buster-backports (because of the native encryption for versions >= 0.8.0).
toquinho
 
Posts: 50
Joined: 2014-06-24 16:50

Re: [Solved] Error when updating zfs-zed

Postby toquinho » 2021-03-02 17:10

Deleting the symlink did not cause any problems, and the package has already been updated. See also
https://salsa.debian.org/zfsonlinux-team/zfs/-/merge_requests/38
toquinho
 
Posts: 50
Joined: 2014-06-24 16:50


Return to System configuration

Who is online

Users browsing this forum: No registered users and 17 guests

fashionable