Bacula-sd-cloud-driver

If none of the more specific forums is the right place to ask

Bacula-sd-cloud-driver

Postby spiritwalker » 2021-04-07 14:19

I have successfully installed and running Bacula 9.6.7-3~bpo10+1 (BackPorts edition) on Buster 10.

I'm setting up cloud storage with Wasabi Cloud Storage and require bacula-sd-cloud-driver (plugin).

From the Debian deb/rpm there is a package bacula-cloud-storage_9.6.7-1_amd64.deb

I tried to install the deb package, but Debian complaining it depends on bacula-common 9.6.7-1 (Mine is 9.6.7-3~bpo10+1)

Debain asking me to " Try 'apt --fix-broken install' with no packages (or specify a solution)."

I suppose I need to scrap the entire installation and reinstall a 'stable' version of Bacula 9.4.2, but there's no community binary 'bacula-sd-cloud-driver' for Buster edition.

Not sure what to do here. Will 'apt --fix-broken install' resolve this?
User avatar
spiritwalker
 
Posts: 2
Joined: 2021-04-07 13:47

Re: Bacula-sd-cloud-driver

Postby 4D696B65 » 2021-04-07 14:40

You should be able to get bacula-common 9.6.7-1 from the same place you got bacula-cloud-storage_9.6.7-1_amd64.deb.
Looking at the website it seems very outdated.
https://www.bacula.org/what-is-bacula/system-requirements
User avatar
4D696B65
 
Posts: 2538
Joined: 2009-06-28 06:09

Re: Bacula-sd-cloud-driver

Postby spiritwalker » 2021-04-07 16:17

I'm running bacula-common 9.6.7-3~bpo10+1

Here's what I get trying to install the cloud driver:
------------------------
root@baculavm:~# dpkg -i bacula-cloud-storage_9.6.7-1_amd64.deb
(Reading database ... 29368 files and directories currently installed.)
Preparing to unpack bacula-cloud-storage_9.6.7-1_amd64.deb ...
Unpacking bacula-cloud-storage (9.6.7-1) over (9.6.7-1) ...
dpkg: dependency problems prevent configuration of bacula-cloud-storage:
bacula-cloud-storage depends on bacula-common (= 9.6.7-1); however:
Version of bacula-common on system is 9.6.7-3~bpo10+1.
bacula-cloud-storage depends on libcurl4-openssl-dev; however:
Package libcurl4-openssl-dev is not installed.

dpkg: error processing package bacula-cloud-storage (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
bacula-cloud-storage
-----------------------------

It's installed, but needs libcurl4-openssl-dev:

"/opt/bacula/plugins/bacula-sd-cloud-driver-9.6.7.so"
---------------------------
apt install libcurl4-openssl-dev

The following packages have unmet dependencies:
bacula-cloud-storage : Depends: bacula-common (= 9.6.7-1) but 9.6.7-3~bpo10+1 is to be installed
Recommends: awscli but it is not going to be installed
libcurl4-openssl-dev : Depends: libcurl4 (= 7.64.0-4+deb10u2) but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
User avatar
spiritwalker
 
Posts: 2
Joined: 2021-04-07 13:47

Re: Bacula-sd-cloud-driver

Postby 4D696B65 » 2021-04-07 19:03

libcurl4 (= 7.64.0-4+deb10u2 is in bullseye

https://packages.debian.org/buster/libcurl4
User avatar
4D696B65
 
Posts: 2538
Joined: 2009-06-28 06:09


Return to General Questions

Who is online

Users browsing this forum: No registered users and 13 guests

fashionable