Problems connecting to Wireless Network

If none of the more specific forums is the right place to ask

Problems connecting to Wireless Network

Postby Quytelda » 2013-08-20 23:01

Hello,
I'm having some connection issues with a WPA/WPA2 enterprise network with TTLS authentication. Initially I can connect OK, and the connection works, but it disconnects and reconnects every few minutes. I checked dmesg, and it is flooded with information:
Code: Select all
$ dmesg
[ 1777.878149] wlan0: direct probe to 72:13:2a:70:50:7b (try 1/3)
[ 1778.076099] wlan0: direct probe to 72:13:2a:70:50:7b (try 2/3)
[ 1778.276212] wlan0: direct probe to 72:13:2a:70:50:7b (try 3/3)
[ 1778.476105] wlan0: direct probe to 72:13:2a:70:50:7b timed out
[ 1782.942564] ieee80211 phy0: brcms_ops_bss_info_changed: qos enabled: false (implement)
[ 1782.942581] ieee80211 phy0: brcmsmac: brcms_ops_bss_info_changed: disassociated
[ 1782.942592] ieee80211 phy0: brcms_ops_bss_info_changed: arp filtering: enabled false, count 1 (implement)
[ 1782.942605] wlan0: deauthenticating from 72:d0:74:fe:e3:6b by local choice (reason=2)
[ 1782.945475] cfg80211: Calling CRDA to update world regulatory domain
[ 1782.968425] wlan0: direct probe to 72:74:a7:1f:51:b9 (try 1/3)
[ 1782.971291] cfg80211: World regulatory domain updated:
[ 1782.971294] cfg80211:     (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[ 1782.971297] cfg80211:     (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 1782.971300] cfg80211:     (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[ 1782.971308] cfg80211:     (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[ 1782.971310] cfg80211:     (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 1782.971313] cfg80211:     (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 1783.168136] wlan0: direct probe to 72:74:a7:1f:51:b9 (try 2/3)
[ 1783.368149] wlan0: direct probe to 72:74:a7:1f:51:b9 (try 3/3)
[ 1783.568212] wlan0: direct probe to 72:74:a7:1f:51:b9 timed out
[ 1784.189563] wlan0: direct probe to 72:7c:46:6c:55:16 (try 1/3)
[ 1784.388096] wlan0: direct probe to 72:7c:46:6c:55:16 (try 2/3)
[ 1784.588127] wlan0: direct probe to 72:7c:46:6c:55:16 (try 3/3)
[ 1784.788086] wlan0: direct probe to 72:7c:46:6c:55:16 timed out
[ 1785.118166] wlan0: authenticate with 72:d0:74:fe:e3:6b (try 1)
[ 1785.119976] wlan0: authenticated
[ 1785.124815] wlan0: associate with 72:d0:74:fe:e3:6b (try 1)
[ 1785.125697] wlan0: RX ReassocResp from 72:d0:74:fe:e3:6b (capab=0x811 status=0 aid=1)
[ 1785.125705] wlan0: associated
[ 1785.126118] ieee80211 phy0: brcms_ops_bss_info_changed: qos enabled: true (implement)
[ 1785.126135] ieee80211 phy0: brcmsmac: brcms_ops_bss_info_changed: associated
[ 1785.126145] ieee80211 phy0: changing basic rates failed: -22
[ 1785.126153] ieee80211 phy0: brcms_ops_bss_info_changed: arp filtering: enabled true, count 1 (implement)
[ 1785.128045] cfg80211: Calling CRDA for country: US
[ 1785.132555] cfg80211: Regulatory domain changed to country: US
[ 1785.132559] cfg80211:     (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[ 1785.132562] cfg80211:     (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2700 mBm)
[ 1785.132565] cfg80211:     (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 1700 mBm)
[ 1785.132567] cfg80211:     (5250000 KHz - 5330000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 1785.132570] cfg80211:     (5490000 KHz - 5600000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 1785.132573] cfg80211:     (5650000 KHz - 5710000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 1785.132575] cfg80211:     (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 3000 mBm)
[ 1785.135495] ieee80211 phy0: brcms_ops_bss_info_changed: qos enabled: true (implement)
[ 1794.272640] ieee80211 phy0: brcms_ops_bss_info_changed: arp filtering: enabled true, count 0 (implement)
[ 1794.272890] ieee80211 phy0: brcms_ops_bss_info_changed: qos enabled: false (implement)
[ 1794.272896] ieee80211 phy0: brcmsmac: brcms_ops_bss_info_changed: disassociated
[ 1794.272899] ieee80211 phy0: brcms_ops_bss_info_changed: arp filtering: enabled false, count 0 (implement)
[ 1794.272903] wlan0: deauthenticating from 72:d0:74:fe:e3:6b by local choice (reason=3)
[ 1794.284532] cfg80211: Calling CRDA to update world regulatory domain
[ 1794.310428] cfg80211: World regulatory domain updated:
[ 1794.310432] cfg80211:     (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[ 1794.310435] cfg80211:     (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 1794.310438] cfg80211:     (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[ 1794.310440] cfg80211:     (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[ 1794.310443] cfg80211:     (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 1794.310446] cfg80211:     (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 1835.875089] wlan0: direct probe to 72:13:2a:99:8e:d7 (try 1/3)
[ 1836.072094] wlan0: direct probe to 72:13:2a:99:8e:d7 (try 2/3)
[ 1836.272216] wlan0: direct probe to 72:13:2a:99:8e:d7 (try 3/3)
[ 1836.472172] wlan0: direct probe to 72:13:2a:99:8e:d7 timed out
[ 1836.867996] wlan0: direct probe to 72:74:a7:92:78:2e (try 1/3)
[ 1837.068218] wlan0: direct probe to 72:74:a7:92:78:2e (try 2/3)
[ 1837.268210] wlan0: direct probe to 72:74:a7:92:78:2e (try 3/3)
[ 1837.468100] wlan0: direct probe to 72:74:a7:92:78:2e timed out
[ 1837.742106] wlan0: direct probe to 72:55:f1:2e:23:2b (try 1/3)
[ 1837.940107] wlan0: direct probe to 72:55:f1:2e:23:2b (try 2/3)
[ 1838.140125] wlan0: direct probe to 72:55:f1:2e:23:2b (try 3/3)
[ 1838.340148] wlan0: direct probe to 72:55:f1:2e:23:2b timed out
[ 1838.585150] wlan0: authenticate with 72:55:f1:fe:e3:6b (try 1)
[ 1838.592480] wlan0: authenticated
[ 1838.592698] wlan0: associate with 72:55:f1:fe:e3:6b (try 1)
[ 1838.593578] wlan0: RX ReassocResp from 72:55:f1:fe:e3:6b (capab=0x811 status=0 aid=6)
[ 1838.593581] wlan0: associated
[ 1838.593982] ieee80211 phy0: brcms_ops_bss_info_changed: qos enabled: true (implement)
[ 1838.593989] ieee80211 phy0: brcmsmac: brcms_ops_bss_info_changed: associated
[ 1838.593992] ieee80211 phy0: changing basic rates failed: -22
[ 1838.593995] ieee80211 phy0: brcms_ops_bss_info_changed: arp filtering: enabled true, count 0 (implement)
[ 1838.595107] cfg80211: Calling CRDA for country: US
[ 1838.599877] cfg80211: Regulatory domain changed to country: US
[ 1838.599881] cfg80211:     (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[ 1838.599884] cfg80211:     (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2700 mBm)
[ 1838.599887] cfg80211:     (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 1700 mBm)
[ 1838.599889] cfg80211:     (5250000 KHz - 5330000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 1838.599892] cfg80211:     (5490000 KHz - 5600000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 1838.599894] cfg80211:     (5650000 KHz - 5710000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 1838.599897] cfg80211:     (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 3000 mBm)
[ 1838.632930] ieee80211 phy0: brcms_ops_bss_info_changed: qos enabled: true (implement)
[ 1839.058600] ieee80211 phy0: brcms_ops_bss_info_changed: arp filtering: enabled true, count 1 (implement)


I'm not really sure what the issue is. I have the brcsmac wireless driver, and my wireless card is Broadcom BCM43224 802.11a/b/g/n (rev 01).

Any ideas?
Quytelda
 
Posts: 14
Joined: 2012-06-12 17:23

Re: Problems connecting to Wireless Network

Postby michapma » 2013-08-22 02:55

I was curious and a google indicates that this is from Network Manager dropping the connection. Make sure wicd and network manager are not both installed.

Try googling deauthenticating, reason=3 (could also add debian to avoid specifics to packages from other distros).
Maybe have a look at these:
viewtopic.php?f=7&t=79475
viewtopic.php?f=10&t=76469
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=683407
User avatar
michapma
 
Posts: 444
Joined: 2008-05-04 20:49
Location: to the left of Zurich

Re: Problems connecting to Wireless Network

Postby Quytelda » 2013-08-22 18:25

It seems to have something to do with the brcmsmac driver. I installed wl, and it works fine. I wonder if I should file a bug report? I haven't seen any that describe my problem exactly, at least not under the parameters of the system I am using.
Quytelda
 
Posts: 14
Joined: 2012-06-12 17:23

Re: Problems connecting to Wireless Network

Postby michapma » 2013-08-22 22:48

Glad you got it working.

I have no idea whether a bug report would be useful.
User avatar
michapma
 
Posts: 444
Joined: 2008-05-04 20:49
Location: to the left of Zurich

Re: Problems connecting to Wireless Network

Postby Quytelda » 2013-09-02 02:47

Never mind about getting it working. It worked for about an hour, and then it was right back to the same old thing. For some reason the wl driver keeps spitting out errors to my virtual terminals en masse, making it hard to type anything. They all say "wrong mac address", with absolutely no context. Anyhow, I like brcmsmac better. How the heck do I get rid of wl though?
Quytelda
 
Posts: 14
Joined: 2012-06-12 17:23

Re: Problems connecting to Wireless Network

Postby michapma » 2013-09-02 10:11

Quytelda wrote:Never mind about getting it working. It worked for about an hour, and then it was right back to the same old thing. For some reason the wl driver keeps spitting out errors to my virtual terminals en masse, making it hard to type anything. They all say "wrong mac address", with absolutely no context. Anyhow, I like brcmsmac better. How the heck do I get rid of wl though?


How did you install it?

According to https://wiki.debian.org/wl the wl module is provided by broadcom-sta-dkms (also pulls in wireless-tools). I'd say remove/purge the broadcom-sta-dkms package. Try reversing the instructions: "modprobe -r wl", and make sure you've followed https://wiki.debian.org/brcm80211 .
User avatar
michapma
 
Posts: 444
Joined: 2008-05-04 20:49
Location: to the left of Zurich

Re: Problems connecting to Wireless Network

Postby Quytelda » 2013-09-03 16:38

Okay, I'm back to brcmsmac, but unfortunately I'm now back to square one. I'm going to try working with the power settings a bit, but I don't have much hope for that.

Edit:
I heard some people resolved similar problem by using:
# iwconfig wlan0 power off

I tried that and received:
Error for wireless request "Set Power Management" (8B2C) :
SET failed on device wlan0 ; Operation not supported.

Not sure if that's significant or not.

Edit2:
More info:
Code: Select all
# sudo cat /var/log/syslog | grep -e etwork -e wlan

Sep  3 16:54:33 macbook NetworkManager[3336]: <info> (wlan0): supplicant interface state: scanning -> disconnected
Sep  3 16:54:33 macbook NetworkManager[3336]: <info> Auto-activating connection 'INet'.
Sep  3 16:54:33 macbook NetworkManager[3336]: <info> Activation (wlan0) starting connection 'INet'
Sep  3 16:54:33 macbook NetworkManager[3336]: <info> (wlan0): device state change: disconnected -> prepare (reason 'none') [30 40 0]
Sep  3 16:54:33 macbook NetworkManager[3336]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) scheduled...
Sep  3 16:54:33 macbook NetworkManager[3336]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) started...
Sep  3 16:54:33 macbook NetworkManager[3336]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) scheduled...
Sep  3 16:54:33 macbook NetworkManager[3336]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) complete.
Sep  3 16:54:33 macbook NetworkManager[3336]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) starting...
Sep  3 16:54:33 macbook NetworkManager[3336]: <info> (wlan0): device state change: prepare -> config (reason 'none') [40 50 0]
Sep  3 16:54:33 macbook NetworkManager[3336]: <info> Activation (wlan0/wireless): access point 'INet' has security, but secrets are required.
Sep  3 16:54:33 macbook NetworkManager[3336]: <info> (wlan0): device state change: config -> need-auth (reason 'none') [50 60 0]
Sep  3 16:54:33 macbook NetworkManager[3336]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) complete.
Sep  3 16:54:34 macbook NetworkManager[3336]: <info> (wlan0): supplicant interface state: disconnected -> inactive
Sep  3 16:54:35 macbook ntpd[3259]: Deleting interface #20 wlan0, 172.16.185.124#123, interface stats: received=4, sent=4, dropped=0, active_time=42 secs
Sep  3 16:54:35 macbook NetworkManager[3336]: <warn> No agents were available for this request.
Sep  3 16:54:35 macbook NetworkManager[3336]: <info> (wlan0): device state change: need-auth -> failed (reason 'no-secrets') [60 120 7]
Sep  3 16:54:35 macbook NetworkManager[3336]: <warn> Activation (wlan0) failed for access point (INet)
Sep  3 16:54:35 macbook NetworkManager[3336]: <info> Marking connection 'INet' invalid.
Sep  3 16:54:35 macbook NetworkManager[3336]: <warn> Activation (wlan0) failed.
Sep  3 16:54:35 macbook NetworkManager[3336]: <info> (wlan0): device state change: failed -> disconnected (reason 'none') [120 30 0]
Sep  3 16:54:35 macbook NetworkManager[3336]: <info> (wlan0): deactivating device (reason 'none') [0]
Sep  3 16:54:38 macbook NetworkManager[3336]: <info> (wlan0): device state change: disconnected -> unavailable (reason 'none') [30 20 0]
Quytelda
 
Posts: 14
Joined: 2012-06-12 17:23

Re: Problems connecting to Wireless Network

Postby michapma » 2013-09-06 22:24

Sorry, I will try to look into this later... anyone feel free to jump in.
User avatar
michapma
 
Posts: 444
Joined: 2008-05-04 20:49
Location: to the left of Zurich

Re: Problems connecting to Wireless Network

Postby deltaflyer » 2013-09-07 06:57

give this a try, it might also give a few pointers to where the problem lies
http://www.linux-tips-and-tricks.de/index.php/collectNWData.sh/collectNWData-Schnellstart/Quickstart.html#English
free your computer,use opensource
User avatar
deltaflyer
 
Posts: 325
Joined: 2007-10-02 18:03
Location: EastAnglia,U.K.


Return to General Questions

Who is online

Users browsing this forum: No registered users and 13 guests

fashionable