Startx not working

New to Debian (Or Linux in general)? Ask your questions here!

Startx not working

Postby hernangl » 2014-06-07 23:41

Hello, i have 3 weeks messing with linux
have installed Debian 7 without graphic interface, then i start to install everything from scratch

have this problem for the last week:

root@GimliDeb:/# startx


X.Org X Server 1.12.4
Release Date: 2012-08-27
X Protocol Version 11, Revision 0
Build Operating System: Linux 3.2.0-4-amd64 i686 Debian
Current Operating System: Linux GimliDeb 3.2.0-4-686-pae #1 SMP Debian 3.2.57-3 i686
Kernel command line: BOOT_IMAGE=/vmlinuz-3.2.0-4-686-pae root=/dev/mapper/Debian-root ro quiet
Build Date: 17 December 2013 08:37:13PM
xorg-server 2:1.12.4-6+deb7u2 (Julien Cristau <jcristau@debian.org>)
Current version of pixman: 0.26.0
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.1.log", Time: Sat Jun 7 20:54:27 2014
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
resize called 1024 768
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning: Type "ONE_LEVEL" has 1 levels, but <RALT> has 2 symbols
> Ignoring extra symbols
Errors from xkbcomp are not fatal to the X server
^X
^X
^Cxinit: connection to X server lost

waiting for X server to shut down .Server terminated successfully (0). Closing log file.

xinit: unexpected signal 2
root@GimliDeb:/#
hernangl
 
Posts: 5
Joined: 2014-06-07 23:33

Re: Startx not working

Postby kiyop » 2014-06-08 01:50

Did you press CTRL+x twice and CTRL+c once to quit x-server (xorg)?

Generally speaking, logging in to GUI with root privilege on debian is not good.

Log in to CLI with non-root user and execute "startx".

If GUI is not displayed, press ALT+SysRq+R and then press CTRL+ALT+F7. If GUI is not displayed, press CTRL+ALT+F1 to go back to tty1 (CLI).

If you cannot log in to GUI by "startx", there may be graphics issues.
Read https://wiki.debian.org/GraphicsCard
Openbox, JWM: Jessie, Sid, Arch / Win XP (on VirtualBox), 10
http://kiyoandkei.bbs.fc2.com/
User avatar
kiyop
 
Posts: 3984
Joined: 2011-05-05 15:16
Location: Where persons without desire to improve themselves fear to tread, in Japan

Re: Startx not working

Postby hernangl » 2014-06-09 00:38

Did you press CTRL+x twice and CTRL+c once to quit x-server (xorg)?
yes,

Generally speaking, logging in to GUI with root privilege on debian is not good.
i know but all i need is to install xbmc for my kids, so no worries

Log in to CLI with non-root user and execute "startx".
no permissions

If GUI is not displayed, press ALT+SysRq+R and then press CTRL+ALT+F7. If GUI is not displayed, press CTRL+ALT+F1 to go back to tty1 (CLI).

If you cannot log in to GUI by "startx", there may be graphics issues.
Read https://wiki.debian.org/GraphicsCard
already installed

same state, graphics not working
hernangl
 
Posts: 5
Joined: 2014-06-07 23:33

Re: Startx not working

Postby hakerdefo » 2014-06-09 05:00

What Desktop Environment/Window Manager have you installed?
Delete if the following file exists. Replace 'yourusername' in the following commands with your username
Code: Select all
rm /home/yourusername/.Xauthority

Also post the output of following,
Code: Select all
cat /home/yourusername/.xinitrc

Code: Select all
stat /home/yourusername/.xinitrc

Cheers!!!
User avatar
hakerdefo
 
Posts: 256
Joined: 2014-05-05 05:31

Re: Startx not working

Postby kiyop » 2014-06-09 13:03

hernangl wrote:Log in to CLI with non-root user and execute "startx".
no permissions

Do you mean that an error message showing that your non-root user cannot execute startx because of lack of permission, when you execute startx with the user?
If so, you really messed up your debian by starting x-window-system with root privilege ! ;)
I am curious how to solve your problem.
Cheers! hakerdefo!
Openbox, JWM: Jessie, Sid, Arch / Win XP (on VirtualBox), 10
http://kiyoandkei.bbs.fc2.com/
User avatar
kiyop
 
Posts: 3984
Joined: 2011-05-05 15:16
Location: Where persons without desire to improve themselves fear to tread, in Japan

Re: Startx not working

Postby hernangl » 2014-06-11 00:36

What Desktop Environment/Window Manager have you installed?
A:gnome

Delete if the following file exists. Replace 'yourusername' in the following commands with your username

rm /home/yourusername/.Xauthority
Also post the output of following,
cat /home/yourusername/.xinitrc
stat /home/yourusername/.xinitrc
A: No such file or directory
Im still using root, and i would like to keep this way

Do you mean that an error message showing that your non-root user cannot execute startx because of lack of permission, when you execute startx with the user?
A: Yes this is correct, i create a new user after desktop install.

hernan@GimliDeb:~$ startx
X: user not authorized to run the X server, aborting.
xinit: giving up
xinit: unable to connect to X server: Connection refused
xinit: server error
hernangl
 
Posts: 5
Joined: 2014-06-07 23:33

Re: Startx not working

Postby dasein » 2014-06-11 01:11

Please, for the benefit of everyone, including yourself, learn how to use [quote] and [code] tags. Using [quote] tags makes it 10 times easier for folks to read the "back and forth" of the exchange and allows folks to see what's "old" and what's "new" without reading every single word of your post(s). Using [code] tags makes it easier for folks to distinguish your own words from the output of the command(s) you've entered.
User avatar
dasein
 
Posts: 7775
Joined: 2011-03-04 01:06
Location: Terra Incantationum

Re: Startx not working

Postby hernangl » 2014-06-11 02:00

dasein wrote:Please, for the benefit of everyone, including yourself, learn how to use quote and code tags. Using quote tags makes it 10 times easier for folks to read the "back and forth" of the exchange and allows folks to see what's "old" and what's "new" without reading every single word of your post(s). Using code tags makes it easier for folks to distinguish your own words from the output of the command(s) you've entered.

my apologies, so be it
hernangl
 
Posts: 5
Joined: 2014-06-07 23:33

Re: Startx not working

Postby hakerdefo » 2014-06-11 05:26

Run following command as root,
Code: Select all
dpkg-reconfigure x11-common

And from the dialogue box asking the question
Users allowed to run X server

Choose 'Anybody' as answer.
Reboot and startx as normal user.
Cheers!!!
User avatar
hakerdefo
 
Posts: 256
Joined: 2014-05-05 05:31

Re: Startx not working

Postby hernangl » 2014-06-12 00:50

hernan@GimliDeb:~$ startx
X.Org X Server 1.12.4
Release Date: 2012-08-27
X Protocol Version 11, Revision 0
Build Operating System: Linux 3.2.0-4-amd64 i686 Debian
Current Operating System: Linux GimliDeb 3.2.0-4-686-pae #1 SMP Debian 3.2.57-3 i686
Kernel command line: BOOT_IMAGE=/vmlinuz-3.2.0-4-686-pae root=/dev/mapper/Debian-root ro quiet
Build Date: 17 December 2013 08:37:13PM
xorg-server 2:1.12.4-6+deb7u2 (Julien Cristau <jcristau@debian.org>)
Current version of pixman: 0.26.0
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Wed Jun 11 22:04:06 2014
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
vesa: Ignoring device with a bound kernel driver

Fatal server error:
no screens found

Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

Server terminated with error (1). Closing log file.
xinit: giving up
xinit: unable to connect to X server: Connection refused
xinit: server error

"#!$%$%, still not working, but thanks anyway
hernangl
 
Posts: 5
Joined: 2014-06-07 23:33

Re: Startx not working

Postby hakerdefo » 2014-06-12 04:49

As root do,
Code: Select all
Xorg -configure

Code: Select all
cp /root/xorg.conf.new /etc/X11/xorg.conf

And as normal user,
Code: Select all
startx

Cheers!!!
User avatar
hakerdefo
 
Posts: 256
Joined: 2014-05-05 05:31


Return to Beginners Questions

Who is online

Users browsing this forum: No registered users and 14 guests

fashionable