python-wxgtk2.8

If none of the more specific forums is the right place to ask

python-wxgtk2.8

Postby akuankkis » 2016-11-14 14:51

Tribler needs python-wxgtk2.8 and Debian has only python-wxgtk3.0. How to get 2.8?
akuankkis
 
Posts: 77
Joined: 2011-10-09 09:29

Re: python-wxgtk2.8

Postby pylkko » 2016-11-14 20:16

akuankkis wrote:Tribler needs python-wxgtk2.8 and Debian has only python-wxgtk3.0. How to get 2.8?


If it is not in the repo and you cannot use pip, then build it accoding to instructions from their web page.
User avatar
pylkko
 
Posts: 1793
Joined: 2014-11-06 19:02

Re: python-wxgtk2.8

Postby stevepusser » 2016-11-14 22:46

Since Tribler is not in the repositories, perhaps you might let us know how the heck you are trying to install it, since my incredible Dr. Strange-like psychic powers seem to be taking a sick day today.

The "Amazing" Steve
MX Linux packager and developer
User avatar
stevepusser
 
Posts: 12182
Joined: 2009-10-06 05:53

Re: python-wxgtk2.8

Postby akuankkis » 2016-11-15 06:03

stevepusser wrote:Since Tribler is not in the repositories, perhaps you might let us know how the heck you are trying to install it


There is deb package in Tribler dowload page but it needs python-wxgt2.8.
akuankkis
 
Posts: 77
Joined: 2011-10-09 09:29

Re: python-wxgtk2.8

Postby millpond » 2016-11-15 10:06

akuankkis wrote:
stevepusser wrote:Since Tribler is not in the repositories, perhaps you might let us know how the heck you are trying to install it


There is deb package in Tribler dowload page but it needs python-wxgt2.8.



Thats the least of the problems. Its a frankenconcoction, pulled out of a mishmash of ubuntu unstable and a bunch of other stuff. You will need pip install wx, but it still wont seem to work because parts of it want python3.5 which I would NOT put on a debian system. '

Dont f**k with system Perl, and dont f**k with system Python - you can add as much as you want - but dont screw with the major version changes.

Its apparently looking for wx-phoenix, which is available from wxpython.org - which is currently down,
Better luck tomorrow.
millpond
 
Posts: 670
Joined: 2014-06-25 04:56

Re: python-wxgtk2.8

Postby millpond » 2016-11-15 18:37

This morning i got Tribler working. Pull Tribler from:
https://github.com/Tribler/tribler

wx from:
https://pypi.python.org/pypi/wx/

And be prepared for an adventure in installing missing libraries.
Something needed for this system as i do intend to turn it into a development system.

You do NOT need python 3.5. At one step along the way something will tell you to use pip3 install xxx - if it doesnt work, try pip install xxx.

Be warned that pip uses the C compiler, so make sure yours is up to date with all the standard headers. Initally the builds will fail - look for the missing libraries and install them AND the -dev files.

It can easily steal half a day of your life.

And of questionable value: Will a Tor like network support the throughputs required for torrents? Tor sure as hell wont.
Arent proxies problematic for DHT and PEX?

Better off with utorrent/rtorrent on a cheap VPN. And of course turn off IPv6.
millpond
 
Posts: 670
Joined: 2014-06-25 04:56

Re: python-wxgtk2.8

Postby stevepusser » 2016-11-15 19:19

Tribler was in upstream Debian for a time a few years ago, I'm sure it was dropped for good reasons.

Anyway, it's fairly trivial to rebuild the Wheezy python-wxgtk2.8 source packages on Wheezy; basically all of wxwidgets 2.8. I can say this with confidence, having done it some time back for MX 15:

Code: Select all
apt-cache show tribler
Package: tribler
Version: 6.4.3+git20150522.3557ba92-1mx150+1
Architecture: all
Bugs: mailto: maintainer@mepiscommunity.org
Maintainer: Steven Pusser (Stevo) <maintainer@mepiscommunity.org>
Installed-Size: 6483
Depends: libav-tools, libjs-excanvas, libjs-mootools, libx11-6, python-apsw, python-cherrypy3, python-cryptography, python-feedparser, python-gmpy, python-leveldb, python-libtorrent (>= 0.16.4), python-m2crypto, python-netifaces, python-pil, python-pyasn1, python-requests, python-twisted, python-wxgtk2.8, vlc (>= 1.1.0), gconf2 (>= 2.28.1-2), python:any (>= 2.7.5-5~)


We're pretty busy polishing MX 16 for a release candidate right now, but I may find time to set a repository for python-wxgtk2.8 and Tribler on the OBS.
MX Linux packager and developer
User avatar
stevepusser
 
Posts: 12182
Joined: 2009-10-06 05:53

Re: python-wxgtk2.8

Postby stevepusser » 2016-11-15 19:50

Hmmm...try this deb, I rebuilt it so it's installable on Jessie and tries to use python-wxtgk3.0 instead. I'm at a place that blocks torrent ports, and that seems to keeps it from opening a GUI for me: https://drive.google.com/open?id=0BxE7w ... 2N6eW5lckk
MX Linux packager and developer
User avatar
stevepusser
 
Posts: 12182
Joined: 2009-10-06 05:53

Re: python-wxgtk2.8

Postby akuankkis » 2016-11-16 06:31

It don't work. Maybe part of the Tribler code must rewrite for python-wxtgk3.0.

Code: Select all
aa@ic2:~$ tribler
Starting Tribler...
aa@ic2:~$
akuankkis
 
Posts: 77
Joined: 2011-10-09 09:29


Return to General Questions

Who is online

Users browsing this forum: No registered users and 14 guests

fashionable