how to set the RESUME variable (SOLVED)

Kernels & Hardware, configuring network, installing services

how to set the RESUME variable (SOLVED)

Postby marcetm » 2017-05-26 12:58

Hi all,

From about a month, every single time "apt upgrade" calls to "update-initramfs" I'm receiving this message:

W: initramfs-tools configuration sets RESUME=UUID=75a1abae-a571-45e0-8ba8-2af714d13b59
W: but no matching swap device is available.
I: The initramfs will attempt to resume from /dev/sda3
I: (UUID=010325a0-3867-4606-94da-51efff3e57ba)
I: Set the RESUME variable to override this.


Anyone knows how should I set the RESUME variable?
Last edited by marcetm on 2017-05-26 16:29, edited 1 time in total.
marcetm
 
Posts: 135
Joined: 2015-08-02 21:30

Re: how to set the RESUME variable

Postby debiman » 2017-05-26 13:33

i'm not sure, but i'm guessing that this:
marcetm wrote:W: but no matching swap device is available.

might mean that your swap partition has changed UUID and you need t adjust that in fstab (and maybe elsewhere)
this typically happens when you install another OS alongside the first one.
so check your swaps actual UUID with 'sudo blkid', then compare to the one in /etc/fstab.
User avatar
debiman
 
Posts: 3064
Joined: 2013-03-12 07:18

Re: how to set the RESUME variable

Postby orythem27 » 2017-05-26 13:42

Look into /etc/initramfs-tools/initramfs.conf and /etc/initramfs-tools/conf.d/*

In my case it is set in /etc/initramfs-tools/conf.d/resume.

You might try finding the correct settings as stated in the above post by @debiman, correct the variable in the initramfs-tools config file, then regenerate initramfs by
Code: Select all
# update-initramfs -u -k all
User avatar
orythem27
 
Posts: 252
Joined: 2017-05-11 07:59
Location: P.R. China

Re: how to set the RESUME variable

Postby marcetm » 2017-05-26 16:28

I've edited the file

/etc/initramfs-tools/conf.d/resume

and changed the line (there's only one)

RESUME=UUID=75a1abae-a571-45e0-8ba8-2af714d13b59

by

RESUME=UUID=010325a0-3867-4606-94da-51efff3e57ba

as update-initramfs warned me in its message.

Now when I enter:
Code: Select all
# update-initramfs -u -k all


it doesn't complain anymore.

Thanks both for your help.
marcetm
 
Posts: 135
Joined: 2015-08-02 21:30


Return to System configuration

Who is online

Users browsing this forum: No registered users and 8 guests

fashionable