Change the Default Icon on your Gnome Menu Applet

Share your own howto's etc. Not for support questions!

Change the Default Icon on your Gnome Menu Applet

Postby rickh » 2007-05-11 17:01

A while back, I was involved in a discussion here about changing the icon on the Gnome menu. The consensus was that you should:
1. rename the default icon (/user/share/pixmaps/gnome-logo-icon-transparent.png) to archive it, then
2. rename whatever icon you wanted used to that default name.
That seems to be a widespread solution on the web.

Someone came along and recommended using the gnome configuration editor to change the icon, but, at the time I couldn't get anything to work on my system. I still don't know what I was doing wrong, but since then, I have figured it out, and I thought a brief explanation might be useful to others.

I have also discovered, and quickly adopted, the "main menu" Gnome applet which uses a single menu format to replace the default "menu bar" with it's Applications|Places|Desktop format. That choice shouldn't make any difference in the technique.

The Right Way:
Probably the most common replacement for the Gnome footprint (among us Debianites) is the Debian swirl. I like this one. I copied the 32x32 version to /usr/share/pixmaps/menu32.png

Once you've selected the icon you want, get into the configuration editor -- System Tools|Configuration Editor, or aptitude install gconf-editor if necessary. From there -- apps|panel|objects.

You will see a series of folders named object_0, object_1, etc. The trick now is to discover which of those objects is your menu application. Believe me, it could be any of them. Each folder contains a similar collection of information. The solution for me was to click thru all the objects watching the "position" key. Since my menu is at the left side of the panel, it was the one with the lowest number in that key. That turned out to be object_3.

From there on, it's a piece of cake. Click the checkbox for "use_custom_icon", then right-click on "custom_icon", select "Edit key..." and enter the full path to your chosen icon. (For me: /usr/share/pixmaps/menu32.png)

Cute!
Last edited by rickh on 2007-06-23 15:31, edited 1 time in total.
Debian-Lenny/Sid 32/64
Desktop: Generic Core 2 Duo, EVGA 680i, Nvidia
Laptop: Generic Intel SIS/AC97
User avatar
rickh
 
Posts: 3475
Joined: 2006-06-29 02:13
Location: Albuquerque, NM USA

Postby actionM » 2007-05-11 17:38

Follow his guide and you too can have a thundercats start menu!
http://flickr.com/photo_zoom.gne?id=428174328&size=o
User avatar
actionM
 
Posts: 897
Joined: 2007-05-01 02:11

Postby rickh » 2007-05-14 05:30

I decided I like this set better.
Debian-Lenny/Sid 32/64
Desktop: Generic Core 2 Duo, EVGA 680i, Nvidia
Laptop: Generic Intel SIS/AC97
User avatar
rickh
 
Posts: 3475
Joined: 2006-06-29 02:13
Location: Albuquerque, NM USA

Postby Telemachus » 2007-07-06 12:20

Just a quick update on this HOWTO. Gnome 2.18 hit Lenny last night, and sure enough, my previously customized Debian icon was blown away. No problem, I thought, I will just redo it. I had always used the old method (copy my icon over /usr/share/pixmaps/gnome-logo-transparent-icon.png), but that no longer worked. No problem, I thought, I remember that Rickh wrote a HOWTO with another method to do this, and I will go use his method. Unfortunately, that didn't work for me at all either. (In a nutshell, in case anyone else has trouble: "Use custom icon" only works for menu-object or drawer-object items, and my menu has a menu-bar item there. Maybe it does matter if you use the menu-applet, but I haven't tested that.)

After a little time with Google and the help of this thread from the Gnome support site, I now know why Rick and I weren't able to use the old copy method: the icon is no longer sourced from /usr/share/pixmaps etc. In 2.18, the icon is sourced from /usr/share/icons/themename/scalable/places/gnome-main-menu.svg, where themename is just whatever icon theme you use - e.g. gnome, Tango, Wasp. That in turn is a symbolic link to /usr/share/icons/themename/size/places/start-here.png where themename and size are variables for your icon theme and the pixel size of the menubar.

I shrank my preferred icon (same as my avatar here) to 22x22 and copied that over /usr/share/icons/gnome/22x22/places/start-here.png, and that worked like a charm. Rick, Action and I are probably three out of the 10 total people world-wide that care about this issue, but I figured I would put up my current solution in case anyone else had trouble with Rick's.
User avatar
Telemachus
 
Posts: 4675
Joined: 2006-12-25 15:53

Postby CocoAUS » 2007-07-07 19:43

None of the methods you or rickh posted are working for me :(

I've got a 24x24 png (autobots icon) in /usr/share/icons/Tango/24x24/places/start-here.png

Interestingly, if I change panel size, everything changes size with the panel except the icon for the menu-bar applet. Also, there was no menu-bar icon at all in the Tango folder. I copied the icon to both the gnome folder and the Tango folder to be sure. Any ideas?
User avatar
CocoAUS
 
Posts: 513
Joined: 2007-04-29 08:40

Postby Telemachus » 2007-07-07 20:00

CocoAUS wrote:None of the methods you or rickh posted are working for me :(

I've got a 24x24 png (autobots icon) in /usr/share/icons/Tango/24x24/places/start-here.png

Interestingly, if I change panel size, everything changes size with the panel except the icon for the menu-bar applet. Also, there was no menu-bar icon at all in the Tango folder. I copied the icon to both the gnome folder and the Tango folder to be sure. Any ideas?

Ok, I have a few thoughts. First, are you in Lenny with Gnome 2.18? If not, my new method won't work for you. In Etch with Gnome 2.16, you want to copy your image over /usr/share/pixmaps/gnome-logo-icon-transparent.png. Second,(if you do have Gnome 2.18) make sure that (a) you are using the icon theme you think and (b) you are copying to the right size. I have my panel at 22x22 and I am using the gnome icons, so I copied to /usr/share/icons/gnome/22x22/start-here.png, but you have to check both of those for your system. If you have already done that, sorry if I am restating the obvious for you. Also after you do the change, you need to either log out or kill the panel to get the change. (To kill the panel, as root enter "killall gnome-panel" - if you have the battery status applet, it may make it pop onto the desktop. Don't worry, it will be fine when you next log in.) This is all I can think of right now. Let me know if any of this helps.
User avatar
Telemachus
 
Posts: 4675
Joined: 2006-12-25 15:53

Postby CocoAUS » 2007-07-07 20:31

Thanks for the suggestions, but I've made sure everything is right (Gnome 2.18, right icon set, right size, restart X, etc). The custom icon setting in gconf-editor doesn't work, either. I'll play around with it a bit and if I figure anything out, I'll post back here just incase anyone else has the same problem.
User avatar
CocoAUS
 
Posts: 513
Joined: 2007-04-29 08:40

Postby Telemachus » 2007-07-07 21:41

One more question: tell me exactly how you copied the image (what method or what command). That might help me to think about what went wrong.
User avatar
Telemachus
 
Posts: 4675
Joined: 2006-12-25 15:53

Postby CocoAUS » 2007-07-08 00:29

Telemachus wrote:One more question: tell me exactly how you copied the image (what method or what command). That might help me to think about what went wrong.


Opened the folder as root, copy-and-pasted the icon over via right-click menus.
User avatar
CocoAUS
 
Posts: 513
Joined: 2007-04-29 08:40

Postby Telemachus » 2007-07-08 02:44

CocoAUS wrote:Opened the folder as root, copy-and-pasted the icon over via right-click menus.

I did it from the command line as root, but I don't see how that would make a difference. Still, if you want to play with it, here it is:
Code: Select all
# mv debian.png start-here.png
# cp start-here.png /usr/share/icons/gnome/22x22/places/start-here.png
# killall gnome-panel

I changed the name of the image to start-here.png, so the symlink would find it, then copied it over to the folder and restarted the gnome-panel. I've done it on two machines now and it worked both times. I can't think of why it didn't work for you. It's too bad, because I was pretty happy that I had figured out this minor mystery. You might try posting at the Gnome support forums. Maybe someone there will know another trick.
User avatar
Telemachus
 
Posts: 4675
Joined: 2006-12-25 15:53

Postby rickh » 2007-07-08 02:53

Debian-Lenny/Sid 32/64
Desktop: Generic Core 2 Duo, EVGA 680i, Nvidia
Laptop: Generic Intel SIS/AC97
User avatar
rickh
 
Posts: 3475
Joined: 2006-06-29 02:13
Location: Albuquerque, NM USA

Postby CocoAUS » 2007-07-08 03:37

Yeah, still not working. I tried copying the icon into each size folder just to make sure, but no dice.
User avatar
CocoAUS
 
Posts: 513
Joined: 2007-04-29 08:40

Postby Telemachus » 2007-07-08 09:52

rickh wrote:Here's another take on the issue:

http://www.linuxquestions.org/questions ... t=563658#4

It's actually the same take as the Gnome support forums link I gave above, since deepclutch at Linux Questions is the same person as praka123 at Gnome support. (He posted one of his answers verbatim at both sites. I'm surprised to learn how often people post identical questions or answers at two or more Linux sites simultaneously.)

It still bugs me that only one of the two methods works on some systems and that on Coco's no method works, but I'm giving up on this mystery for now.
User avatar
Telemachus
 
Posts: 4675
Joined: 2006-12-25 15:53

Postby anthony » 2007-07-17 08:32

thanks for this. I would like to add that when searching for the proper object, I noticed that mine has the object_type set as menu-object. All of the other ones had the object_type set as launcher_object (for me anyway). So that might help finding the right one faster.


Also, does anyone know how to get rid of the little tiny arrow that appears on the icon of the main menu? Its an indicator for a drop down. It doesn't really matter if its there or not but I would rather not have it if it can be removed.
User avatar
anthony
 
Posts: 94
Joined: 2006-08-16 04:29


Return to Docs, Howtos, Tips & Tricks

Who is online

Users browsing this forum: No registered users and 6 guests

fashionable