Howto open mailto's in Icedove from Iceweasel ?[Solved]

If none of the more specific forums is the right place to ask

Howto open mailto's in Icedove from Iceweasel ?[Solved]

Postby PM » 2007-06-18 21:33

How to start Icedove and open a blank letter when clicking on a mailto-link in iceweasel ?
I use Debian 4.0 and KDE.

How to fix it ?
Last edited by PM on 2007-06-20 13:50, edited 6 times in total.
PM
 
Posts: 24
Joined: 2007-04-28 19:13
Location: Lat:55:36:00N Lon:13:00:00E

Postby PM » 2007-06-18 22:39

Ok, no solution yet ... :?

Where is the about:config file located, so I can go in manually and edit the file instead of doing it in iceweasel ?
PM
 
Posts: 24
Joined: 2007-04-28 19:13
Location: Lat:55:36:00N Lon:13:00:00E

Postby Red Knuckles » 2007-06-20 00:23

Type 'about:config' in URL box. Then type 'mailto' In 'Filter' box and either change

'network.protocol-handler.app.mailto'

[modify] to '/usr/bin/icedove' or whichever mailclient/path you wish to use. OR ADD

'network.protocol-handler.app.mailto'

as 'string' and put '/usr/bin/icedove' as 'value'. To add right click in empty space in about:config window and select 'string'.

To set icedove to open iceweasel by default go to >Edit>Preferences>Advanced>Config Editor and type 'http' in filter line. Then either change or add 'network.protocol-handler.app.http' and use '/usr/bin/iceweasel' as value. Do the same for 'https' and 'ftp'. As before add as 'string'. If this doesn't quite make sense post back and I'll try again to explain. :shock:
Thanks,
Red Knuckles
Sabayon 3.4 AMD64, Debian SID AMD64, Ubuntu 7.04 AMD64,
ASUS M2NPV-VM, AMD Athlon64 X2 4800+, 2GB DDR2 800
Red Knuckles
 
Posts: 96
Joined: 2006-10-18 00:26
Location: Colorado, USA

Postby PM » 2007-06-20 12:59

Red Knuckles wrote:Type 'about:config' in URL box. Then type 'mailto' In 'Filter' box and either change

'network.protocol-handler.app.mailto'

[modify] to '/usr/bin/icedove' or whichever mailclient/path you wish to use. OR ADD

'network.protocol-handler.app.mailto'

as 'string' and put '/usr/bin/icedove' as 'value'. To add right click in empty space in about:config window and select 'string'.

To set icedove to open iceweasel by default go to >Edit>Preferences>Advanced>Config Editor and type 'http' in filter line. Then either change or add 'network.protocol-handler.app.http' and use '/usr/bin/iceweasel' as value. Do the same for 'https' and 'ftp'. As before add as 'string'. If this doesn't quite make sense post back and I'll try again to explain. :shock:

Hi!

Thanks for reply ...

Ok, that worked fine !!!! :) After I messed around for a bit :roll:
PM
 
Posts: 24
Joined: 2007-04-28 19:13
Location: Lat:55:36:00N Lon:13:00:00E

Postby jongi » 2008-10-25 12:14

Here's a strange thing.

When I use Firefox (Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.3) Gecko/2008092416 Firefox/3.0.3) clicking on a mailto link opens the mail client specified in about:config.

However when using Iceweasel (Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.3) Gecko/2008092816 Iceweasel/3.0.3 (Debian-3.0.3-2), nothing happens when I click a mailto link.
Desktop: Debian (Sid) 64-bit, Gentoo 64-bit and Ubuntu Jaunty 64-bit
Laptop: Gentoo 32-bit
MythTV: Debian (Testing) 32-bit
jongi
 
Posts: 477
Joined: 2007-04-15 02:41


Return to General Questions

Who is online

Users browsing this forum: No registered users and 5 guests

fashionable