LVM/boot problem

Kernels & Hardware, configuring network, installing services

LVM/boot problem

Postby brennanr » 2007-11-12 16:30

Hi there

I have a Dell Inspiron 640m laptop running Debian Etch with the 2.6.18 kernel

It had worked fine for a couple of months but I shut it down last week and it
won't reboot as drops to the initramfs Busybox shell.

The problem seems to be with mounting the root filesystem under LVM2 as grub manages to
load and then after some normal initialisation I get:
Code: Select all
Begin: Running /scripts/local-top ...
ide0: I/O resource 0x1F0-0x1F7 not free.
ide0: ports already in use, skipping proble
ide1: I/O resource 0x170-0x177 not free.
ide1: ports already in use, skipping proble
device-mapper: ioctl: 4.7.0-ioctl (2006-06-24) initialised: dm-devel@redhat.com
    Volume group "debianrob" not found
    Volume group "debianrob" not found
Done.
Begin: Waiting for root file system ...
     Check root= bootarg cat /proc/cmdline
     or missing modules, devices: cat /proc/modules ls /dev
ALERT! dev/mapper/debianrob-root does not exist. Dropping to a shell!



There is only a single hard disk setup with the Debain installer to use LVM.
It's partitioned into:
/sda2 Grub etx3 /boot partition
/sda5 /tmp swap partition
/sda6 / ext3 debian install

sda6 is the logical volume called debianrob

I can mount the /sda2 and see the Grub ext3 partition but if I try to
mount /sda6 all I see is the empty directories lost+found and rob
I fear that this is because I tried booting with a knoppox 5.1 live cd
and it wrote that data to the /sda6 partition when I tried to veiw it, eek.

Is my data all gone?

I have followed the process for no volume groups being found in the
LVM2 FAQ at
http://dev.riseup.net/grimoire/storage/lvm2/#my_logical_volumes_are_not_active_or_usable_on_restart
But I had no joy. All I get is "no volume groups found"

The one thing that might have confused Debian is that I had a USB memory
stick plugged into the laptop at power down but I've done that before with
no problems.

Any help appreciated

rgds
rob
brennanr
 
Posts: 1
Joined: 2007-11-12 16:00

Postby Guest » 2007-11-14 09:56

Update:

I've looked at the partition table using sfdisk and I can see that sda6
is marked as "linux" rather than "linux LVM". I assume this is very
ominous. :-(
I have been trying to recover using Knoppix and the Debian install
disk but I have been careful and I don't believe that I committed to
a re-partioning (though I suppose its more likely me than a bug).

More evidence. I tried to use the method described here
http://www.linuxjournal.com/node/8874/print
to recover the LVM metadata from after the MBR using dd
but found nothing.

I had actually begun to doubt myself that I had setup LVM
at all (given the above) but I see in GRUB that the root arg
for the kernel references /media/mapper/volumegroup rather
than a device so it was configured that way at one stage.

Is there a way to get the kernel/init scripts to step through
the boot process so I can see all the logging sent to the
console or is there a log kept on the initramfs ?

On the positive side I was able to recover some source by decompiling
some jar files so not all is lost :-)

rgds
rob
Guest
 

Postby Guest » 2007-12-12 20:24

Hi!
I have the same problem.
I installed Debian from the Debian 4.0r1 netinst CD (ETCH). Then I tried to update Debian to LENNY from Internet. Update ended successful. After reboot I saw this:

Code: Select all
dm-devel@redhat.com
    Volume group "main" not found
    Volume group "main" not found
Done.
Begin: Waiting for root file system ...


I have no idea what is happened.
Guest
 

Postby torstenkarusseit » 2007-12-13 23:33

Hi, the same with me.
I'm trying to install a 2.6.23 kernel on my debian etch (2.6.18), wich was installed on lvm.
Booting the 2.6.23 it shows the "volume group xy not found" error and waits for root fs.
Who may help ?
torstenkarusseit
 

Can't get LVM to work on Etch with 2.6.23 here, either.

Postby Anonimo » 2007-12-15 18:08

I've tried building 2.6.23.9 from kernel.org, first with built-ins for my devices only, then with update-initramfs when I found that was necessary for LVM, then with the config from 2.6.18. None of those worked.
The kernel-source-2.6.23 from backports.org built with make-kpkg doesn't work either.
Not sure what to try next.

After I got the device selection sorted out, the output has always been the same as far as I can tell: it looks like the volume group doesn't appear, but the initrd scripts flood the screen with error messages, and I can't see what happened at that point.

I tried videoing the boot with my camera, but only totem+gstreamer will play the mp4 files it generates properly (xine based players and newer mplayers crop the image to 320x200 and I haven't been able to force it to do otherwise with options) Frustratingly it won't slow playback or allow seeks with frame-by-frame granularity, and I can't find any other players based on gstreamer.
Anonimo
 

OK, trying linux-image-2.6.23-1-amd64_2.6.23-1_amd64.deb

Postby Guest » 2007-12-15 20:36

I'll be surprised if it works, but I'll give it a go...
Guest
 

Postby Guest » 2007-12-15 20:55

Consider me surprised! Worked fine. I'll need to install linux-headers-2.6.23-1-amd64_2.6.23-1_amd64.deb to get everything working (e.g. my rtx00 wlan usb stick) but that seemed to do the trick. I'd prefer a whittled down kernel, but I guess I'll have to work backwards from the kernel package. Maybe I'll try building a kernel under it once all is working: it'll pick up the /proc/config.gz from it and things may well work nicely from then on.
Guest
 

Postby Guest » 2007-12-15 21:59

The headers wouldn't install as they required a package that depends on libc6 and other stuff I don't want to upgrade to the testing or unstable version. Consequently I had to build the kernel in order to build other modules. The kernel I built with make-kpkg from the linux-source-2.6.23 package booted fine, too. I built one of the extra modules I needed OK. The problems I've had with others are beyond the scope of this topic, I think.
Guest
 


Return to System configuration

Who is online

Users browsing this forum: No registered users and 13 guests

fashionable