apt-get upgrade grows fonts

Everything about X, Gnome, KDE, ... and everything running on it

apt-get upgrade grows fonts

Postby EMD » 2008-05-06 04:56

On my Lenny system, I just ran an apt-get dist-upgrade, which upgraded xserver-xorg. After restarting X, all of my fonts were 20 percent larger (on both KDE and IceWM).

Reconfiguring all of my fonts was a PITA, but it's for the best. (The Etch fonts were too small).

Does anyone know why the font sizes change?
.
User avatar
EMD
 
Posts: 989
Joined: 2007-06-10 03:03
Location: /dev/tty7 (Don't deny it. You're here too!)

Postby roseway » 2008-05-06 06:44

It's not the fonts which have changed, but the DPI value of the screen. If you type

xdpyinfo | grep resol

you will see what the current DPI value is. For most people 96 x 96 is the optimum value for font quality.
Eric
User avatar
roseway
 
Posts: 1511
Joined: 2007-12-31 22:50
Location: Kent, UK

Postby EMD » 2008-05-06 06:58

Thanks!

Is there an easy way to change that?
User avatar
EMD
 
Posts: 989
Joined: 2007-06-10 03:03
Location: /dev/tty7 (Don't deny it. You're here too!)

Postby jackass » 2008-05-06 08:23

Open /etc/kde3/kdm/kdmrc (as root) and scroll down until you see: ServerArgsLocal=-nolisten tcp

Change to: ServerArgsLocal=-nolisten tcp -dpi 96

Then reboot.
Debian - Testing/Sid
User avatar
jackass
 
Posts: 66
Joined: 2008-04-28 19:58
Location: United States

Postby EMD » 2008-05-06 13:45

Thanks. I suspect that the xserver-xorg upgrade changed my resolution to 96 x 96, but I'd like to reduce the size of the fonts, so what would be a good value to pick? 80 x 80?
User avatar
EMD
 
Posts: 989
Joined: 2007-06-10 03:03
Location: /dev/tty7 (Don't deny it. You're here too!)

Postby IsaacKuo » 2008-05-06 14:21

Another standard dpi would be 72dpi (used on Macs since the original).
Isaac Kuo
User avatar
IsaacKuo
 
Posts: 316
Joined: 2008-04-24 20:06

Postby EMD » 2008-05-06 14:31

IsaacKuo wrote:Another standard dpi would be 72dpi (used on Macs since the original).

I've been playing around and I just set it at 72 dpi! I love it!

EDIT: Is there any particular reason for choosing multiples of 12? (i.e. 12*6=72 and 12*8=96)
User avatar
EMD
 
Posts: 989
Joined: 2007-06-10 03:03
Location: /dev/tty7 (Don't deny it. You're here too!)

Postby sleepyEDB » 2008-05-07 01:07

I (and my eyes) thank you for the tip! :)


sleepy
"The road of life is rocky, and you may stumble too. While you point your finger, someone else is judging you." --Bob Marley
User avatar
sleepyEDB
 
Posts: 98
Joined: 2005-09-11 19:47
Location: Detroit, MI

Postby Bulkley » 2008-05-07 02:17

jackass wrote:Open /etc/kde3/kdm/kdmrc (as root) and scroll down until you see: ServerArgsLocal=-nolisten tcp

Change to: ServerArgsLocal=-nolisten tcp -dpi 96

Then reboot.


For those of us without kde, where else would we do that?
Bulkley
 
Posts: 5848
Joined: 2006-02-11 18:35

Postby jackass » 2008-05-07 03:34

Bulkley wrote:
jackass wrote:Open /etc/kde3/kdm/kdmrc (as root) and scroll down until you see: ServerArgsLocal=-nolisten tcp

Change to: ServerArgsLocal=-nolisten tcp -dpi 96

Then reboot.


For those of us without kde, where else would we do that?


I don't know the answer for Gnome or the other WMs. Sorry.
Debian - Testing/Sid
User avatar
jackass
 
Posts: 66
Joined: 2008-04-28 19:58
Location: United States

Postby Bulkley » 2008-05-07 04:20

I found this site http://www.mikeyp.com/weblog/linux. Scroll down to Improving Debian/Ubuntu Fonts. I've been playing with his instructions but I'm not sure it's changing anything.
Bulkley
 
Posts: 5848
Joined: 2006-02-11 18:35

Postby IsaacKuo » 2008-05-07 04:39

One method of adjusting the dpi which doesn't depend on the desktop environment is xorg.conf.

In the Monitor section of xorg.conf, you can specify the display size in millimeters. For example:

Section "Monitor"
Identifier "Nokia 445Xi"
Option "DPMS"
HorizSync 28-99
VertRefresh 59-60
DisplaySize 400 300
...

So, what if you want 72dpi? Then, you take your screen resolution in pixels, and multiply it by 25.4/72. This gives you the screen size in millimeters.

For example, with a resolution of 1024x768, you'd have

1024*25.4/72 = 361.24
768*25.4/72 = 270.93

The numbers don't have to be exact, so the corresponding line could be:

DisplaySize 360 270
Isaac Kuo
User avatar
IsaacKuo
 
Posts: 316
Joined: 2008-04-24 20:06

Postby Bulkley » 2008-05-08 05:40

When I do xdpyinfo | grep resol the result is 85 x85. Nothing I do changes this. So, what is setting it? Where do I look?
Bulkley
 
Posts: 5848
Joined: 2006-02-11 18:35

Postby Skytramp » 2008-05-11 11:27

Bulkley wrote:
jackass wrote:Open /etc/kde3/kdm/kdmrc (as root) and scroll down until you see: ServerArgsLocal=-nolisten tcp

Change to: ServerArgsLocal=-nolisten tcp -dpi 96

Then reboot.


For those of us without kde, where else would we do that?


On Etch+Gnome: Desktop>Preferences>Font>Details>Resolution:...dots per inch

On Lenny+Gnome: System>Preferences>Appearance>Fonts>Details>Resolution:...dots per inch
User avatar
Skytramp
 
Posts: 9
Joined: 2008-03-02 07:52
Location: Italy

Postby hafilip84 » 2008-05-11 18:12

Skytramp wrote:
Bulkley wrote:
jackass wrote:Open /etc/kde3/kdm/kdmrc (as root) and scroll down until you see: ServerArgsLocal=-nolisten tcp

Change to: ServerArgsLocal=-nolisten tcp -dpi 96

Then reboot.


For those of us without kde, where else would we do that?


On Etch+Gnome: Desktop>Preferences>Font>Details>Resolution:...dots per inch

On Lenny+Gnome: System>Preferences>Appearance>Fonts>Details>Resolution:...dots per inch

Hmmm... But where are config files?
I'm sorry for my language mistakes. I'm not a native speaker at all...
hafilip84
 
Posts: 40
Joined: 2006-07-21 01:14
Location: Legionowo, Poland

Next

Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 4 guests

fashionable