[solved] x11 every mouse click is a double-click

Everything about X, Gnome, KDE, ... and everything running on it

[solved] x11 every mouse click is a double-click

Postby Stephen Howard » 2008-05-07 12:57

Yesterday I updated Lenny and today (being the boot following the update), all mouse clicks (left or right) are interpreted as double clicks.

I suspect X11 because of the large number of X11 updates yesterday. That said, xorg.conf hasn't changed. Can anyone suggest a solution?
Last edited by Stephen Howard on 2008-05-09 02:17, edited 1 time in total.
Stephen Howard
 
Posts: 28
Joined: 2008-05-07 12:48

Postby Volker Groll » 2008-05-07 20:58

For me it helps to comment out a second mouse InputDevice from xorg.conf.
I inserted it long ago to access the touch in my laptop and a usb mouse in parallel.

But why this behaviour has changed?
Volker Groll
 
Posts: 2
Joined: 2008-05-07 20:50

Postby Stephen Howard » 2008-05-08 00:37

Good point Volger - I too have a second mouse entry from several months ago when I was testing a wireless mouse. I'll delete the entry and see what happens.

That said, like you I don't understand why the behaviour has changed.
Stephen Howard
 
Posts: 28
Joined: 2008-05-07 12:48

Postby Stephen Howard » 2008-05-08 07:58

I can confirm that the fix worked. Still v.puzzled why though.

Thanks Volker
Stephen Howard
 
Posts: 28
Joined: 2008-05-07 12:48

Postby Nyhm » 2008-05-08 16:34

Same problem (updated Debian lenny today). I have two mouse-related InputDevice sections in xorg.conf

Code: Select all
Section "InputDevice"
        Identifier      "Configured Mouse"
        Driver          "mouse"
        Option          "CorePointer"
        Option          "Device"                "/dev/psaux"
        Option          "Protocol"              "PS/2"
        Option          "Emulate3Buttons"       "true"
        Option          "ZAxisMapping"          "4 5"
EndSection

Section "InputDevice"
       Identifier      "Generic Mouse"
       Driver          "mouse"
       Option          "SendCoreEvents"        "true"
       Option          "Device"                "/dev/input/mice"
       Option          "Protocol"              "ImPS/2"
       Option          "Emulate3Buttons"       "true"
       Option          "ZAxisMapping"          "4 5"
EndSection


In addition, this section has both mouses listed:

Code: Select all
Section "ServerLayout"
        Identifier      "Default Layout"
        Screen          "Default Screen"
        InputDevice     "Generic Keyboard"
        InputDevice     "Configured Mouse"
       InputDevice     "Generic Mouse"
EndSection


I've tried commenting out each. With "Generic Mouse" enabled, I get the double-click problem. With only "Configured Mouse" enabled, clicking is correct, but no scroll wheel!! I can't live with that for long...

I do not know what to do beyond this. I will greatly appreciate any further help!

Edited to correct which works: "Configured Mouse" clicking works, but NO SCROLL WHEEL!
Nyhm
 
Posts: 7
Joined: 2006-10-24 15:23

Postby Nyhm » 2008-05-08 17:08

Another clue: Gnome seems to be controlling my mouse, which was not the case before. When X first starts, the mouse is fast. When GDM starts, the mouse changes to a different cursor and slows down. Gnome's Mouse Preferences application can adjust this (which I do not think worked before).

I'm using a Logitech MX500 optical USB mouse, which has worked for many years with Debian, until now.

Thanks for any advice you can offer to get my scroll wheel working again.
Nyhm
 
Posts: 7
Joined: 2006-10-24 15:23

Postby Nyhm » 2008-05-08 18:00

Aha! Here's the configuration that works for me (manually edited in xorg.conf):

Code: Select all
Section "InputDevice"
   Identifier   "Configured Mouse"
   Driver      "mouse"
   Option      "CorePointer"
   Option      "Device"      "/dev/psaux"
   Option      "Protocol"      "ImPS/2"
   Option      "Emulate3Buttons"   "true"
   Option      "ZAxisMapping"      "4 5"
EndSection


The important change was:

Code: Select all
   Option      "Protocol"      "ImPS/2"


As explained : http://humanreadable.nfshost.com/sdeg/s ... -mouse.htm

I seem to be close to normal, but monkeying with xorg.conf worries me, especially if it will continue to work under future xorg updates in Debian.
Nyhm
 
Posts: 7
Joined: 2006-10-24 15:23

Postby Volker Groll » 2008-05-08 18:21

Hi Nyhm,

Yeah, i just finished playing around, and my results are fairly the same:

i stripped down my xorg.conf to the following and everything works

Code: Select all
Section "InputDevice"
    Identifier  "Generic Mouse"
    Driver      "mouse"
    Option      "Device"        "/dev/input/mice"
    Option      "Protocol"      "Auto"
EndSection

Section "ServerLayout"
    Identifier  "Default Layout"
    Screen      "Default Screen"
    InputDevice "Generic Keyboard"
    InputDevice "Generic Mouse" "CorePointer"
EndSection


For me the mouse wheel also does not work with protocol ps/2, so as you found: your protocol is wrong.
From /var/log/Xorg.0.log i can see, that here ExplorerPS/2 is used by X11, but as you see, i use Auto.
I normally do not use gnome, but if i try to use it with ps/2 and do not set the InputDevice
to CorePointer but to SendCoreEvents i also get (in my opinion) strange beahviour:
Cannot start terminal, maximize window, when clicking title bar.

Perhaps you can also try the Protocol "Auto" and post the used driver from Xorg.0.log. Thanks.
~
Volker Groll
 
Posts: 2
Joined: 2008-05-07 20:50

Postby Nyhm » 2008-05-08 18:40

Notice that my mouse wheel works correctly, as configured above, with Protocol "ImPS/2".

Under my configuration above, this is what Xorg.0.log shows for the mouse driver:

Code: Select all
(II) LoadModule: "mouse"
(II) Loading /usr/lib/xorg/modules/input//mouse_drv.so
(II) Module mouse: vendor="X.Org Foundation"
        compiled for 1.4.0, module version = 1.2.3
        Module class: X.Org XInput Driver
        ABI class: X.Org XInput driver, version 2.0


I guess this is some type of generic Xorg mouse driver. Next, I'll try protocol Auto, as you suggested...
Nyhm
 
Posts: 7
Joined: 2006-10-24 15:23

Postby Nyhm » 2008-05-08 18:48

Using Option Protocol Auto, as suggested, this new entry shows up in Xorg.0.log:

Code: Select all
(--) Configured Mouse: PnP-detected protocol: "ExplorerPS/2"
(II) Configured Mouse: ps2EnableDataReporting: succeeded


I'm not sure what difference this will make. Everything seems the same as Protocol ImPS/2.

Thanks for the input -- I hope this gets sorted for future Debian releases.
Nyhm
 
Posts: 7
Joined: 2006-10-24 15:23


Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 18 guests

fashionable