Hsdpa usb pendrive on Linux Debian Etch

Share your own howto's etc. Not for support questions!

Hsdpa usb pendrive on Linux Debian Etch

Postby Rodolfo Medina » 2008-08-12 18:17

Operating system: Debian Etch, kernel 2.6.18.
Device: Huawei e169.

See:

http://ubuntuforums.org/showthread.php?t=858032

. In Italy the device is sold with a CD-ROM containing the file
`fr.5407.0.Linux Driver V100R001B302_29.tar'. Copy it into ~/tmp, then do:

$ cd tmp
$ tar xvvf fr.5407.0.Linux\ Driver\ V100R001B302_29.tar
$ cd Linux\ Driver\ V100R001B302/

. In the first line of the file rules/10-Huawei-Datacard-Old-Kernel.rules,
change all occurrences of `103' into `101'. Then do:

# cp -vi HWActivator remove_pl2303 /sbin
# cp -vi rules/10-Huawei-Datacard-Old-Kernel.rules /etc/udev/rules.d
# /sbin/HWActivator "Register"
# apt-get install ppp
# adduser <your-username> dip

-------------------------------------------------------------------------------
NOTE1: with a kernel greater than 2.6.18 but not greater than 2.6.20, in the
above procedure you probably should use the file 10-Huawei-Datacard.rules
instead of 10-Huawei-Datacard-Old-Kernel.rules, changing the first line from

SUBSYSTEM=="usb", SYSFS{idProduct}=="1001", SYSFS{idVendor}=="12d1", RUN+="/sbin/rmmod pl2303"

to

SUBSYSTEM=="usb", SYSFS{idProduct}=="1001", SYSFS{idVendor}=="12d1", RUN+="/sbin/modprobe usbserial vendor=0x12d1 product=0x1001"

. Instead, with a kernel greater than 2.6.20 you may needn't do anything,
only plu the device in, or at the most it should be enough to do:

# cp -vi HWActivator remove_pl2303 /sbin
# /sbin/HWActivator "Register"

instead of

# cp -vi HWActivator remove_pl2303 /sbin
# cp -vi rules/10-Huawei-Datacard-Old-Kernel.rules /etc/udev/rules.d
# /sbin/HWActivator "Register"
-------------------------------------------------------------------------------

Now, create the file /etc/chatscripts/huawei and fill it with:

ABORT BUSY
ABORT 'NO CARRIER'
ABORT VOICE
ABORT 'NO DIALTONE'
ABORT 'NO DIAL TONE'
ABORT 'NO ANSWER'
ABORT DELAYED
'' ATZ
OK-AT-OK AT+CGDCONT=1,"IP","ibox.tim.it"
OK-AT-OK AT+CGQREQ=1,2,4,3,6,31
OK-AT-OK AT+CGQMIN=1,2,4,3,6,31
OK-AT-OK AT+CGATT=1 OK-AT-OK ATD*99#
CONNECT ''

. The apn address ibox.tim.it can be changed at your needs when you're using
a different internet provider (see NOTE2 below). Create the file
/etc/ppp/peers/huawei and fill it with:

hide-password
noauth
connect "/usr/sbin/chat -v -s -f /etc/chatscripts/huawei"
debug
-crtscts
/dev/ttyUSB0
460800
defaultroute
noipdefault
remotename huawei
ipparam huawei
usepeerdns
nodetach

, then reboot. Insert the device (I suggest to use a cable, because the
device gets hot), then look at the light and wait: at first it flashes twice
and stops, twice and stops, with a green light. Then it flashes once at a
time, with a blue (or red) light: now you can connect: do:

$ pon huawei

and you are connected. `Ctrl-c' to close connection. (If sometimes the modem
sticks instead of connecting, plug it off and then in again.) During the data
transfer, a blue persistent light means umts mode, whereas a cian persistent
light means hsdpa mode.

To uninstall the driver, do:

# /sbin/HWActivator "Unregister"
# rm -vi /sbin/HWActivator /sbin/remove_pl2303 /etc/udev/rules.d/10-Huawei-Datacard-Old-Kernel.rules

-------------------------------------------------------------------------------
NOTE2: when connecting with a different provider from Tim, I could not surf
through internet. Then I decided to comment out the line `usepeerdns' in the
file /etc/ppp/peers/huawei and to edit manually the file /etc/resolv.conf
according to the provider:

with Tim, resolv.conf must be:

nameserver 213.230.155.94
nameserver 213.230.130.222


; with Tre,

nameserver 62.13.171.2
nameserver 62.13.171.1


; with Wind,

nameserver 193.70.152.25
nameserver 193.70.192.25


. I didn't try with Vodafone yet.
-------------------------------------------------------------------------------
Last edited by Rodolfo Medina on 2008-09-04 11:11, edited 1 time in total.
Rodolfo Medina
 
Posts: 22
Joined: 2006-05-06 10:39

Postby oswaldkelso » 2008-08-31 12:45

The Vodafone driver is gpl'd and meant to work on the "3" network also.

https://forge.betavine.net/projects/vodafonemobilec/

I've not tried it but am trying to gather some info as I may go down the hsdpa only road (no phone line or adsl) I only get 3 days to get it working before I'm locked into a 15gb 18 month contract or have to bow out. If anyone has any info and could pass it on I'd be grateful. In particularly with reference to 3 as its the only provider with a decent download allowance atm. It also has a half Price offer on :)

I read some where that it's a dual modem / storage device. Some linux users needed to plug it into a xp / vista pc first before it would be seen as a modem, and work on linux?

cheers
Running systemd free on Dragora GNU/linux-libre on. Dell Latitude 5420, Samsung NC10.
Refracta and Linux-libre on Dell inspiron 530 http://jxself.org/linux-libre/
Debian on PowerPC.
"Ubuntu will always be brown" dilberts_left_nut
User avatar
oswaldkelso
 
Posts: 833
Joined: 2005-07-26 23:20
Location: UK

Postby oswaldkelso » 2008-09-28 17:51

Sep 16 2008
Acer one with Debian lenny and Huawei e160g and Huawei e169

Today I bought a Huawei e160g hsdpa modem. I went to my local “3″ phone shop and took my acer one running Debian Lenny with me. After a little chat I persuaded the store assistant to let me plug it into their demo Huawei e169 hsdpa modem. This modem has a theoretical speed of 7.2 mb. At the moment here in the uk a top speed is a more realistic 5.4mb.

Prior to going to the store I had down loaded and installed the Vodafone Mobile Connect Card -VMC Card Driver Linux 2.0.beta3.

https://forge.betavine.net/projects/vodafonemobilec/

The result was great the driver saw it and connected straight off I had bookmarked a download speed site and ran a quick test. A impressive 5.4mb. download speed was recorded.

Things were looking good but I had on problem to solve. I live at the base of a viaduct in the valley between a small town and a village. My mobile phone reception can be dodgy depending on the provider. I knew O2, and vodaphone worked but had no idea if 3 would. Their map said excellent coverage around me and good coverage where I live. There was no way I was going to commit to a 18 month contract with no returns on phones when I may have no coverage. They did however have 3 days returns on modems and I could do a pay-as-you-go £50 for the modem and £10 for the sim. I bought a Huawei e160g and went to my sons to try it.

At my son house a mile up the road from me we got the full advertised speed of the e160g modem. hsdpa was working and the blue light active. 3.6mb

Modem Speed Test Page

This page was loaded in 0.105 seconds.

Your throughput 36740960 bps
Typical ISDN 64K 64000 bps
Typical ISDN 128K 128000 bps
Typical 8M Broadband 8M bps

At my house we got half dial up speed on the e160g modem!!! hsdpa was not working and the green light active.

Modem Speed Test Page - Test Results

Date: Tuesday, September 16th, 2008
Time: 20:17:13
File size: 34963 bytes
Download Time: 10.597 seconds
Average Throughput: 3300 Bytes/sec (26400bps)
*Estimated Connection Speed: around 26,400 bps

Your throughput 26400bps
Typical 33.6K 32000bps
Typical 50K 48000bps
Typical ISDN 64K 64000bps
Typical ISDN 128K 128000bps

I played around with it in different rooms but apart from 25 seconds when I held the modem against the window in a never to be repeated position :( I was flogging a dead horse. I even booted up osx and tried it with that no difference, same speed no even on 3 but Orange!! As I understand it if hsdpa fails it searches for the next fastest type of connection even switching carriers. They all have deals between each other to ensure you at least get some connection.

Edit: I'm aware I've got my bits/bytes arse about face
Running systemd free on Dragora GNU/linux-libre on. Dell Latitude 5420, Samsung NC10.
Refracta and Linux-libre on Dell inspiron 530 http://jxself.org/linux-libre/
Debian on PowerPC.
"Ubuntu will always be brown" dilberts_left_nut
User avatar
oswaldkelso
 
Posts: 833
Joined: 2005-07-26 23:20
Location: UK


Return to Docs, Howtos, Tips & Tricks

Who is online

Users browsing this forum: No registered users and 6 guests

fashionable