[SOLVED] Mounting ext4 drive

Kernels & Hardware, configuring network, installing services

[SOLVED] Mounting ext4 drive

Postby super.rad » 2008-12-01 16:04

I've been trying fedora 10 for a few weeks and decided to also try reformatting one of my drives as ext4. I've have had no problems with it at all and the drive was actually quieter than usual (is an old and pretty noisy drive) and fsck check's have been much quicker than on ext3.
To mount the drive in fedora I just typed
Code: Select all
mount -t ext4 /dev/sdb1 /media/media

and in fstab I just changed filesystem from ext3 to ext4 and it mounted on boot with no problems.
After having a few problems on fedora (and not liking rpm/yum as much as deb/apt) I reinstalled Debian from the weekly testing CD. As lenny is still frozen I decided to upgrade to sid until squeeze is released when I will change my sources back to testing.
The problem is I tried to mount the drive using the same commands I used on fedora and got the error
Code: Select all
mount: unknown filesystem type 'ext4'

So after a bit of searching I found the following from here
In Debian Lenny (Testing), the following current packages provide ext4 support:

* ext4dev module in the linux-image package (2.6.26-10)
* e2fsprogs (1.41.3-1)

It should be noted that the stock 2.6.26 ext4 has problems with delayed allocation and with filesystems with non-extent based files. So until Debian starts shipping a 2.6.27 based kernel or a 2.6.26 kernel with at least the 2.6.26-ext4-7 patchset, you should mount ext4dev filesystems using -o nodelalloc and only use freshly created filesystems using "mke2fs -t ext4dev". (Without these fixes, if you try to use an ext3 filesystem which was converted using tune2fs -E test_fs -o extents /dev/DEV, you will probably hit a kernel BUG the moment you try to delete or truncate an old non-extent based file.)

So I tried mounting the drive using "ext4dev" instead of just "ext4" but I'm getting this error:
Code: Select all
mount: wrong fs type, bad option, bad superblock on /dev/hdd1,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so

output from dmesg | tail
Code: Select all
[ 2418.752407] EXT4-fs: hdd1: not marked OK to use with test code.

Can anyone help me to mount this drive?
Thanks

EDIT: Forgot to say, I know I could just build a newer kernel but I want to check if theres an easier way first as I have never built/compiled a kernel before
Last edited by super.rad on 2008-12-02 12:16, edited 1 time in total.
User avatar
super.rad
 
Posts: 41
Joined: 2007-08-24 17:43
Location: Wales

Postby bugsbunny » 2008-12-01 18:34

A bit of googling and I suggest that you look at the following:
man tune2fs
-E option
the test_fs and ^test_fs flags
User avatar
bugsbunny
 
Posts: 5355
Joined: 2008-07-06 17:04

Postby CreamFilledGiraffe » 2008-12-01 19:59

Try
Code: Select all
insmod ext4dev

first.

Might help.
Peace,
Rich
CreamFilledGiraffe
 
Posts: 434
Joined: 2008-01-08 21:23
Location: Ottawa, Canada

Postby super.rad » 2008-12-01 22:48

bugsbunny wrote:A bit of googling and I suggest that you look at the following:
man tune2fs
-E option
the test_fs and ^test_fs flags


Thanks, tried that and worked perfectly, incase anyone else has this problem I typed
Code: Select all
tune2fs -E test_fs /dev/hdd1

then
Code: Select all
mount -t ext4dev /dev/hdd1 /media/media
User avatar
super.rad
 
Posts: 41
Joined: 2007-08-24 17:43
Location: Wales


Return to System configuration

Who is online

Users browsing this forum: No registered users and 19 guests

fashionable