stop x server?

Everything about X, Gnome, KDE, ... and everything running on it

stop x server?

Postby arjun » 2006-02-05 18:08

Hi. I'm not quitesure how to go about stopping x. I have a custom kernel and I need to install nvidia video drivers; and this can't be done with x running. Im using xorg 6.9. Thanks.
arjun
 
Posts: 6
Joined: 2006-02-05 18:05
Location: Mississauga, Ontario

Postby Demetrius » 2006-02-05 18:22

This question is asked so often that there really should be a sticky explaining how to do it.

The answer depends on what display manager you are using, but is very similar regardless.

1. Log out of your desktop environment, back to your login screen.
2. Press Ctrl+Alt+F1 to get to a CLI login prompt and log in, then su to root.
3. Issue the command /etc/init.d/xdm stop this command is the one thing that will change based on your GUI login manager. If you use GDM substitute 'gdm' for 'xdm', if you use KDM substitute 'kdm' for 'xdm', etc.
4. Do whatever you need to do that requires X to not be running.
5. Restart X and your GUI login manager with the command /etc/init.d/xdm start. Again, substitute 'xdm' with your login manager of choice.
6. Log out of the console, press Ctrl+Alt+F7, and log back into X.
Demetrius
 
Posts: 49
Joined: 2005-09-15 17:20

Postby arjun » 2006-02-05 18:35

Thanks. Everything worked without a hitch.
arjun
 
Posts: 6
Joined: 2006-02-05 18:05
Location: Mississauga, Ontario

Questions about stopping X-server

Postby narguello » 2006-03-01 15:11

Hi!
Sorry, but I don't get to do the first two steps of the method mentioned by Demetrius, that is, I log out of my desktop environment and back to the login screen (also in graphic mode) and the key combination "Ctrl+Alt+F1" doesn't work as it is explained.
Please, could you help me?
Thanks in advance.

Demetrius wrote:This question is asked so often that there really should be a sticky explaining how to do it.

The answer depends on what display manager you are using, but is very similar regardless.

1. Log out of your desktop environment, back to your login screen.
2. Press Ctrl+Alt+F1 to get to a CLI login prompt and log in, then su to root.
3. Issue the command /etc/init.d/xdm stop this command is the one thing that will change based on your GUI login manager. If you use GDM substitute 'gdm' for 'xdm', if you use KDM substitute 'kdm' for 'xdm', etc.
4. Do whatever you need to do that requires X to not be running.
5. Restart X and your GUI login manager with the command /etc/init.d/xdm start. Again, substitute 'xdm' with your login manager of choice.
6. Log out of the console, press Ctrl+Alt+F7, and log back into X.
narguello
 
Posts: 8
Joined: 2006-02-20 08:33

Re: Questions about stopping X-server

Postby Lavene » 2006-03-01 17:53

narguello wrote:Hi!
Sorry, but I don't get to do the first two steps of the method mentioned by Demetrius, that is, I log out of my desktop environment and back to the login screen (also in graphic mode) and the key combination "Ctrl+Alt+F1" doesn't work as it is explained.
Please, could you help me?
Thanks in advance.


I assume you use the KDM login manager? KDM does not allow "Ctrl+Alt+F1" as default so you'll need to do it while you are logged in. I'm not sure if setting KDM to allow root login will change that..?

What I usually do is that I run the system down to runlevel 1, that is logging in as root at the console and type init 1. It will run the system down into single user mode and you can do whatever administrative task you need to do. When you're done you enter init 2 and the system will go back up to normal.

Tina :)
Lavene
Site admin
 
Posts: 5098
Joined: 2006-01-04 04:26
Location: Oslo, Norway


Return to Desktop & Multimedia

Who is online

Users browsing this forum: fd0 and 10 guests

fashionable