Touchpad Not Working

Getting your soundcard to work, using Debian on non-i386 hardware, etc

Touchpad Not Working

Postby ghostdawg » 2009-06-13 08:33

After about two weeks of not using my Acer Aspire One with Debian Squeeze, I started it up and ran an upgrade. Once the upgrade finished now it seems the touchpad is not working. I tried using a USB mouse and it doesn't work either, it worked also before the upgrade.

Any idea how to get the touchpad and usb mouse working again or what the problem could be? I'm not too keen on laptops issues.

Thnx.
Tower | Debian Testing & Mageia 1 | HP DX5150 AMD64 | 512gb | 40gb
AAO | Mandriva 2010.2 | Intel Atom | 1gb | 160gb
Mini Mac G4 | Debian & OSX | 1gb | 60gb
User avatar
ghostdawg
 
Posts: 1093
Joined: 2006-08-29 03:39
Location: STLMO

Re: Touchpad Not Working

Postby acimmarusti » 2009-06-13 13:10

maybe the automatic detection is broken. If so, make sure you have your touchpad and usb mouse correctly set up in your xorg.conf file.
Please post the contents of it here
acimmarusti
 
Posts: 393
Joined: 2009-02-27 04:59
Location: College Park, MD USA

Re: Touchpad Not Working

Postby ghostdawg » 2009-06-13 13:51

Okay, the mouse pointer moves using the touchpad but when I tap to open menus it is not working. I can't even do the right click to open the menu. It seems I'm not able to open up any windows to view the xorg.conf file.

With the usb mouse plugged in, the pointer doesn't move at all using it, but it does move with the touchpad. Any other suggestions? I sure don't want to reinstall but if need be I will.

Thnx.
Tower | Debian Testing & Mageia 1 | HP DX5150 AMD64 | 512gb | 40gb
AAO | Mandriva 2010.2 | Intel Atom | 1gb | 160gb
Mini Mac G4 | Debian & OSX | 1gb | 60gb
User avatar
ghostdawg
 
Posts: 1093
Joined: 2006-08-29 03:39
Location: STLMO

Re: Touchpad Not Working

Postby acimmarusti » 2009-06-13 14:42

I see...mmm...do you have a keyboard shortcut to open up a terminal/konsole ? if so, use it and open up one. In there use vim to open your /etc/X11/xorg.conf file.

If you don't know if you have one or simply don't have one set up, then press Alt + F1 to access the Applications menu.. (are you using gnome or KDE?, I believe this will work for either of them....but don't know about others like XFCE). Browse through the menu and open up a terminal/konsole. Now use vim to display your xorg.conf file. Edit it and add the following:

Code: Select all
Section "Module"
        .........................
   Load  "synaptics"
        Load "mouse"
EndSection

Section "ServerLayout"
        ..........................................
   InputDevice    "Generic Keyboard"
   InputDevice    "Synaptics Touchpad"
   InputDevice    "USB Mouse"
EndSection

Section "InputDevice"
   Identifier  "Generic Keyboard"
   Driver      "kbd"
   Option       "CoreKeyboard"
        ..................................
EndSection

Section "InputDevice"
   Identifier  "Synaptics Touchpad"
   Driver      "synaptics"
   Option       "SendCoreEvents" "true"
   Option       "Device" "/dev/psaux"
   Option       "Protocol" "auto-dev"
   Option       "SHMConfig" "true"
   Option       "HorizEdgeScroll" "0"
   Option       "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
   Identifier  "USB Mouse"
   Driver      "mouse"
   Option       "CorePointer"
   Option       "Device" "/dev/input/mice"
   Option       "Protocol" "Auto"
EndSection


The dots (...........) mean that there might be other stuff in these sections that you shouldn't touch!

If you don't know how to use vim, then you can find tutorials online, however, you'll only need to know just a few things to make this work.

Open xorg.conf with vim
Code: Select all
su
vim /etc/X11/xorg.conf


Press "insert" key to edit the file. Once your changes have been made press "escape" key and type ":w" (to save changes) and then ":q" (to quit)

After this you can either restart X (Ctrl + Alt + Backspace) or simply restart your computer (I usually prefer the latter)

I hope this works for ya
acimmarusti
 
Posts: 393
Joined: 2009-02-27 04:59
Location: College Park, MD USA

Re: Touchpad Not Working

Postby ghostdawg » 2009-06-13 15:26

Thanks for the reply. I was able to use Ctl-Alt-F4 to get to another console and I prefer nano as text editor. Vi gives me the blues.

I'll have to move the netbook near the tower because of no printer to print your suggestion on adding that code to xorg.conf. Which, by the way, my xorg.conf is one of those newer bare minimum xorg.conf, so I'll add it to mine and see what happens.

Thnx again.
Tower | Debian Testing & Mageia 1 | HP DX5150 AMD64 | 512gb | 40gb
AAO | Mandriva 2010.2 | Intel Atom | 1gb | 160gb
Mini Mac G4 | Debian & OSX | 1gb | 60gb
User avatar
ghostdawg
 
Posts: 1093
Joined: 2006-08-29 03:39
Location: STLMO

Re: Touchpad Not Working

Postby pendrachken » 2009-06-14 02:50

all you should have to do to get the touchpad working again is add the driver synaptics under the configured mouse line.

[/code]
Section "InputDevice"
Identifier "Configured Mouse"
Driver "synaptics"
[/code]

and make sure you have the xserver-xorg-input-synaptics package installed and updated, It may have gotten lost in your upgrade somehow.... for the other USB mouse plug it in and check dmesg to see if the USB driver is recognizing it.
fortune -o
Your love life will be... interesting.
:twisted: How did it know?

The U.S. uses the metric system too, we have tenths, hundredths and thousandths of inches :-P
pendrachken
 
Posts: 1049
Joined: 2007-03-04 21:10
Location: U.S.A. - WI.

Re: Touchpad Not Working

Postby ghostdawg » 2009-06-14 18:35

Thanks for the help. I got it sorted out by adding the lines to xorg.conf. I appreciate the help.
Tower | Debian Testing & Mageia 1 | HP DX5150 AMD64 | 512gb | 40gb
AAO | Mandriva 2010.2 | Intel Atom | 1gb | 160gb
Mini Mac G4 | Debian & OSX | 1gb | 60gb
User avatar
ghostdawg
 
Posts: 1093
Joined: 2006-08-29 03:39
Location: STLMO


Return to Hardware

Who is online

Users browsing this forum: No registered users and 7 guests

fashionable