change character encoding in xfce4 desktop

Kernels & Hardware, configuring network, installing services

change character encoding in xfce4 desktop

Postby forum4programs » 2009-07-16 22:25

Hi,

Can somebody help me how to change character encoding, so I can type more accurately. I don't have english keyboard, but the system use it.

Currently using stable lenny with xfce
forum4programs
 
Posts: 12
Joined: 2009-05-22 21:30

Re: change character encoding in xfce4 desktop

Postby garrincha » 2009-07-17 10:52

forum4programs wrote:Hi,

Can somebody help me how to change character encoding, so I can type more accurately. I don't have english keyboard, but the system use it.

Currently using stable lenny with xfce


IIRC, click on the main menu --> Settings --> keyboard --> layout ---> add (your country keyboard)
Maurice Green on Usain Bolt's 9.58: "The Earth stopped for a second, and he went to Mars."
User avatar
garrincha
 
Posts: 2341
Joined: 2006-06-02 16:38

Re: change character encoding in xfce4 desktop

Postby forum4programs » 2009-07-17 14:23

garrincha wrote:IIRC, click on the main menu --> Settings --> keyboard --> layout ---> add (your country keyboard)


Actually, I want to change current keyboard map to Finnish, currently using English.

What I have done to use finnish keyboard layout:
Code: Select all
dpkg-reconfigure locales
dpkg-reconfigure console-data


Nothing work :(
forum4programs
 
Posts: 12
Joined: 2009-05-22 21:30

Re: change character encoding in xfce4 desktop

Postby garrincha » 2009-07-17 14:44

forum4programs wrote:
garrincha wrote:IIRC, click on the main menu --> Settings --> keyboard --> layout ---> add (your country keyboard)


Actually, I want to change current keyboard map to Finnish, currently using English.

The method I suggested should work, at least for xfce4 desktop that you're using. When you click on main menu --> settings --> keyboard, click on 'layout' tab and deselect 'use system default' and click on 'add' button, a keyboard layout selection window will come up, from there you can choose 'Finland' and click 'o.k.' If in event that this doesn't work, log out of x and login to take effect.

For console, use dpkg-reconfigure console-data and select keymap from arch list - there should be Finnish listed.
Maurice Green on Usain Bolt's 9.58: "The Earth stopped for a second, and he went to Mars."
User avatar
garrincha
 
Posts: 2341
Joined: 2006-06-02 16:38

Re: change character encoding in xfce4 desktop

Postby forum4programs » 2009-07-17 15:17

garrincha wrote:
forum4programs wrote:
garrincha wrote:IIRC, click on the main menu --> Settings --> keyboard --> layout ---> add (your country keyboard)


Actually, I want to change current keyboard map to Finnish, currently using English.

The method I suggested should work, at least for xfce4 desktop that you're using. When you click on main menu --> settings --> keyboard, click on 'layout' tab and deselect 'use system default' and click on 'add' button, a keyboard layout selection window will come up, from there you can choose 'Finland' and click 'o.k.' If in event that this doesn't work, log out of x and login to take effect.

Cant find add-button anywhere.
Image



garrincha wrote:For console, use dpkg-reconfigure console-data and select keymap from arch list - there should be Finnish listed.

Yes, There is. - select keymap from arch list => qwerty => Finnish => standard
But it works only on tty console. :(
forum4programs
 
Posts: 12
Joined: 2009-05-22 21:30

Re: change character encoding in xfce4 desktop

Postby garrincha » 2009-07-18 10:03

What version of xfce4 you're using? I'm currently on Debian Squeeze and the xfce4 version is 4.6.1 (same as in Debian unstable):
After clicking on main menu: setting --> keyboard and then click on add to bring up the selection window:
Image
Maurice Green on Usain Bolt's 9.58: "The Earth stopped for a second, and he went to Mars."
User avatar
garrincha
 
Posts: 2341
Joined: 2006-06-02 16:38


Return to System configuration

Who is online

Users browsing this forum: No registered users and 9 guests

fashionable
cron