[SOLVED] Video doesn't want to sleep

Kernels & Hardware, configuring network, installing services

[SOLVED] Video doesn't want to sleep

Postby fabio85 » 2009-10-21 19:23

Hi there!
I have a problem with my laptop: video doesn't want to sleep! When I'm inactive the video is black but illumination is on: I have set it to sleep after 10 minutes, but nothing... I think that is a Gnome issue (it started at the beginning of summer with my old computer) because I changed PC and I have the same problem...
Some help?

Thank you!
Last edited by fabio85 on 2009-10-28 09:18, edited 3 times in total.
Debian Squeeze for AMD64
Toshiba A500-14F: Core Duo 2 P8700, ATI Mobility Radeon HD4650 with 1GB VRAM DDR3, 4GB RAM DDR2, 320GB Hard Disk
fabio85
 
Posts: 84
Joined: 2008-02-10 16:49
Location: Milan (Italy)

Re: Video doesn't want to sleep

Postby sacx » 2009-10-21 21:20

That means your monitor is not supporting DPMS or your Xorg server doesn't have it enabled ... Did you tried to force your monitor going in standby ?

Run this from a X console:

Code: Select all
xset +dpms
xset dpms force off
xset dpms force standby


Also you can read http://randomerror.wordpress.com/2009/10/21/quick-tip-x-server-standby/

Regards
User avatar
sacx
 
Posts: 30
Joined: 2006-03-24 11:08

Re: Video doesn't want to sleep

Postby fabio85 » 2009-10-24 16:11

Thank you for the reply! I had the 3 parameters set to 0... this is why my monitor didn't sleep!
Debian Squeeze for AMD64
Toshiba A500-14F: Core Duo 2 P8700, ATI Mobility Radeon HD4650 with 1GB VRAM DDR3, 4GB RAM DDR2, 320GB Hard Disk
fabio85
 
Posts: 84
Joined: 2008-02-10 16:49
Location: Milan (Italy)

Re: Video doesn't want to sleep

Postby fabio85 » 2009-10-25 17:57

But I have a problem: how can I set this parameters at boot and resume time? I followed the instructions in your link, but they don't work for me! I have the 3 parameters set to 0 at every boot!
Debian Squeeze for AMD64
Toshiba A500-14F: Core Duo 2 P8700, ATI Mobility Radeon HD4650 with 1GB VRAM DDR3, 4GB RAM DDR2, 320GB Hard Disk
fabio85
 
Posts: 84
Joined: 2008-02-10 16:49
Location: Milan (Italy)

Re: Video doesn't want to sleep

Postby hameau » 2009-10-25 19:08

Instead of using the gui setting tools for screensaver and power options, use gconf. It seems that the connection between the gui tools and gconf isn't always working correctly at present.

For example, I had to set apps/gnome-power-manager/backlight/dpms_method_ac to 'standby' to get my monitor to sleep properly.
Nick.
hameau
 
Posts: 257
Joined: 2008-11-13 17:42
Location: France

Re: Video doesn't want to sleep

Postby sacx » 2009-10-26 08:05

So this problem appears when you are under X ?

Regards
User avatar
sacx
 
Posts: 30
Joined: 2006-03-24 11:08

Re: Video doesn't want to sleep

Postby fabio85 » 2009-10-26 15:34

Instead of using the gui setting tools for screensaver and power options, use gconf. It seems that the connection between the gui tools and gconf isn't always working correctly at present.

For example, I had to set apps/gnome-power-manager/backlight/dpms_method_ac to 'standby' to get my monitor to sleep properly.

I tried to do this but nothing changed! But why Gnome is so buggy at present?!?!? I have heard that Sid is less buggy than Squeeze in the last time...

So this problem appears when you are under X ?

Yes, when I'm using X... if I set standby values, monitor will sleep after the right number of seconds, but it will erase this setup on next boot or suspend! I tried to create a startup script to set these numbers, but it seems that method is changed...
Code: Select all
update-rc.d -f avvio.sh start 99 2 3 4 5 .

What's the matter with this line of code? When I run it I receive these warnings:
Code: Select all
update-rc.d: using dependency based boot sequencing
insserv: warning: script 'K01avvio.sh' missing LSB tags and overrides
insserv: warning: script 'avvio.sh' missing LSB tags and overrides

I have always used this method... but now it doen't work...

I noticed one thing when I installed Debian on my new pc, and it can be important: I had not a xorg.conf!!! I created the file from zero to run fglrx drivers for my ATI video card! My xorg.conf now is:
Code: Select all
Section "Device"
    Identifier    "ATI"
    Driver        "fglrx"
EndSection

Section "Monitor"
    Identifier    "Configured Monitor"
    Option        "DPMS"   "true"
EndSection

Section "Screen"
    Identifier     "Default Screen"
    Monitor        "Configured Monitor"
    Device         "Configured Video Device"
    DefaultDepth    24
EndSection

Section "ServerLayout"
    Identifier       "Main Layout"
    Option        "BlankTime"     "10"     # Oscura lo schermo dopo 5 minuti (Fake)
    Option        "StandbyTime"     "11"    # Spegne lo schermo dopo 10 minuti (DPMS)
    Option        "SuspendTime"     "20"    # Sospende dopo 20 minuti
    Option        "OffTime"        "20"    # Spegne dopo mezz’ora
EndSection

Section "ServerFlags"
Option "blank time" "150"
Option "standby time" "300"
Option "suspend time" "600"
Option "off time" "1200"
Option "dpms" "true"
EndSection

I tried ServerLayout and ServerFlags alone, but nothing is changed...
Debian Squeeze for AMD64
Toshiba A500-14F: Core Duo 2 P8700, ATI Mobility Radeon HD4650 with 1GB VRAM DDR3, 4GB RAM DDR2, 320GB Hard Disk
fabio85
 
Posts: 84
Joined: 2008-02-10 16:49
Location: Milan (Italy)

Re: Video doesn't want to sleep

Postby bugsbunny » 2009-10-26 18:24

But why Gnome is so buggy at present?!?!?
Because they're in the process of transitioning to 2.28. It's not that buggy, most of the current glitches can be easily worked around. That are are glitches is, however, indisputable.
User avatar
bugsbunny
 
Posts: 5355
Joined: 2008-07-06 17:04

Re: Video doesn't want to sleep

Postby hameau » 2009-10-27 11:07

fabio85 wrote:
For example, I had to set apps/gnome-power-manager/backlight/dpms_method_ac to 'standby' to get my monitor to sleep properly.

I tried to do this but nothing changed!

It doesn't work for me since yesterday!

I have rolled back to gnome-screensaver 2.24.1-2+b1, which was the last version to control the monitor reliably (for me).
Nick.
hameau
 
Posts: 257
Joined: 2008-11-13 17:42
Location: France

Re: Video doesn't want to sleep

Postby fabio85 » 2009-10-28 09:18

I solved the problem passing to Sid... now my monitor sleeps properly!
Thank you for the help!
Debian Squeeze for AMD64
Toshiba A500-14F: Core Duo 2 P8700, ATI Mobility Radeon HD4650 with 1GB VRAM DDR3, 4GB RAM DDR2, 320GB Hard Disk
fabio85
 
Posts: 84
Joined: 2008-02-10 16:49
Location: Milan (Italy)


Return to System configuration

Who is online

Users browsing this forum: No registered users and 9 guests

fashionable