apt-get upgrade kernel issue

If none of the more specific forums is the right place to ask

apt-get upgrade kernel issue

Postby Jamesk5 » 2006-04-19 14:35

Two nights ago I ran: apt-get upgrade .. and let it run over night. In the process it upgraded the kernel (apparently) to the latest version.
I had been running "etch", until yesterday where it wont boot.
I've posted on linuxquestions.org and howtoforge.net and no one seems to be able to help me (or aren't just reading my posts).

Now I can no longer boot into debian and get the following error:

Begin: Waiting for root file system... ...
Done.
ALERT! /dev/hda1 does not exist. Dropping to shell!

BusyBox v1.01 (Debian 1:1.01-4) Built-in shell (ash)
Enter 'help' for a list of built-in commands.

/bin/sh: can't access tty; job control turned off
/ #



I can get into knoppix and see the drive fine, so the file system is still very much intact.

Here's a copy of my /boot/menu.lst (accessed via knoppix) as a search via google (and various forums) seems to match the error im getting to a problem in this file, in particular the initrd - but In my /boot/ directory I can't see an updated image file for the new kernel

# menu.lst - See: grub(8), info grub, update-grub(8)
# grub-install(8), grub-floppy(8),
# grub-md5-crypt, /usr/share/doc/grub
# and /usr/share/doc/grub-doc/.

## default num
# Set the default entry to the entry number NUM. Numbering starts from 0, and
# the entry number 0 is the default if the command is not used.
#
# You can specify 'saved' instead of a number. In this case, the default entry
# is the entry saved with the command 'savedefault'.
# WARNING: If you are using dmraid do not change this entry to 'saved' or your
# array will desync and will not let you boot your system.
default 0

## timeout sec
# Set a timeout, in SEC seconds, before automatically booting the default entry
# (normally the first entry defined).
timeout 5

# Pretty colours
color cyan/blue white/blue

## password ['--md5'] passwd
# If used in the first section of a menu file, disable all interactive editing
# control (menu entry editor and command-line) and entries protected by the
# command 'lock'
# e.g. password topsecret
# password --md5 $1$gLhU0/$aW78kHK1QfV3P2b2znUoe/
# password topsecret

#
# examples
#
# title Windows 95/98/NT/2000
# root (hd0,0)
# makeactive
# chainloader +1
#
# title Linux
# root (hd0,1)
# kernel /vmlinuz root=/dev/hda2 ro
#

#
# Put static boot stanzas before and/or after AUTOMAGIC KERNEL LIST

### BEGIN AUTOMAGIC KERNELS LIST
## lines between the AUTOMAGIC KERNELS LIST markers will be modified
## by the debian update-grub script except for the default options below

## DO NOT UNCOMMENT THEM, Just edit them to your needs

## ## Start Default Options ##
## default kernel options
## default kernel options for automagic boot options
## If you want special options for specific kernels use kopt_x_y_z
## where x.y.z is kernel version. Minor versions can be omitted.
## e.g. kopt=root=/dev/hda1 ro
## kopt_2_6_8=root=/dev/hdc1 ro
## kopt_2_6_8_2_686=root=/dev/hdc2 ro
# kopt=root=/dev/hda1 ro

## default grub root device
## e.g. groot=(hd0,0)
# groot=(hd0,0)

## should update-grub create alternative automagic boot options
## e.g. alternative=true
## alternative=false
# alternative=true

## should update-grub lock alternative automagic boot options
## e.g. lockalternative=true
## lockalternative=false
# lockalternative=false

## additional options to use with the default boot option, but not with the
## alternatives
## e.g. defoptions=vga=791 resume=/dev/hda5
# defoptions=

## altoption boot targets option
## multiple altoptions lines are allowed
## e.g. altoptions=(extra menu suffix) extra boot options
## altoptions=(recovery mode) single
# altoptions=(recovery mode) single

## controls how many kernels should be put into the menu.lst
## only counts the first occurence of a kernel, not the
## alternative kernel options
## e.g. howmany=all
## howmany=7
# howmany=all

## should update-grub create memtest86 boot option
## e.g. memtest86=true
## memtest86=false
# memtest86=true

## ## End Default Options ##

title Debian GNU/Linux, kernel 2.6.15-1-486
root (hd0,0)
kernel /boot/vmlinuz-2.6.15-1-486 root=/dev/hda1 ro
initrd /boot/initrd.img-2.6.15-1-486
savedefault
boot

title Debian GNU/Linux, kernel 2.6.15-1-486 (recovery mode)
root (hd0,0)
kernel /boot/vmlinuz-2.6.15-1-486 root=/dev/hda1 ro single
initrd /boot/initrd.img-2.6.15-1-486
savedefault
boot

### END DEBIAN AUTOMAGIC KERNELS LIST



Thanks very much!!
James
Jamesk5
 
Posts: 1
Joined: 2006-04-19 14:18

Postby Red » 2006-04-20 13:39

Hi,you may have a problem with your fstab file. Copy it here .
User avatar
Red
 
Posts: 69
Joined: 2006-04-20 12:36

Re: apt-get upgrade kernel issue

Postby guest » 2006-04-20 13:40

Jamesk5 wrote:Two nights ago I ran: apt-get upgrade .. and let it run
## ## End Default Options ##

title Debian GNU/Linux, kernel 2.6.15-1-486
root (hd0,0)
kernel /boot/vmlinuz-2.6.15-1-486 root=/dev/hda1 ro
initrd /boot/initrd.img-2.6.15-1-486
savedefault
boot

title Debian GNU/Linux, kernel 2.6.15-1-486 (recovery mode)
root (hd0,0)
kernel /boot/vmlinuz-2.6.15-1-486 root=/dev/hda1 ro single
initrd /boot/initrd.img-2.6.15-1-486
savedefault
boot

### END DEBIAN AUTOMAGIC KERNELS LIST



Thanks very much!!
James


In the menu.list you have same options twice? Which kernel do you have now?
guest
 

Postby Red » 2006-04-20 14:50

guest, this is normal!
User avatar
Red
 
Posts: 69
Joined: 2006-04-20 12:36

Postby Red » 2006-04-20 15:47

Boot with Knoppix. Then test this:
Code: Select all
$ su -
# fdisk -l
# fixmbr /dev/hda


Code: Select all
# mount -t ext3 -o rw /dev/hda1 /mnt


Code: Select all
# chroot /mnt
# grub-install /dev/hda for Grub
# /sbin/lilo for Lilo
#exit
#sync
User avatar
Red
 
Posts: 69
Joined: 2006-04-20 12:36

Postby Guest » 2006-04-26 09:58

I had the same problem with two machines and there seems to be some kind of problem related to initramfs-tools. I removed initramfs-tools and installed yaird (using chroot with livecd) and now the machines are booting again.
Guest
 

Postby Guest » 2006-04-26 11:10

I forgot to mention that the initrd image needs to be regenerated using yaird: yaird -o /boot/initrd.img-2.6.15-1-486 2.6.15-1-486.
Guest
 

Postby Nemo DX Zimmer » 2006-05-02 22:00

I just had the same problem with ETCH, and what I did was this:

booting live cd (knoppix)

opened up a shell and issued the following commands:

Code: Select all
su -
mount -t ext3 -o rw /dev/hda1 /mnt
chroot /mnt
apt-get update
apt-get upgrade


Now, for me the problem was that udev was not updated, and that might not be the case for someone else, but I fixed it simply with:

Code: Select all
apt-get install udev


rebooted the system, and everything is back to normal.

I tried the suggested yiard thingie, but it didnt work (due to my stupidness of course hehe, proc was not mounted), and I am happy I didnt succeed with that at the moment.

Hope this helps someone :)

//Nemo DX Zimmer //Esknetlabs
Nemo DX Zimmer
 

Postby Guest » 2006-05-09 01:06

I did the same thing with a MEPIS live CD and was able to boot successfully! Thanks for the information!
Guest
 

thanks

Postby dedeibel » 2006-05-12 08:11

Nemo DX Zimmer wrote:Now, for me the problem was that udev was not updated, and that might not be the case for someone else, but I fixed it simply with:

Code: Select all
apt-get install udev


Thank you very much. I Had the same Problem with Etch on AMD64. :D

dedeibel
dedeibel
 

apt-get install udev

Postby pelle » 2006-05-18 19:14

installing udev solved my issue as well
pelle
 

Postby Hygelac » 2006-05-21 02:12

Installing udev (by chrooting with DSL) was what I need too; thanks!
User avatar
Hygelac
 
Posts: 21
Joined: 2006-05-19 15:30
Location: Montréal, Québec

Alert ! /dev/hda1 does not exist (booting debian etch)

Postby Anat » 2006-05-27 10:31

Thanks a lot for this message : It works perfectly.

I have just one thing to add :

after
#mount -t ext3 -w /dev/hda1 /mnt
#chroot /mnt

I added this line to have apt-get working :

#mount -a

(because my others partitions (used by apt) where not mounted)

I hope it could help...

Sincerily.

Anat
Anat
 

Postby Guest » 2006-05-27 10:32

Thanks a lot for this message : It works perfectly.

I have just one thing to add :

after
#mount -t ext3 -w /dev/hda1 /mnt
#chroot /mnt

I added this line to have apt-get working :

#mount -a

(because my others partitions (used by apt) where not mounted)

I hope it could help...

Sincerily.

Anat
Guest
 

Postby Guest » 2006-05-27 16:08

Nemo DX Zimmer wrote:
Code: Select all
su -
mount -t ext3 -o rw /dev/hda1 /mnt
chroot /mnt
apt-get update
apt-get upgrade


Now, for me the problem was that udev was not updated, and that might not be the case for someone else, but I fixed it simply with:

Code: Select all
apt-get install udev



Thanks, this fixed the same problem for me. I thought I was going to have to reinstall everything. Upgrading to udev 0.091-2 did the trick.

Cheers!!
Guest
 

Next

Return to General Questions

Who is online

Users browsing this forum: No registered users and 11 guests

fashionable