Turn off system beep when I can't move cursor?

If none of the more specific forums is the right place to ask

Turn off system beep when I can't move cursor?

Postby coldReactive » 2010-03-29 16:27

It's annoying to get the system beep when I can't move the cursor anymore, is there a way to turn it off?
User avatar
coldReactive
 
Posts: 102
Joined: 2010-03-27 21:08

Re: Turn off system beep when I can't move cursor?

Postby idud » 2010-03-29 16:47

I use alsamixer from alsa-utils package. There's a channel named Beep or PC Beep. Mute it using "m" key.
User avatar
idud
 
Posts: 39
Joined: 2008-10-29 23:50
Location: Tasikmalaya, Indonesia

Re: Turn off system beep when I can't move cursor?

Postby Laurent » 2010-03-29 16:57

Or you could prevent the system beep loading by adding the pcspkr module in your blacklist at /etc/modprobe.d/
However, for some strange reason, that will not work (It least, it didn't work with me on squeeze)

But I found a possible solution (not tested yet) :wink:
http://ramblingfoo.blogspot.com/2007/01/how-to-disable-pcspkr-in-etch.html

Edit: I found a valuable solution :P
Add this two lines to your /etc/modprobe.d/blacklist.conf

Code: Select all
blacklist pcspkr
blacklist snd_pcsp


Apparently, the system beep module consists of 2 modules
User avatar
Laurent
 
Posts: 21
Joined: 2010-03-21 12:05
Location: Belgium

Re: Turn off system beep when I can't move cursor?

Postby coldReactive » 2010-04-02 12:19

idud wrote:I use alsamixer from alsa-utils package. There's a channel named Beep or PC Beep. Mute it using "m" key.


Sadly, the IBM T41 doesn't have that in alsamixer. laurent's fix worked though.
User avatar
coldReactive
 
Posts: 102
Joined: 2010-03-27 21:08

Re: Turn off system beep when I can't move cursor?

Postby s3a » 2010-04-05 20:35

In system, administration, sound or somewhere like that there is an option to remove beeping. Sorry, I cannot tell you exactly what to do at the moment because I am not on my Debian computer.
Use Mnemosyne to Study for School!
User avatar
s3a
 
Posts: 777
Joined: 2008-07-17 22:13

Re: Turn off system beep when I can't move cursor?

Postby coldReactive » 2010-04-05 23:23

s3a wrote:In system, administration, sound or somewhere like that there is an option to remove beeping. Sorry, I cannot tell you exactly what to do at the moment because I am not on my Debian computer.


I've already fixed it. :|

Also, I don't have gnome, I use openbox.
User avatar
coldReactive
 
Posts: 102
Joined: 2010-03-27 21:08

Re: Turn off system beep when I can't move cursor?

Postby carlp101 » 2012-04-22 16:02

I can confirm adding "blacklist pcspkr" to /etc/modprobe.d/blacklist.conf worked for me. You must restart for it to take affect. I run Linux Mint Debian Edition with XFCE on a Dell Studio 15 (1558).
carlp101
 
Posts: 1
Joined: 2012-04-22 15:58

Re: Turn off system beep when I can't move cursor?

Postby supertxiki » 2014-03-13 15:51

coldReactive wrote:Sadly, the IBM T41 doesn't have that in alsamixer. laurent's fix worked though.


In terminal view not all audio channels are visible, so you have to click the right arrow a few times until the channel "Beep" appears.
supertxiki
 
Posts: 1
Joined: 2014-03-13 15:44

Re: Turn off system beep when I can't move cursor?

Postby sanlav » 2014-03-13 16:32

I saw a lot of ... how I can put it instead of Stupid ? ... advices from 6 people here on how to turn these beeps Off.
Instead of you, I would simply google "beep codes" and maybe, just maybe, understood something.... ....
Mine are Allways ON.

EDIT: Depending on the BIOS code you get at startup there is an existing problem circumcircled by Debian OS and/or, most probably, an future unresolvable problem...
sanlav
 
Posts: 21
Joined: 2014-02-05 13:05


Return to General Questions

Who is online

Users browsing this forum: No registered users and 15 guests

fashionable