ntfs-3g mount: failed to open /dev/fuse: permission denied

If none of the more specific forums is the right place to ask

ntfs-3g mount: failed to open /dev/fuse: permission denied

Postby Laxman Neupane » 2010-05-19 18:03

Hi.

I cannot get access to my external hard disk. It says as in the "SUBJECT" above.

What should I do? I installed Debian XFCE testing. :D
User avatar
Laxman Neupane
 
Posts: 93
Joined: 2010-03-08 11:16

Re: ntfs-3g mount: failed to open /dev/fuse: permission denied

Postby Raffles10 » 2010-05-19 21:12

Are you a member of the 'plugdev' group ? If not add yourself:

Code: Select all
useradd -G plugdev <username>
Debian Squeeze + KDE 4.4.4 + AMD Athlon™ 64 X2 Dual Core Processor 6000 + nVidia GeForce 8600
User avatar
Raffles10
 
Posts: 192
Joined: 2008-12-09 16:36
Location: London, UK

Re: ntfs-3g mount: failed to open /dev/fuse: permission denied

Postby Laxman Neupane » 2010-05-20 04:39

Raffles10 wrote:Are you a member of the 'plugdev' group ? If not add yourself:

Code: Select all
useradd -G plugdev <username>


It says this:

Code: Select all
laxman@debian:~$ su -
Password:
root@debian:~# useradd -G plugdev laxman
useradd: user 'laxman' already exists
root@debian:~#


I think I am already in it.

What else should I try?
User avatar
Laxman Neupane
 
Posts: 93
Joined: 2010-03-08 11:16

Re: ntfs-3g mount: failed to open /dev/fuse: permission denied

Postby julian67 » 2010-05-20 04:49

Check you are in the group fuse. If not, add yourself and log out and in again.
Wisdom from my inbox: "do not mock at your pottenocy"
User avatar
julian67
 
Posts: 4648
Joined: 2007-04-06 14:39
Location: Just hanging around

Re: ntfs-3g mount: failed to open /dev/fuse: permission denied

Postby aspnair » 2010-05-20 05:05

Try "id" from your user shell. You could find all your current uid/gid and the groups you are associated
Compressed Air Energy Storage, Entropy and Efficiency
http://saurorja.org/2012/06/18/compress ... fficiency/
User avatar
aspnair
 
Posts: 1247
Joined: 2009-06-18 12:27
Location: Twitter: @anand_sivaram

Re: ntfs-3g mount: failed to open /dev/fuse: permission denied

Postby Laxman Neupane » 2010-05-22 04:12

aspnair wrote:Try "id" from your user shell. You could find all your current uid/gid and the groups you are associated



Code: Select all
laxman@lenny:~$ id
uid=1000(laxman) gid=1000(laxman) groups=20(dialout),24(cdrom),25(floppy),29(audio),44(video),46(plugdev),110(netdev),1000(laxman)
laxman@lenny:~$



This is what it says. I think there is no "fuse" group there.

:|
User avatar
Laxman Neupane
 
Posts: 93
Joined: 2010-03-08 11:16


Return to General Questions

Who is online

Users browsing this forum: No registered users and 23 guests

fashionable