errors while trying to install

Help with issues regarding installation of Debian

errors while trying to install

Postby dw5437 » 2010-07-05 21:33

What in the world does all this mean ? Trying to install lame.

Since release 150, udev requires that support for the CONFIG_SYSFS_DEPRECATED
feature is disabled in the running kernel.

Please upgrade your kernel before or while upgrading udev.

AT YOUR OWN RISK, you can force the installation of this version of udev
WHICH DOES NOT WORK WITH YOUR RUNNING KERNEL AND WILL BREAK YOUR SYSTEM
AT THE NEXT REBOOT by creating the /etc/udev/kernel-upgrade file.
There is always a safer way to upgrade, do not try this unless you
understand what you are doing!


dpkg: error processing /var/cache/apt/archives/udev_158-1_i386.deb (--unpack):
subprocess new pre-installation script returned error exit status 1
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LANG = "en_US.UTF-8"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LANG = "en_US.UTF-8"
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
Errors were encountered while processing:
/var/cache/apt/archives/udev_158-1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
debian:/home/dw5437# apt-get install lame
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
libpango1.0-0: Depends: libcairo2 (>= 1.8.10-3) but 1.6.4-7 is to be installed
libudev0: Depends: udev (= 158-1) but 0.125-7+lenny3 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

Any help appreciated.
dw5437
 
Posts: 19
Joined: 2006-08-13 19:59

Re: errors while trying to install

Postby dw5437 » 2010-07-05 21:59

Well now I cannot open a terminal or the update manager. Using 686 version with Dell Inspiron Quad Cpu at 2.50 GHz.
dw5437
 
Posts: 19
Joined: 2006-08-13 19:59

Re: errors while trying to install

Postby AnInkedSoul » 2010-07-05 22:05

looks like you have tried upgrading the system and b0rk3d it
AnInkedSoul
 
Posts: 461
Joined: 2010-06-11 05:05

Re: errors while trying to install

Postby dw5437 » 2010-07-05 22:47

Nope, didn't even try to upgrade. I installed brasero when I got the original error and then tried to down load lame from the command line when I got the same message again. Now I cannot access Synaptic and then the machine went to sleep and wouldn't wake up. I done a ctl+alt+del with no result and then Ctl+alt+backspace with no result. So I powered down and it refused to boot. Then I tried to reinstall with no boot result which is now why I am posting on Ubuntu which installed fine.
dw5437
 
Posts: 19
Joined: 2006-08-13 19:59

Re: errors while trying to install

Postby AnInkedSoul » 2010-07-05 22:49

cool....so problem solved I assume
AnInkedSoul
 
Posts: 461
Joined: 2010-06-11 05:05

Re: errors while trying to install

Postby craigevil » 2010-07-05 23:04

as root do
Code: Select all
touch /etc/udev/kernel-upgrade
is the solution to the udev error.

Or you can do what the all-knowing dpkg bot says:
As of <udev> 150 in squeeze, Linux kernel 2.6.27 or newer is required (i.e. upgrade kernel and udev at the same time).
If udev installation fails and you already have a squeeze kernel installed, then reboot into the new kernel and "aptitude -f install ; aptitude safe-upgrade" to continue. See http://bugs.debian.org/571255
Debian Sid KDE 4.8 Kernel 3.7 Thinkpad R40 Intel M 1.3 CPU 2GB RAM Radeon Mobility 7500
Debian - "If you can't apt-get something, it isn't useful or doesn't exist"
Giant Debian sources.list | Debian upgrade script smxi | sysinfo script inxi
User avatar
craigevil
 
Posts: 5149
Joined: 2006-09-17 03:17
Location: down the rabbit hole

Re: errors while trying to install

Postby dw5437 » 2010-07-05 23:32

Okay, thanks for the help. The only problem now is that Debian will not reinstall so I can get to the command line. If I ever get it to install again will try your idea. Many thanks
I really really don't want Ubuntu but that is all that works for now.
dw5437
 
Posts: 19
Joined: 2006-08-13 19:59

Re: errors while trying to install

Postby jheaton5 » 2010-07-06 01:10

dw5437 wrote:Okay, thanks for the help. The only problem now is that Debian will not reinstall so I can get to the command line. If I ever get it to install again will try your idea. Many thanks
I really really don't want Ubuntu but that is all that works for now.

Are you saying that the box will not boot from the hard drive, or it will not even boot from the install cd?
debian sid with kernel img 3.8.10 lxde no dm
User avatar
jheaton5
 
Posts: 1475
Joined: 2008-08-20 01:40
Location: Sharpsburg, GA, USA

Re: errors while trying to install

Postby dw5437 » 2010-07-06 04:48

It won't boot from either. I think my Motherboard or Dvd went south on me. I did take a direct hit from lightning on monday. Ubuntu is working flaky also but for now I can get online.
dw5437
 
Posts: 19
Joined: 2006-08-13 19:59

Re: errors while trying to install (solved)

Postby dw5437 » 2010-07-11 23:17

Thanks craigevil. reinstalled and working fine with your suggestion.
dw5437
 
Posts: 19
Joined: 2006-08-13 19:59


Return to Installation

Who is online

Users browsing this forum: No registered users and 11 guests

fashionable